Update broke Bluetooth Audio

There was an update to pulseaudio awhile ago. After the update my bluetooth broke again. Just like the last time. I tried doing the steps that fixed it the first time but it didn’t work.

Sure its pulse and not your shiny new 5.9 kernel?

Maybe. But had 5.9 since was available. BT was fine. I guess I should try going down. Thanks.

Ok, so I was about to try using 5.8. I booted up my laptop to check on work first before restarting and using 5.8, but for some reason bluetooth was working. Last night it wasn’t. But big shout out to @The_Quantum_Alpha for helping me out a lot.

1 Like

I had a similar issue after updates this morning. I could pair headsets just fine, but they would not connect. In the end it was an alternate pulseaudio bluetooth module I was running I used some time ago to be able to manually switch between bluetooth audio protocols. Anyway replaced package community/pulseaudio-modules-bt 1.4-3 with extra/pulseaudio-bluetooth 14.0-1. It seems this package is incompatible with pulseaudio 14.x

logs showed this:

src/service.c:btd_service_connect() a2dp-sink profile connect failed for AA:AA:AA:AA:AA:AA: Protocol not available

I also updated my audio driver in the morning. Now it’s working fine for me.