[Unstable Update] June 2024 Edition

Welcome to the new monthly unstable branch thread.

Recent News

Noticeable Package changes

NVIDIA 550.90.07-2: nvidia-drm parameters were set by default. Black Screen issues with Hybrid Systems

With the NVIDIA 550.90.07-2 packages, the nvidia-drm modeset=1 and fbdev=1 parameters were set by default. However that created issues with hybrid systems, which not using Nvidia at all for DRM. So we reverted that change.

You can verify the parameters are set by the following commands providing Y as output:

sudo cat /sys/module/nvidia_drm/parameters/modeset
sudo cat /sys/module/nvidia_drm/parameters/fbdev

Known Issues

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.


Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Check if your mirror has already synced:

2 Likes

It seems from the last KDE updates (it has beens a couple weeks I think, more or less) I can’t have the CPU monitoring widget (the one from KDE itself), along with some other similar monitoring widgets, to work properly, they do not display the usual graphs in the Panel. I tried a new user it is the same. I didnt find relevant logs, beside this

02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:46: TypeError: Cannot read property 'updateRateLimit' of null
02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:45: TypeError: Cannot read property 'totalSensors' of null
02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:41: TypeError: Cannot read property 'highPrioritySensorIds' of null
02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:33: TypeError: Cannot read property 'title' of null
02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:46: TypeError: Cannot read property 'updateRateLimit' of null
02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:45: TypeError: Cannot read property 'totalSensors' of null
02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:41: TypeError: Cannot read property 'highPrioritySensorIds' of null
02/06/2024 22:53	plasmashell	file:///usr/share/plasma/plasmoids/org.kde.plasma.systemmonitor/contents/ui/main.qml:33: TypeError: Cannot read property 'title' of null

before:

now:

If I click where it seems there is nothing, the widget properly show the popup with all the working information and graphs in the popup, but the Panel part doesn’t display the graph as it should.

Here, with intel CPUs, it’s working fine.

Open the widget config window and try to change some properties and apply them, then revert them and apply.

Then open ~/.config/plasma-org.kde.plasma.desktop-appletsrc, and search for the applet section which contains e.g title=Individual Core Usage

And check that saved settings are the same you changed in the GUI, especially updateRateLimit and chartFace.

The same issue with removing this file from TTY and logging in, or with new user.
I don’t know if it is related but there is no more Ksysguard on my system, only its library.

//EDIT: issue is not with Ksysguard but the CPU widget not displaying the graph in Panel.

is deprecated and should not be on your system.
(though there is apparently some plasma 6 port in the AUR)

It’s called ksysguard6-git, and it works. :wink:

:point_down:

2 Likes

I do not think.

The width of all bar chart widgets is a known bug due to lack of automatic scaling in the current KDE panel. The width is hard coded.
I changed the bar chart to a line chart that shows CPU usage history, but the width has not changed.

Maybe caused by my UHD-Monitor (4k) - incorrect hardware detection.
EDIT: not correct, “normal” monitor, other PC ==> the same error (is not really an error but a notice)

1 Like

It did work alright in Plasma 6.0.4, though — or that is to say, at least for the CPU load, because the memory load bar was too narrow.

The hard-coding was apparently introduced in 6.0.5.

I was sitting crying in my corner when they first removed ksysguard, as I had it configured for my GPU etc. and it was my go-to system monitor on GNOME. :rofl:

You guys made my day!

1 Like

Has anyone tried to install a 6.10-RC2 kernel with proprietary NVIDIA drivers? I want to understand the kernel modules cannot build for any driver or only on the test version 555.

1 Like

So you want the panel to automatically make enough space for you to see multiple data?

That widget can reside within any panel and also within the desktop, so if you set your widget to show a chart with many sensors, then it’s wise to move it from panel to desktop and resize it enough to see all data.

I would be also really interested, i need to install 6.10 RC2 because of this commit ata: ahci: Do not apply Intel PCS quirk on Intel Alder Lake - kernel/git/libata/linux.git - libata development tree

Since several months none of my SATA devices are detected from 6.7, and this is apparently the fix for that (because of Alder Lake cpu)

I know there is no nvidia modules built for RC kernel and i have no integrated intel graphics (due to Intel F serie) so i must use nvidia modules/drivers anyhow.

What if if we install dkms nvidia driver ?

Well, my question concerned DKMS modules (it may not be entirely clear), at the moment, as a result, the build of the module ends with an error.
I created a topic on the NVIDIA forum with this question, we will see what will be answered there.

I think it’s better to create a dedicated thread also here in the appropriate section

I’d imagine that one line patch will very soon get back-ported to earlier kernels, but in the meantime you could build a patched 6.9 kernel yourself if you’re up for it. Just make sure you have some kind of recovery option before installing it, I take no responsibilty :stuck_out_tongue:

$ git clone https://gitlab.manjaro.org/packages/core/linux69.git
$ cd linux69
$ curl -o 9999-alder_lake_ahci.patch https://git.kernel.org/pub/scm/linux/kernel/git/libata/linux.git/patch/?id=9e2f46cd87473c70d01fcaf8a559809e6d18dd50
$ sha256sum 9999-alder_lake_ahci.patch

Edit PKGBUILD, add 9999-alder_lake_ahci.patch to the end of sources, and the sum to the end of sha256sums, then run makepkg (which will take a while depending on your system - around 25 minutes on my 5800X with 32GB ram and MAKEFLAGS="-j$(nproc)" in /etc/makepkg.conf).

And when it’s all done you should have the packages

linux69-6.9.3-1-x86_64.pkg.tar.zst
linux69-headers-6.9.3-1-x86_64.pkg.tar.zst
1 Like

I do not think that there is a great sense in this, it is unlikely that someone, in addition to users of the unstable branch, are interesting to the RC kernel.
In any case, the user on the Nvidia forum shared a link to a patch that can fix the error, But unfortunately it involves the re -build of the kernel, which does not suit me

Hi, thank you for guiding me. I managed to generate the kernel.

Then, i installed it and force re-install nvidia drivers :

sudo pacman -U linux69-6.9.3-1-x86_64.pkg.tar.zst linux69-headers-6.9.3-1-x86_64.pkg.tar.zst
sudo mhwd -f -i pci video-nvidia

But, i cannot boot my system, it cannot reach graphical target.

I have the following errors in dmesg

nvidia: loading out-of-tree module taints kernel.
nvidia: module license 'NVIDIA' taints kernel.
Disabling lock debugging due to kernel taint
nvidia: module verification failed: signature and/or required key missing - tainting kernel
nvidia: module license taints kernel.
BPF: [123924] TYPEDEF  
BPF: type_id=6
BPF:  
BPF: Invalid name
BPF: 
failed to validate module [nvidia] BTF: -22
BPF: [123924] TYPEDEF  
BPF: type_id=6
BPF:  
BPF: Invalid name
BPF: 
failed to validate module [nvidia] BTF: -22
BPF: [123924] TYPEDEF  
BPF: type_id=6
BPF:  
BPF: Invalid name
BPF: 
failed to validate module [nvidia] BTF: -22
BPF: [123924] TYPEDEF  
BPF: type_id=6
BPF:  
BPF: Invalid name
BPF: 
failed to validate module [nvidia] BTF: -22

Do you have an idea of my issue ?

I am on kernel 6.6 right now, and i have snapshots so i am not stucked.


Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Looks like something to do with kernel module signing? I’m afraid I don’t own any NVIDIA hardware myself and I don’t really know much about those drivers or exactly what mhwd does when installing them. Maybe someone who does can help further…

1 Like

Update to the version 555.52.04 solved the problem.