[Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python

I just tried pamac upgrade used the wrong password and got the same message as you.I tried it again with the right password and it showed I needed updates.

My wired Ethernet isn’t working under 6.2.6-1.

I checked the output with lshw -C network and got an *-network UNCLAIMED for RTL8111/8168/8411.

driver / module was not loaded (probably r8169), you can try manually (# modprobe r8169 and watch journalctl) but the question remains why it didn’t on startup.
Same controller / kernel here, all is fine.

1 Like

Found the issue! I missed an error on pamac stating “bad return status for module build on kernel: 6.2.6-1-MANJARO”. So I rebuild r8168-dkms and everything is back on track. Thanks, @dragan, for checking, it saved me some debugging.

I’m having trouble with linux510 5.10.175-1. It hangs and won’t continue booting. 5.10.174-1 works fine.

Looks like it’s the same as here: [Testing Update] 2023-03-18 - Kernels, Thunderbird, Cinnamon, KDE-git, Python, Haskell - #3 by Oldhabbits

When update mkinitcpio:
“WARNING: Possibly missing firmware for module: ‘csiostor’”

I attempted a fix with mkinitcpio 35.1-3.

2 Likes

Not helping;
https://bbs.archlinux.org/viewtopic.php?id=284485

1 Like

mkinitcpio 35.1-4 should do the trick.

3 Likes

YES - it works -Thank You

1 Like

After upgrading from Kernel version 6.2.7-2 to 6.2.8-1, I get the error message:

$ journalctl --no-pager -p 3 -b --output=cat
spl: version magic '6.2.7-2-MANJARO SMP preempt mod_unload ' should be '6.2.8-1-MANJARO SMP preempt mod_unload '
spl: version magic '6.2.7-2-MANJARO SMP preempt mod_unload ' should be '6.2.8-1-MANJARO SMP preempt mod_unload '

It looks like version magic of spl doesn’t match kernel version.

$ modinfo spl
filename:       /lib/modules/6.2.8-1-MANJARO/extramodules/spl.ko.xz
version:        2.1.9-1
license:        GPL
author:         OpenZFS
description:    Solaris Porting Layer
srcversion:     0248BCBBFA4DFB290E4D2F0
depends:        
retpoline:      Y
name:           spl
vermagic:       6.2.7-2-MANJARO SMP preempt mod_unload

Solution:

  1. Uninstall linux62-zfs
  2. Install zfs-dkms. The error messages are gone. (But the ZFS module is not loaded.)

Edit:

OpenZFS 2.1.9 is not compatible with Kernel 6.2.8, because building the zfs module failed, but it has no issue with Kernel 6.2.7.

Solution:

Switch back to Kernel 6.1 LTS, no error message in journalctl :+1:

The known issue:

1 Like

:information_source: NVIDIA 530.41.03 drivers will be available shortly.

Note that there is now compatibility for Linux kernels with Indirect Branch Tracking (IBT). The ibt=off kernel parameter is no longer required.

VirtualBox still needs this kernel parameter when using Intel 11th CPU.

Why? More info, please?

Either way, that has nothing to do with the NVIDIA driver.

I tested VirutalBox on Intel11th CPU. If I removed this kernel parameter, then I still get the same issue as before:

1 Like

Thanks for the info. I’ll mention that in the next update post (probably Testing Updates). No need for a new Unstable Updates post probably until GNOME 44 is available.

6 posts were split to a new topic: Substring instead of substituted value after mkinitcpio update

Best solution for me:

I created a new KVM/QEMU to setup a small NAS with separate Kernel 6.1 LTS and ZFS that directly access my external physical disks as pass-through disks via PCI without virtual.

  • Host: Kernel 6.2 is now running on my PC without ZFS.
  • Guest: Kernel 6.1 LTS is running on my KVM with ZFS on the same PC.

Both communicate via a local NFS share (Speed ~31Gb/s). NFS preserves all file permissions :+1:, Samba does not.

They plan to have a proper fix for this in the 2.1.10 release, see this comment on that issue.

1 Like

:warning: Please make a backup and test grub 2.06.r456.g65bc45963-1.
There should be no issues on EFI systems. The main thing is making sure it still works with Legacy BIOS.

1 Like