[Unstable Update] 2022-04-07 - GNOME 42, Mesa 22.0.1, Octopi 0.13.0, KDE-git, Haskell

This Packages are dropped from Repo.:

$ pacman -Qm
gnome-icon-theme 3.12.0-6
gnome-icon-theme-symbolic 3.12.0-6
qpdfview 0.4.18-2

Oh that’s sad. I didn’t know it was that old and unmaintained.
Is there are a similarly simple pdf viewer with the same features?


xreader seems to be a better and maintained alternative. This is after trying 8 pdf viewers…


After today’s update, the search function in gnome overview is no longer working. It was working before today’s update.

Can’t reproduce, check your extensions.

1 Like

Thanks. Seems to be the “User theme” extension that is causing the problem. Fixed after I disabled this one.

I’ve found the source of the issue. Your current package does not include the version addition in the .json file, hence the extension is shown as out of date, even with the applied patch.

I’ve updated the PKGBUILD with upstream fixes to version 10.4 and can confirm the tray is working again.

 PKGBUILD | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/PKGBUILD b/PKGBUILD
index fee27fc..76034aa 100644
@@ -4,10 +4,10 @@
 pkgname=('pamac-cli' 'pamac-gtk' 'pamac-gnome-integration')
 pkgdesc="A Package Manager based on libalpm with AUR and Appstream support"
 arch=('x86_64' 'aarch64')
@@ -18,10 +18,9 @@ options=(!emptydirs !strip)
-        'gnome-shell-extension.patch'
+        #'gnome-shell-extension.patch'
-            '25a4cb7906aeed14c196deeeb6cc6e6bd9f91610bf947ec355944bf09e38aa16')
 prepare() {
   mv "$srcdir/pamac-$_commit" "$srcdir/pamac-v$_pkgver"

1 Like

gdm 42.0+r11+g4a52f026 showing black screen, reverting to 42.0-1 solves the issue.

There’s a very similar issue on EndeavourOS forums, the solution links to GDM+Wayland+nvidia wiki article. Basically, this should solve it:

# ln -s /dev/null /etc/udev/rules.d/61-gdm.rules

Was about to suggest the same.
qpdfview and xreader are the most decent PDF viewers. Sad to see qpdfviewer go.
Foxit reader is pretty decent as well, but the last version is old and it doesn’t scale at all with 125/150/175% scaling.

1 Like

Why? You are now stuck with the objectively awful looking adwaita.

Talking about that inconsistent, amateurish, disgusting theme…

I have seen a few decent GTK4 themes being used through ~/.config/gtk-4.0/
I used one of these and am attempting by a massive amount of trials and a huge deal of errors to replicate Matcha-sea (default Manjaro theme) look and feel for legacy libadwaita-powered GTK4 applications, so that the default Gnome 42 Manjaro experience for libadwaita-enforced apps is at least a bit more modern and consistent throughout as many applications as possible.

This is a big endeavour and I will report if I can eventually manage something interesting.

1 Like

How long to reach stable branch?

Screenshot from 2022-04-15 17-27-19

brightness icon issue, i tried with turned off all extension but still same error i got

Gnome 42…
No issues on Manjaro,
BUT on Ubuntu 21.10 and then 22.04 - Digital Spooking -
I had to clean the application-caches (with Stacer)…

Try removing manjaro-gdm-theme package along with any themes applied to the gdm user.

And the Package Maintainer spake, saying, “Thou shalt not upgrade from pacman-mirrors 4.23.2-2 to 4.23.2-3. 4.23.2-2 shalt be the the version thou shalt keep, and the number of the version shall be 4.23.2-2. 4.23.2-4 shalt thou not upgrade to. 4.23.2-5 is right out.”

:bomb: :boom:

:angel: :musical_note:


After switching to the unstable branch, updating everything from it and rebooting, Gnome shell crashed after a few minutes use.

Turning off all extensions, logging out and in and everything has been fine so far.

It is simple: Gnome 42 finally uses libadwaita, the only UI design officially supported. Let’s see what the wider user community comes up with to bring their beloved theming back. For developers it might be easier only to concentrate their UI design on Adwaita.

1 Like

Trying to get there.
It’s a slow process though. And a hack.

Here’s what I have gotten to, it’s still not even alpha and full of inconsistencies, but it’s a start.



Let Gnome be Gnome and see how it goes

1 Like