[Unstable Update] 2021-12-13 - Python 3.10 Rebuilds

they were released as frequently as well. surely must be for obvious reasons, than when its not. no reasons to complain if its that serious anyway.

https://cdn.kernel.org/pub/linux/kernel/v5.x/#:~:text=ChangeLog-5.15.10%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2017,14%3A24%20%20%20%201019

and we are in unstable branch afterall, sooner we have nothing to alarm functionally, the other branches can get them as well (the last changelog is lenghthy)

I guess you’re talking about this?

1 Like

@Yochanan Has libreswan been removed? I went to install networkmanager-l2tp which has libreswan as a recommended dependency, but such package is missing in the repo.

libreswan has always been in the AUR and so was networkmanager-l2tp until last February. I’ll let the Arch package maintainer know he forgot to import libreswan along with it.

EDIT: The maintainer decided to drop libreswan from optional dependencies instead of importing it. :man_shrugging:

2 Likes

Perhaps, GRUB update involved.

PC boot up directly after grub menu: `error: sparse file not allowed`

After

the update
~/Desktop ❯ tail -n18 /var/log/pacman.log
[2021-12-26T08:17:41+0300] [PAMAC] synchronizing package lists
[2021-12-26T08:18:32+0300] [ALPM] transaction started
[2021-12-26T08:18:33+0300] [ALPM] upgraded opencv (4.5.4-11 -> 4.5.5-1)
[2021-12-26T08:18:33+0300] [ALPM] upgraded gmic (3.0.0-2 -> 3.0.0-3)
[2021-12-26T08:18:33+0300] [ALPM] warning: /etc/default/grub installed as /etc/default/grub.pacnew
[2021-12-26T08:18:33+0300] [ALPM] upgraded grub (2.06-1 -> 2.06-2)
[2021-12-26T08:18:33+0300] [ALPM-SCRIPTLET] :: Grub does no longer support side-loading modules when secure boot is
[2021-12-26T08:18:33+0300] [ALPM-SCRIPTLET]    enabled. Thus booting will fail, unless you have an efi executable
[2021-12-26T08:18:33+0300] [ALPM-SCRIPTLET]    'grubx64.efi' with bundled modules.
[2021-12-26T08:18:33+0300] [ALPM] upgraded gst-plugins-bad-libs (1.18.5-3 -> 1.18.5-4)
[2021-12-26T08:18:33+0300] [ALPM] upgraded gst-plugins-bad (1.18.5-3 -> 1.18.5-4)
[2021-12-26T08:18:33+0300] [ALPM] upgraded mlt (7.4.0-1 -> 7.4.0-2)
[2021-12-26T08:18:33+0300] [ALPM] upgraded mlt6 (6.26.1-7 -> 6.26.1-8)
[2021-12-26T08:18:34+0300] [ALPM] transaction completed
[2021-12-26T08:18:34+0300] [ALPM] running '30-systemd-update.hook'...
[2021-12-26T08:18:34+0300] [ALPM] running '90-packagekit-refresh.hook'...
[2021-12-26T08:18:34+0300] [ALPM] running 'texinfo-install.hook'...
[2021-12-26T08:29:31+0300] [PAMAC] synchronizing package lists

I got ordinary


but immediately after it the

If to press any key, booting proceeds fine (sddm, user session, etc.).

The message is absent in

~/Desktop ❯ journalctl -b | grep -i "sparse"                          
~/Desktop ❯ journalctl -b | grep -i "not allowed"
~/Desktop ❯
cat /etc/default/grub
~/Desktop ❯ cat /etc/default/grub           
(...)

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

(...)

I have btrfs encrypted setup.


GRUB version in boot menu does not match grub package version

Compare
image
with the

~/Desktop ❯ pamac info grub | grep "Ver"
Version               : 2.06-2

Going back to the issue above, it appears to happen only with kernel series 5.15 every time my system boots up from a restart. If I previously power off my system and then I boot it up again with kernel 5.15, then I will be able to manage Bluetooth devices from Gnome Settings. This odd behaviour was introduced for me after this major update, although it never happens with kernel series 5.10.

No big deal, but still I think it’s worth reporting this in case someone else experiences the same in future releases for the other branches.

Updated inxi output below (truncated) for further reference :slightly_smiling_face:

System:
  Kernel: 5.15.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: root=UUID=59c46027-8f73-4e0e-a52e-825f3df72c29 rootfstype=xfs
    add_efi_memmap acpi_osi='Windows 2020' lsm=lockdown,yama,apparmor,bpf
    audit=1 initrd=\initramfs-5.15-x86_64.img
  Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 7559 v: 1.3.1
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0H0CC0 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.3.1 date: 12/02/2018
...
Memory:
  RAM: total: 15.5 GiB used: 6.86 GiB (44.3%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S
    family: 6 model-id: 0x5E (94) stepping: 3 microcode: 0xCC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 2911 high: 2995 min/max: 800/3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2995 2: 2918 3: 2900
    4: 2900 5: 2900 6: 2900 7: 2900 8: 2877 bogomips: 41621
...
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:191b class-ID: 0300
  Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Dell driver: nouveau
    v: kernel bus-ID: 02:00.0 chip-ID: 10de:139b class-ID: 0302
  Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB
    driver: uvcvideo bus-ID: 1-4:2 chip-ID: 1bcf:28b0 class-ID: 0e02
  Display: wayland server: X.org 1.21.1.2 compositor: gnome-shell driver:
    loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa
    display-ID: 0 resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.11-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
...
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-5:3 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
...
Info:
  Processes: 406 Uptime: 26m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1263 lib: 343
  flatpak: 0 Shell: Zsh v: 5.8 running-in: kitty inxi: 3.3.11

EDIT: I found a very similar issue on the arch forum. Still not resolved there though.

This is due to using a filesystem grub cannot write e.g. f2fs and btrfs.

Remove the save last entry from /etc/default/grub - and the message is gone.

1 Like
The `error: sparse file not allowed` issue was fixed

Changed the line to

# GRUB_SAVEDEFAULT=true

ran

sudo update-grub

and rebooted PC: the message was not shown.
So I unveiled the issue while merging .pacnew and in the same time “improving” my “/etc/default/grub” settings.
Thank you, Frede!


The report of version mismatch in the GRUB menu vs grub package remains.

You need to reinstall grub: not the package but the boot loader (from currently installed package).

2 Likes

lib32-systemd didn’t get updated to 250 like the other systemd packages @Yochanan

It was fixed. My lib32-systemd package was updated this morning.

Systemd (250-2)Problem (?) while copying (using Nemo) some >1 GiB files to USB-drive:

Dez 27 13:21:08 kernel: INFO: task kworker/u64:5:233 blocked for more than 122 seconds.
Dez 27 13:21:08 kernel:       Not tainted 5.15.11-1-MANJARO #1
Dez 27 13:21:08 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Dez 27 13:23:11 kernel: INFO: task kworker/u64:5:233 blocked for more than 245 seconds.
Dez 27 13:23:11 kernel:       Not tainted 5.15.11-1-MANJARO #1
Dez 27 13:23:11 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

Yeah I had a suspicious soft lockup of Dolphin when I was copying a big file to a NFS network location two days ago, kinda similar issue too. The floating notification froze but copying was actually performed without failure. Copying the same file from network location to USB drive didn’t cause any freezes at all.
I also haven’t found any meaningful info in logs…

1 Like

@Yochanan Will libxml2 package be rebuild against python 3.10.x release? It is still dropping some python 2.7 libs.

It already was, but today Python 2 is dropped completely. See today’s news: libxml2>=2.9.12-6 update may require manual intervention

1 Like

I’ve tested here with sudo pacman -U https://archlinux.org/packages/extra/x86_64/libxml2/download and no issues associated to the update. No leftovers either.

I didn’t have any issues updating, either. :man_shrugging:

There’s a quite outdated package in the repo: darch-run, which depends on linux53. Only found out about its existence cos I ran pacman -F /etc/mkinitcpio.d/linux.preset.
(edit: @philm is the packager)

A post was split to a new topic: Systemd-oomd issues

@Yochanan has kernel module ntfs3 dropped for linux515 (5.15.12-1-MANJARO)

$ lsmod | grep ntfs

returns empty

if yes, is this due to a tentative issue?