[Unstable Update] 2021-01-17 - Kernels, Powerline-Go, Mutter, Python

I have User Themes and go with the stock Manjaro dark theming, which doesn’t seem to have been effected at this point. I’m relatively new to Gnome (it took a while for me to realize it’s my favorite, after 20 years of XFCE, KDE and all the others), but I’ve heard that even if a particular extension is not enabled, having it installed can cause problems when Gnome moves from one version to another. I imagine it could also have something to do with graphics hardware, etc.

Already disabled all extensions, changed to 5.11 (At this point I can discard a kernel issue), so far no more crashes.

Yes, on two systems. It appears the gjs 2:1.68.0-2 update affected more than one extension. Downgrading to 2:1.66.2-1 solved the issue.

EDIT: FS#70117 - [gjs] 2:1.68.0-1 causes GNOME session to crash when Element and gajim are started together


total fail with this update … I have to restore snapshot to be able to boot, is starting to roll in Gnome 40, but something is not ok and all screens are flickering mess, intel iGPU + Nvidia on laptop.

edit: all extension are disabled, app drawer is flickering like crazy and writing on top without clear
edit 2: background is rendered as transparent, no matter what I select as picture in settings

edit3: gnome-tweaks is not starting at all

мар 26 12:56:45 org.gnome.tweaks.desktop[31386]: Traceback (most recent call last):
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:   File "/usr/lib/python3.9/site-packages/gtweak/app.py", line 29, in do_activate
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:     self.win = Window(self, model)
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:   File "/usr/lib/python3.9/site-packages/gtweak/tweakview.py", line 59, in __init__
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:     self._model.load_tweaks(self)
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:   File "/usr/lib/python3.9/site-packages/gtweak/tweakmodel.py", line 107, in load_tweaks
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:     mods = __import__("gtweak.tweaks", globals(), locals(), tweak_files, 0)
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:   File "/usr/lib/python3.9/site-packages/gtweak/tweaks/tweak_group_font.py", line 104, in <module>
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:     FontXSettingsTweak(),
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:   File "/usr/lib/python3.9/site-packages/gtweak/tweaks/tweak_group_font.py", line 32, in __init__
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:     self.btn_full.set_active(self.settings["hinting"] == "full")
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:   File "/usr/lib/python3.9/site-packages/gi/overrides/Gio.py", line 259, in __getitem__
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]:     raise KeyError('unknown key: %r' % (key,))
мар 26 12:56:45 org.gnome.tweaks.desktop[31386]: KeyError: "unknown key: 'hinting'"


Same here

  Kernel: 5.10.23-1-MANJARO x86_64 bits: 64 Desktop: sway 1.5.1 
  Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: X556UQK v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X556UQK v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X556UQK.313 date: 03/13/2018 
  ID-1: BAT0 charge: 10.7 Wh (33.2%) condition: 32.2/38.0 Wh (84.7%) 
  volts: 7.6 min: 7.6 
  Info: Dual Core Intel Core i5-7200U [MT MCP] speed: 870 MHz 
  min/max: 400/1400 MHz 
  Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: nouveau v: kernel 
  Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo 
  Display: wayland server: X.Org compositor: sway driver: 
  loaded: intel,nouveau unloaded: modesetting resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  driver: ath10k_pci 
  Local Storage: total: 1.03 TiB used: 18.31 GiB (1.7%) 
  Processes: 223 Uptime: 7m Memory: 11.59 GiB used: 2.05 GiB (17.7%) 
  Shell: Zsh inxi: 3.3.03 

Same problem with Gnome 40 update here as well, lots of flickering in app drawer. It might be a nvidia problem or it might be a manjaro problem, not sure.

When it comes to Gnome-tweaks, it needs to be updated to new version but its still in beta.

1 Like

I am using prime offload so Gnome is running on iGPU

So, flickering issues in iGPU and Nvidia?

I think that problem is connect with theme, but I am not entirely sure

I suspected the same thing and tried new Materia theme, which has a support for Gnome40.
Problem is not with theme.

I also tried gnome-shell-dev and Gnome 40 isos from github in the past and didn’t experience any flickering/layering there…

It doesn’t seem to be gpu-related, since the problem only occurs within the app drawer.

I might try gnome-shell40alfa from aur.

You can try, but at this point it’s about Manjaro’s integration of Gnome 40.

40.beta-0 is now pushed.


Problem of flickering gone with the latest manjaro-gdm-theme update.

Another thing I notice with gnome-shell40alfa package from chaotic aur is that it requires js68 instead of js78. Is this important? Is there a problem with packaging of Manjaro or Arch?


Confirmed on my end. Big Thanks @Manjaro-Team

confirm flickering gone and tweak is working as expected now

caffeine is not compatible with gnome 40, it is not starting by default and when try to enable it

gnome-shell[1827]: JS ERROR: Exception in callback for signal: icon: TypeError: gicon is undefined

It’s not a problem with Caffeine, it’s gnome-shell-extension-appindicator. Fixed with 36-1.