[Unstable Update] 2020-12-12 - BREAKAGE EXPECTED - Kernels, KDE Apps 20.12, Gstreamer, Qt6, Boost, Haskell

This looks like an additional item to be appended to grub:

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically

Plus this but otherwise :ok_hand:

I see nfs4 problems with systemd 247.2.

Dez 18 21:16:45 jupiter kernel: NFS4: Couldn't follow remote path
Dez 18 21:16:45 jupiter kernel: FS-Cache: Duplicate cookie detected
Dez 18 21:16:45 jupiter kernel: FS-Cache: O-cookie c=000000004fe5139c [p=000000006020211c fl=222 nc=0 na=1]
Dez 18 21:16:45 jupiter kernel: FS-Cache: O-cookie d=000000001ed8c2c0 n=00000000ace35359
Dez 18 21:16:45 jupiter kernel: FS-Cache: O-key=[16] '040000000200000002000801c0a81734'
Dez 18 21:16:45 jupiter kernel: FS-Cache: N-cookie c=00000000c6c239c4 [p=000000006020211c fl=2 nc=0 na=1]
Dez 18 21:16:45 jupiter kernel: FS-Cache: N-cookie d=000000001ed8c2c0 n=00000000f78392e3
Dez 18 21:16:45 jupiter kernel: FS-Cache: N-key=[16] '040000000200000002000801c0a81734'

systemd 247.1-4 works fine.

I had this when my NFS3-only share was mounted without nfsvers=3 option in fstab.

The new pamac in unstable branch does not show the AUR updates.

It says no updates in the pamac, but the indicator just shows me that there is a new update.

What does the software mode mean?

I seldom use the GUI of pamac. pamac upgrade should work.
EDIT: My mirror was not up to date, and I hadn’t received pamac 10.0 upgrade when posting this comment.

pamac upgrade -a

like i’ve said AUR updates are ignored with -a switch with pamac 10.0

ex: pamac checkupdates -a

1 Like

Oh! reding is helpfull.
Formerly the -a switch meant “check aur” too.
Upps: software mode does not show ignored (blocked) updates. A feature.
pamac update -h
Aktualisiere dein System

pamac upgrade,update [Optionen]

–force-refresh : Aktualisierung der Datenbanken erzwingen
–enable-downgrade : Paketdegradierung einschalten
–disable-downgrade : Installieren älterer Paketversionen deaktivieren
–download-only, -w : Lade alle Pakete herunter ohne etwas zu installieren/aktualisieren
–ignore <Paket(e)> : Ignoriere Paketaktualisierung, mehrere Pakete können angegeben werden indem sie mit einem Komma getrennt werden
–overwrite : Konfliktdateien überschreiben, mehrere Muster können angegeben werden indem sie mittels Komma getrennt werden
–no-confirm : alle Bestätigungsmeldungen umgehen
–aur, -a : aktualisiere auch Pakete die von AUR installiert wurden
–no-aur : Pakete aus dem AUR nicht aktualisieren
–devel : auch Entwicklungspakete erneuern (nutze --aur)
–no-devel : Entwicklerpakete nicht aktualisieren
–builddir : Build-Verzeichnis (benutzen mit --aur), wenn kein Verzeichnis angegeben wurde, wird das in der pamac.conf-Datei verwendet
pamac upgrade, update [options]

–force-refresh: Force database update
–enable-downgrade: Activate package downgrade
–disable-downgrade: Disable installing older package versions
–download-only, -w: Download all packages without installing / updating anything
–ignore <package (s)>: Ignore package update, multiple packages can be specified by separating them with a comma
–overwrite : Overwrite conflicting files, multiple patterns can be specified by separating them with commas
–no-confirm: bypass all confirmation messages
–aur, -a: also update packages installed by AUR
–no-aur: Do not update packages from the AUR
–devel: also renew development packages (use --aur)
–no-devel: Do not update developer packages
–builddir : Build directory (use with --aur), if no directory is specified, this will be used in the pamac.conf file

quote=“koshikas, post:15, topic:43602, full:true”]
a very tiny update.

pamac (both pamac-cli & pamac-gtk) has LOST ability check for AUR updates it seems. I have double checked that AUR is enabled in pamac configuration.

we know … needs rebuild with api … its being done.


Thank You!

Progress messages are not getting displayed properly.
No message for linux510 started directly got the message linux510 finished.

The software mode in GUI disables AUR support so if you have packages installed from AUR, you should not use it.

1 Like

I’m not using the software mode.

It’s still not working after pamac is updated.

Try to refresh databases from the menu


Thanks, it’s working now.

A post was split to a new topic: Wi-Fi driver crashing with net hook

19dec libilbc has been updated to version 3.x.x, but some apps need libilbc.so.2 for running (discord/ksysguard/etc). Need to create shared link for new lib (i added it handly)