Unlock after long time locked


(KDE/ssdm) Have you tried using the virtual keyboard during login?
Maybe that will give you some clues about the login problem & password.



I have yes, and unfortunately it does the same.

It just happened again. This time while I was on the login/unlock screen, I tried to login with the TTY on Alt + F2. No luck. :cry:

I’m strongly considering just formatting everything and starting from scratch. Just when I got it the way I like it too. sigh

You may be able to avoid reinstallation by creating a new user and copying your files from the problematic account to the new account.

And so you get out of the doubt if the problem is your whole KDE/Manjaro system or just your current user’s problem.


Than you @MrE! I haven’t thought of that. It should help to narrow down the problem, if nothing else.

Now I’m considering using Deja dup (or something similar if there are suggestions) to backup my files & setting from the current user, creating a new user and restoring the backup for it. Would that work? (Mainly so I can get the settings transferred. Most of my data is stored on a separate hard drive.)

I have never used deja dup, and actually, when I have had to restore my configuration, I do it manually: from a full backup I copy what I want to keep. *Until I discovered that my problems were created by bauh snap/??? applications that didn’t update the application menu correctly.


Edit: the issue not was not caused by bauh, but some kind of app that need to update the menu launcher/start menu.


This happened to me too. I clicked the “switch users” button/option and after that, I can re-login.


Thank you @antman!

I’ll give it a go when it happens again!

Cool, thanks @MrE! Just thought I’d do it manually yesterday evening. Because if it’s some sort of error with the user, it might be copied with the backup as well, where the chance is much lower if I do it manually.


So it just happened again, so I tried this and it works. Immediately after logging in, I checked and there was no one else logged in. Finding this funny, I checked with root too, and found the same.

I also checked and none of the processes I deliberately left running (firefox, skype, etc.) seemed to be running. Leading me to think that somehow, for some reason, the session gets ended while idle.

I’ll have to check when I get the chance, which won’t be until tomorrow, at the earliest.

1 Like

There are a lot of PAM login problem discussion on the forum:

But you need live USB to manjaro chroot-ing, and so on. Don’t forget to backup first.

1 Like

Hi @antman,

Thanks for this.

I don;t see myself as a beginner user. Rather somewhere in the more “advanced middle”. Although when I read this type of thing, it makes me feel like a complete newbie. So I’m not comfortable with that kind of thing. I’d rather wait a bit for the update, or failing that, just reinstall.

But, that’s probably just me.

1 Like


So yesterday there was quite a big update. Unfortunately I was unable to catch if there was anything PAM-related in, but I assume there was. IIRC the update was round about 1.5GB.

I hoped that would fix my locking problem. Alas, it seems to have persisted. I’m now seriously considering trying a new user.

Any advice?

That is always a good option. It would also be an indication that the problem exists in your home directory, rather than in the system area. :wink:

Exactly my reasoning as well! So I’m seriously considering it.

1 Like

If it’s PAM related, you could try reinstalling all the packages that own anything in /etc/pam.d:

sudo pacman -S $(pacman -Qoq /etc/pam.d)

I’ll try that as well.


Just did this.

a Little bit after, it happened again. So I don’t know what it is, but it seems safe to say it’s not this.

Thank you anyway!

Can you show: cat /etc/pam.d/system-login

Here you go:


auth       required   pam_shells.so
auth       requisite  pam_nologin.so
auth       include    system-auth

account    required   pam_access.so
account    required   pam_nologin.so
account    include    system-auth

password   include    system-auth

session    optional   pam_loginuid.so
session    optional   pam_keyinit.so       force revoke
session    include    system-auth
session    optional   pam_motd.so          motd=/etc/motd
session    optional   pam_mail.so          dir=/var/spool/mail standard quiet
-session   optional   pam_systemd.so
session    required   pam_env.so           user_readenv=1