Unlock after long time locked

Hi guys,

As previously mentioned in another thread, I have used Linux on and off for many years, finally switching to Manjaro last year permanently and wiping my Windows partition. I haven’t looked back and at this stage I’m not going back. I’m in love with Manjaro KDE for my PC. (And Ubuntu server, for, well, servers.)

As things are I’m a little bit annoyed with one thing. I’m hoping to sort it out because it wasn’t there and then, suddenly, it was! And no, I’m unable to recall if something changed or happened that might be causing this.

Whenever I lock my PC, which is whenever I’m not in front of it, for an extended period of time (e.g. when I go to lunch) and get back, I am unable to unlock it. I get the “Incorrect password” (Or something like that) message when I try. The result being that I have to do a hard reset and log in from scratch. When I test the lock by locking and logging in immediately, it works like a charm.

I have tried many things. None of which I can remember at this moment. I even, at some stage, thought it might be my new splash screen so changed it back. To no avail. I’m now considering figuring out how to reinstall SDDM (or whatever handles the locking and unlocking.

I’m using The latest Manjaro with KDE Manjaro KDE (Version 5.19) and Linux kernel version 5.4.

Any advice?

Hi, do you know if you have a different language/keyboard setting into the session and at the logon screen?

1 Like

And I did have an issue with numlock when I tried KDE. If your password has numbers, and if you type them with the numpad, is the num lock active at logon screen?

Hi there,

Now that you mention it, I remember that it was one of the first things i checked. As far as I could tell, everything seems fine. Although I’m the first to admit I might have missed something, so if you’d like me to run a command and give you the output, I’d do so with pleasure.

The password is alpha-numerical, but I don’t use the Numpad. I have a Roccat keyboard, if that makes any difference.

A hard reset is seldom needed in GNU/Linux. There are several more graceful things you can try first, i.e…:

  1. Switch to a different virtual console ─ also commonly referred to as a tty ─ by pressing Ctrl+Alt in combination with one of the F1…F6 keys. In the KDE Plasma edition, Ctrl+Alt+F2 will do. There, you can log in with your usual credentials, and then you’ll have a separate command-line login session running from which you can kill stuck processes or cleanly reboot the system. You log out of a tty with Ctrl+D, and you can return to the GUI session by pressing Alt+F1 ─ for the XFCE and GNOME editions, this is a different F-key.

  2. The Magic SysRq keys. Press and hold both the Alt key and the PrtSc|SysRq key, and while keeping them pressed down, tap the following key sequence, leaving approximately one second between each key press…: R, E, I, S, U, B.

This key sequence goes directly to the kernel and will cleanly terminate all running processes, kill the stuck processes, flush the buffers, remount all filesystems in read-only mode to prevent any corruption, and then hard-reboot the machine by resetting the processor.

There are several mnemonics you can use for memorizing the keys and the order they should be pressed in, i.e.:

  • It’s the word “busier” spelled backwards.
  • Raising Elephants Is So Utterly Boring.”
  • Reboot Even If System Utterly Broken.”

The above all said, are you using a battery-powered wireless keyboard? If so, such keyboards put themselves to sleep after a certain timeout of inactivity, and it usually takes a key press to wake them up again, but then that first key press won’t be transmitted to the receiver.

1 Like

Hi @Aragorn,

Thank you very much for the information. I know it’s very seldom the answer for things, but that was according to my knowlege and capabilities.

I do not use a wireless keyboard. Tried it. Didn’t like it. Went back to wired. The same with my mouse.

I’m embarrassed to admit that I would probably not be able to follow number 2 in your instructions. Because, due to a motor vehicle accident, I have a very hard time coordinating my movements. Thus to me typing is slow and that will probably not work, then.

So number 1 looks better to me. I’ll give it a go after lunch if it does it again.

2 Likes

You can do it slower ─ up to five seconds between each key press, I believe ─ but the reason why I mention one second is because most of those keys will provide some feedback by way of the drive activity light on the computer chassis, telling you that it is ─ for instance ─ flushing the buffers, even if the console screen remains locked up, and many people just hammer away on their keyboards without paying attention to that. :wink:

AAAH. Thank you. It does make sense. I’ll try and give it a go at some stage.

Thank you!

1 Like

Update:

It just now started doing the same thing for upgrading packages.

It did this in the terminal. I opened system update and tried there, even copying and pasting the password from somewhere, and then making sure it’s correct and it did this.

I’m starting to think it’s a problem in the authentication mechanism.

Have you updated your system recently? (Manjaro must be kept up-to-date.)

There was an issue with authentication, introduced with the latest update, because of a change in the configuration of PAM, needed by the newest version of the PAM framework. PAM is the authentication framework in most UNIX systems.

You have to tend to any .pacnew files created under /etc/pam.d/ and merge them with the existing files, if applicable.

Hi @Aragorn,

I update my Manjaro daily, so yes, it has been updated recently.

I have just checked with ls /etc/pam.d/*.pa as well as ll /etc/pam.d/*.pa as root and I get nothing. no matches found: /etc/pam.d/*.pa

I also get the same when I do a ls /etc/pam.d/*.*, so I browsed to the directory with midnight commander and was unable to find any files with the .pacnew extension.

Um, if you’re on Stable, then there are no daily updates. The last Stable update as I’m writing this was on the 28th of August 2020, and there probably won’t be another one for about one or two weeks, because updates are always bundled together, unless there’s an urgent security update.

That syntax is wrong ─ it won’t give you any results, because you’re looking for files whose name ends in .pa. The files we’re talking about have a name that ends in .pacnew.

That’s a DOS’ism. :wink: In UNIX, …

ls /etc/pam.d/

… suffices, or even…

ls /etc/pam.d/*

Okay, so that then rules out the PAM update. What about a mechanical failure in the keyboard?

Hi @Aragorn,

I just double-checked again, just to make 110% sure and no, nothing with either ls /etc/pam.d/*.pacnew or ll /etc/pam.d/*.pacnew.

I really don’t think it’s the keyboard, because:

  1. It’s not even a year old; and
  2. at all other times it works perfectly. And I type a lot. I can honestly say this is THE best keyboard I’ve ever had.
1 Like

Have you the same password between your current user and the administrator?

Hi @Falav,

Yes, I am the only user of my computer, so yes, the root and current user has the same password.
(Also because, I’m ashamed to say, I usually can’t tell them apart when using the computer. Yes, I know how stupid that is. Trust me when I say, I’m not happy about it either)

Did you try to launch the TTY console from logon screen as advised by @Aragorn? To know if you type “in clear” your password if all the characters are correct? In the hypothesis that some key bindings change from session to logon screen…

As a recent user myself, I put also the same credentials for my user and root :shushing_face: for convenience…

2 Likes

Yes, I understand that completely. Howerver, I meant that I check for updates and update every day if there are updates, so yes, I’m updated.

I don’t. They are distinctly different passwords, and I even have sudo set up to require the target user’s password, as opposed to my regular user’s password. :wink:

Not yet. I’ll have to keep the instruction(s) on my tablet and do it from with that open and available, because there’s absolutely no way I’ll be able to remember them.

I have made absolutely sure the password is correct. Even copied and pasted it once, no difference.

The same passwords is just a convenience, I know. But it’s a strong password, so it’s all good. (It’s an alpha-numeric Latin phrase, so I think it’s quite strong.)