Unlock after long time locked

I have never used deja dup, and actually, when I have had to restore my configuration, I do it manually: from a full backup I copy what I want to keep. *Until I discovered that my problems were created by bauh snap/??? applications that didn’t update the application menu correctly.


Edit: the issue not was not caused by bauh, but some kind of app that need to update the menu launcher/start menu.


This happened to me too. I clicked the “switch users” button/option and after that, I can re-login.


Thank you @antman!

I’ll give it a go when it happens again!

Cool, thanks @MrE! Just thought I’d do it manually yesterday evening. Because if it’s some sort of error with the user, it might be copied with the backup as well, where the chance is much lower if I do it manually.


So it just happened again, so I tried this and it works. Immediately after logging in, I checked and there was no one else logged in. Finding this funny, I checked with root too, and found the same.

I also checked and none of the processes I deliberately left running (firefox, skype, etc.) seemed to be running. Leading me to think that somehow, for some reason, the session gets ended while idle.

I’ll have to check when I get the chance, which won’t be until tomorrow, at the earliest.

1 Like

There are a lot of PAM login problem discussion on the forum:

But you need live USB to manjaro chroot-ing, and so on. Don’t forget to backup first.

1 Like

Hi @antman,

Thanks for this.

I don;t see myself as a beginner user. Rather somewhere in the more “advanced middle”. Although when I read this type of thing, it makes me feel like a complete newbie. So I’m not comfortable with that kind of thing. I’d rather wait a bit for the update, or failing that, just reinstall.

But, that’s probably just me.

1 Like


So yesterday there was quite a big update. Unfortunately I was unable to catch if there was anything PAM-related in, but I assume there was. IIRC the update was round about 1.5GB.

I hoped that would fix my locking problem. Alas, it seems to have persisted. I’m now seriously considering trying a new user.

Any advice?

That is always a good option. It would also be an indication that the problem exists in your home directory, rather than in the system area. :wink:

Exactly my reasoning as well! So I’m seriously considering it.

1 Like

If it’s PAM related, you could try reinstalling all the packages that own anything in /etc/pam.d:

sudo pacman -S $(pacman -Qoq /etc/pam.d)

I’ll try that as well.


Just did this.

a Little bit after, it happened again. So I don’t know what it is, but it seems safe to say it’s not this.

Thank you anyway!

Can you show: cat /etc/pam.d/system-login

Here you go:


auth       required   pam_shells.so
auth       requisite  pam_nologin.so
auth       include    system-auth

account    required   pam_access.so
account    required   pam_nologin.so
account    include    system-auth

password   include    system-auth

session    optional   pam_loginuid.so
session    optional   pam_keyinit.so       force revoke
session    include    system-auth
session    optional   pam_motd.so          motd=/etc/motd
session    optional   pam_mail.so          dir=/var/spool/mail standard quiet
-session   optional   pam_systemd.so
session    required   pam_env.so           user_readenv=1

Ok then, it’s not that. :stuck_out_tongue:
No clue then. Maybe try setting password again with passwd… Also, as already suggested, add new user and copy stuff over.

Just tried this and the output was something in the line of “password not different”, as can be seen below:

╰─➤  passwd
Changing password for mirdarthos.
Current password: 
New password: 
Retype new password: 
The password has not been changed.
New password: 
Retype new password:

Have also created a new user. The sane thing seems to happen to it. In fact, it happened on the first login try. So I’m relatively certain whatever it is, it’s system wide and not limited to my user only.

Do you, perhaps, know what is the command for getting the last reason for the session ending? I just want to see if there’s something that might give me a clue.

But as things stand now, I’m reinstalling over the weekend…


OK, so I’ve decided that I’ll be reinstalling it this weekend if I can’t fix it tonight. Which is a quite possibility.

However, something else that might give someone a clue as to what’s happening occurred a bit ealier:
I was unable to sudo in a currently logged in session, reaffirming my belief that it’s got something to do with thee authentication mechanism. I don’t know, I might be wrong about that, but that is my reasoning of what and why.

You can always search with journalctl.

Btw, there are some updates now and I see ‘shadow’ among them. Check if it fixes anything by mistake. :stuck_out_tongue: