Unknown device type nvme0n1 (two ssd)

I have two ssd, one sata and one nvme, i installed windows to sata and manjaro to nvme, but nvme not showing on boot menu, i installed windows to nvme then showing on boot menu, no fast boot, sata ahci, but i use to as storage nvme disk and showing on bios menu but i said not showing boot menu. i tried many times, when i entered detect grub menu then i seen showing there on live manjaro on usb, also i tried
then i got this message
unkown device type: nvme0n1
what/how will i do?

Hello and welcome!

Could you first provide what system you are running?

inxi -Fazy

Please post it as code with ``` at the first line and the last :wink:

Peek 2020-09-13 19-04

Thank you :wink:

Please, provide also output of:

sudo parted -l
sudo efibootmgr -v
lsblk -f

Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64
root=UUID=64d2ff0d-8db0-4697-8f92-d523cd187300 rw quiet apparmor=1
security=apparmor resume=UUID=33f3e916-d659-4e91-9744-ce0dbc791dc9
Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Type: Laptop System: Acer product: Aspire E5-575G v: V1.47 serial:
Mobo: Acer model: Ironman_SK v: V1.47 serial: UEFI: Insyde v: 1.47
date: 09/06/2018
ID-1: BAT1 charge: 28.1 Wh condition: 28.1/41.4 Wh (68%) volts: 17.0/14.8
model: PANASONIC AS16A5K type: Li-ion serial: status: Full
Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: D6
L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 21607
Speed: 748 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
4: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI Aspire E5-575G
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916
Device-2: NVIDIA GM107 [GeForce 940MX]
vendor: Acer Incorporated ALI Acer Aspire E5-575G driver: nouveau v: kernel
bus ID: 01:00.0 chip ID: 10de:179c
Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus ID: 1-7:5
chip ID: 04f2:b573
Display: x11 server: X.Org 1.20.8 driver: intel,nouveau
unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0.0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5")
diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.7
direct render: Yes
Device-1: Intel Sunrise Point-LP HD Audio
vendor: Acer Incorporated ALI Acer Aspire E5-575G driver: snd_hda_intel
v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71
Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:0fbc
Sound Server: ALSA v: k5.8.6-1-MANJARO
Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel port: 4000 bus ID: 03:00.0
chip ID: 168c:0042
IF: wlp3s0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI Acer Aspire E5-575G driver: r8169 v: kernel
port: 3000 bus ID: 04:00.1 chip ID: 10ec:8168
IF: enp4s0f1 state: down mac:
Device-3: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb
bus ID: 1-5:4 chip ID: 04ca:3015
Local Storage: total: 471.36 GiB used: 7.00 GiB (1.5%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HBHQ-00000
size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 serial: rev: EXH7201Q scheme: GPT
ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 3B6Q scheme: GPT
ID-1: / raw size: 221.11 GiB size: 216.64 GiB (97.98%) used: 7.00 GiB (3.2%)
fs: ext4 dev: /dev/nvme0n1p2
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.06 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3
System Temperatures: cpu: 59.0 C mobo: N/A gpu: nouveau temp: 49 C
Fan Speeds (RPM): N/A
Processes: 197 Uptime: N/A Memory: 15.51 GiB used: 863.2 MiB (5.4%)
Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1082 lib: 336
flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 250GB
Sektör boyutu (mantıksal/fiziksel): 512B/512B
Disk bölümü Tablosu: gpt
Disk Bayrakları:

Numara  Başlangıç  Son    Boyut   Dosya sistemi  İsim                          Bayraklar
 1      1049kB     106MB  105MB   fat32          EFI system partition          önyükleme, esp
 2      106MB      123MB  16,8MB                 Microsoft reserved partition  msftres
 3      123MB      250GB  249GB   ntfs           Basic data partition          msftdata
 4      250GB      250GB  531MB   ntfs                                         gizli, diag

Model: SAMSUNG MZVLB256HBHQ-00000 (nvme)
Disk /dev/nvme0n1: 256GB
Sektör boyutu (mantıksal/fiziksel): 512B/512B
Disk bölümü Tablosu: gpt
Disk Bayrakları: 

Numara  Başlangıç  Son    Boyut   Dosya sistemi   İsim  Bayraklar
 1      2097kB     317MB  315MB   fat32                 önyükleme, esp
 2      317MB      238GB  237GB   ext4
 3      238GB      256GB  18,3GB  linux-swap(v1)        takas
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0000,2001,2002,2003
Boot0000* Windows Boot Manager	HD(1,GPT,456a59f6-dacd-4be2-994e-fae9adb8a92d,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Unknown Device: SAMSUNG MZVLB256HBHQ-00000	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-25-38-81-01-C7-06-76)/HD(1,GPT,04701889-1d22-4f41-b079-0fbb923bf5c0,0x1000,0x96000)RC
Boot0002* USB HDD: TOSHIBA TransMemory	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(1,MBR,0x0,0x53b7f4,0x2000)RC
Boot0006* USB HDD: SanDisk	PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(2,GPT,bb3a52b7-6c2e-4c25-b9a9-ea656b3ab092,0x1ca3534,0x400)RC
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

├─sda1 vfat FAT32 56F5-C6AF
├─sda3 ntfs B2A2F69CA2F6646F
└─sda4 ntfs F83A634A3A63054A
├─nvme0n1p1 vfat FAT32 CBEE-60C0 299,1M 0% /boot/efi
├─nvme0n1p2 ext4 1.0 64d2ff0d-8db0-4697-8f92-d523cd187300 198,6G 3% /
└─nvme0n1p3 swap 1 33f3e916-d659-4e91-9744-ce0dbc791dc9 [SWAP]

it’s a known issue

1 Like

That line is harmless and triggered by /etc/grub.d/60_memtest86+.
That file can even be safely removed on any UEFI system: it will only generate a memtest grub entry on legacy BIOS systems.


when i’m this remove then will show boot menu?

I have some bad news. Looking up your computer model on internet gives a long list of people with the same problems. It seems that the UEFI firmware is not able to boot by default anything else than Windows. The only option seems to be adding grub64.efi to the Secure Boot as explained here:

Other option maybe is to install Windows and Manjaro in Legacy BIOS mode

i removed this then exec update-grub
but still not showing boot menu, something other?

windows and ubuntu installed same storage device? because i tried same ssd, not problem. i have different ssd, problem on nvme :confused:

You are saying that you don’t see the GRUB menu when you start up the system?

What is the output of cat /etc/default/grub

To be clear you have a dual boot system, windows and Manjaro?

Did you select the Manjaro ssd in your BIOS as your startup device?

Are you saying that if you install Manjaro (or any Linux) in your SSD in UEFI mode, you can boot Manjaro and you can see grub?

What then if you try to install Manjaro’s grub to /dev/sda1? besides Windows. Does that make any difference? But of course root would be on the nvme

i said two ssd in my system, both plugged, windows installed on sata and manjaro installed on nvme (both samsung), windows/sata ssd showing bios boot menu but nvme not showing bios boot menu, i enter manjaro installed system from detect efi systems option on manjaro installed usb

This is a known “problem.” The warning is known to be erroneous and I’ve only seen it with Manjaro, not other distros. My device reports “unknown device mmcblk2p1” which is my ESP partition on my baytrail device, but it boots fine. My laptop also reports “unknown device nvme0n1” when I updated grub in Manjaro. If you can boot to the OS of your choice you can ignore the “warning”! Or disable the memtest as suggested in the archived thread or in an earlier post.

that not problem, install, show and enter the system, only problemon nvme :confused:
i said above i can enter manjaro installed system from detect efi systems option on manjaro installed usb

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=33f3e916-d659-4e91-9744-ce0dbc791dc9 udev.log_priority=3”

If you want to enable the save default function, uncomment the following

line, and set GRUB_DEFAULT to saved.


Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

Uncomment to enable booting from LUKS encrypted devices


Uncomment to use basic console


Uncomment to disable graphical terminal


The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command ‘videoinfo’


Uncomment to allow the kernel use the same resolution used by grub


Uncomment if you want GRUB to pass to the Linux kernel the old parameter

format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”


Uncomment to disable generation of recovery mode menu entries


Uncomment and set to the desired menu colors. Used by normal and wallpaper

modes only. Entries specified as foreground/background.


Uncomment one of them for the gfx desired, a image background or a gfxtheme


Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE=“480 440 1”

legacy bios mode does badly affect performance? i want to learn much thing but my english is bad :confused: