Unble to convince my Raspberry Pi4 boot into Manjaro 20.06

I’ve tried both the XFCE and the Plasma versions. I my several attempts, I have used both the Raspberry Pi disk imager software as well as Bolena Etcher to flash my sd cards. I’ve followed along with various YouTube videos step by step trying to figure out where I’m going wrong. Yes, I did make sure that I was using the correct edition for the Raspberry Pi 4. This isn’t unique to Manjaro though as I have tried several different OSes and Raspberry Pi OS and Ubuntu Server are the only ones that I been able to get working. Anyway, I’m approaching my whits end here. Any suggestions?

Have you checked to see if there is anything wrong with your SD card? is it a SD card you already have or new?

My I’ve been using two new SD cards.

Did either of those work?

Did you SHA1 hash the image file?
xfce hash is: 6d6fe2412653f4d3faedc0cfe8be1b299c236e39
kde-plasma hash is: 7bdcbbe04f7e7d56a702c9813c17738fdd5a4792

I flashed the latest Manjaro-ARM-20.08 XFCE release yesterday with out any issues with Etcher. Is there a reason you are flashing 20.06?

Manjaro ARM 20.08 released!

I’m having the same issue on the Pi 4. I’ve been unable to get any edition of Manjaro to boot after the initial install is completed. All other Pi supporting distros have worked fine. It freezes at the initial boot somewhere around starting the bluetooth service, or login management.

The OP may have meant 20.0.8, as I just downloaded 20.0.6 from the archives, and it installed perfectly. All 20.0.8 builds however will not boot for me. Going to try a system update and update you all from here.

After running a system update, all seems to be working. For some reason however, a fresh install from 20.0.8 will not work for me.

Unfortunately, they did not.

20.0.6 is what was avilable when I downloaded it. I’ll download 20.0.8 right now.

I just tried 20.0.8 and, well, no joy.
I have been using Etcher to flash my SD cards. Is there another imaging program that I should be using?

You have never said anything than you can not get it to boot so I have no clue what is going on over there. There would be so many questions as to what it may or may not be doing. like does it ever show anything on the screen, Can you ssh to it, have you tried swapping hdmi ports on the board…

I have downloaded the same image and had no issue installing and running it.

As an FYI @Strit checked and as of yesterday and 9721 rpi4 images have been downloaded so far in August.

I had a problem booting Manjaro on RasPi4. Not sure if this helps. but…

My problem was that the display I was using (an old SamSung HDMI TV Monitor) was not recognized, so I only saw a black screen.

I tried a number of options in edits of ‘config.txt’.

Here is what worked for me.

See /boot/overlays/README for all available options

Also /www.raspberrypi.org/documentation/configuration/config-txt/video.md

initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4



i have the same. issue. I reach a boot hang at " “Reached target bluetooth” and no green flashing. Tried to see if it was the keyboard. Still wasn’t successful. I believe a have flashed my card about 3 times. I have a Raspberry PI 8GB

Tried above with fresh install 20.0.6 and actually worked. I guess its just the latest that’s bugged.

I have had this every time with 20.08.
Just leave it alone. Give it 3 to four mins and it will pick up.

( I installed 20.08 i3 on 3x rpi4’s the other day, same every time).

It installs fine though, just be a little patient, I found.

And it’s always the Bluetooth where it hangs around for a while.

Hope this helps even if it’s not ideal.

Hi Darksky,

I’ve been downloading the images, flashing them to my sd cards, using Bolena Etcher or the Raspberry Pi imager, and attempting to boot using that image. All I have gotten was a blank screen that is unresponsive to my inputs even after waiting several minutes. I’ve been using the same sd cards which seem to work fine with Raspberry Pi OS and Ubuntu Server (Mate).
If there was something wrong with my Pi or my sd cards, I would think that my Pi wouldn’t boot with anything. I’m afraid this is the best information that I have. I’m not sure that my description paints a clearer picture. I’ve been at real loss here. I did see some suggestions down below concerning my display that I will try when I get the chance.

Success! I’m using my Raspberry Pi right now to write this. Thanks for all of your responses as they got me thinking about the potential issues. Special thanks to KendDickey whose reply caused me to look at how the signal was getting to my monitor. As it turned out, I was plugged into the wrong HDMI port for Manjaro. I do intend to edit the file so I can use the first port.
Again Thanks all.

Nice one @KL2IE, it’s good to see a bit of Success now and then.
Ras Pi and Manjaro are a brilliant combination.
I think Manjaro should be on the offical list of Ras Pi Distro’s.

:slight_smile: :+1:

I had the same problem, then plugged into Ethernet, and away it went install complete. I had the same issue with Fedora 32 but gave up, no I know, install with Ethernet if possible. Hope that helps

1 Like

I had the same issue and plugging in ethernet worked a treat, booted straight into setup. Had left it for 45 mins stuck on the Bluetooth line :+1:t2: