Unable to update manjaro-xfce-settings

Hello to all, I have made this post because I recently made the switch from Windows to Linux. I thought it would be a good idea to have a dualboot with Windows 11 for gaming and Manjaro for everything else. Upon installing I went to go update my system, everything was going smoothly until I was met with this error. If anyone has a fix for this it would be greatly appreciated.

Thanks,
Paranoid

Error:

[user@main ~]$ sudo pacman -Syy
:: Synchronizing package databases...
 core                                          166.6 KiB   925 KiB/s 00:00 [##########################################] 100%
 extra                                        1859.8 KiB  7.09 MiB/s 00:00 [##########################################] 100%
 community                                       7.0 MiB  13.4 MiB/s 00:01 [##########################################] 100%
 multilib                                      174.5 KiB   992 KiB/s 00:00 [##########################################] 100%
[user@main ~]$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                                          166.6 KiB  1022 KiB/s 00:00 [##########################################] 100%
 extra                                        1859.8 KiB  6.83 MiB/s 00:00 [##########################################] 100%
 community                                       7.0 MiB  19.2 MiB/s 00:00 [##########################################] 100%
 multilib                                      174.5 KiB  1283 KiB/s 00:00 [##########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "qt5-styleplugins", a dependency of "manjaro-xfce-settings"
:: The following package cannot be upgraded due to unresolvable dependencies:
      manjaro-xfce-settings


Possibly you have installed Manjaro with an outdated ISO. qt5-styleplugins is no longer part of the official repo. Remove it.

Or just ignore it at this update process:

pamac update --force-refresh --no-aur --ignore manjaro-xfce-settings,qt5-styleplugins

It is a meta-package anyway:

Name                  : manjaro-xfce-settings
Version               : 20220204-2
Description           : Manjaro Linux XFCE Settings
URL                   : https://gitlab.manjaro.org/profiles-and-settings/manjaro-xfce-settings
Licenses              : GPL
Repository            : community
Installed Size        : 127.3 kB
Groups                : --
Depends On            : illyria-wallpaper manjaro-base-skel manjaro-icons matcha-gtk-theme noto-fonts
                        papirus-maia-icon-theme qt5ct xcape xcursor-breeze
Optional Dependencies : --
Provides              : manjaro-desktop-settings manjaro-xfce-gtk3-settings manjaro-xfce-gtk3-minimal-settings
Replaces              : manjaro-xfce-gtk3-settings
Conflicts With        : manjaro-desktop-settings manjaro-xfce-gtk3-settings
Packager              : Mark Wagie <mark@manjaro.org>
Build Date            : Fri Feb  4 19:24:02 2022
Validated By          : MD5 Sum  SHA-256 Sum  Signature

qt5-styleplugins has been replaced by qt5ct.

I’m getting the same error.
My iso is from april.
And I’ve been constantly updating, only thing I’ve not updated is the kernel because I want to stick to lts.

This error is due to qt5-styleplugins being a dependency of Manjar-xfce-minimal-settings which is in turn a dependency to Manjaro-xfce-settings.

I think that qt5-styleplugins has been shifted to aur and hence I’ll have to manually install it.

No, qt5-styleplugins is important for gtk2. Since gtk2 is no longer used and is replaced by gtk3, it needs another platform theme for GTK.

So how do I go ahead from here ?

After update everything expect the ignored ones, update again.

Preparing...
Synchronizing package databases...
Refreshing core.db...                                                           
Refreshing extra.db...                                                          
Refreshing community.db...                                                      
Refreshing multilib.db...                                                       
Refreshing core.files...                                                        
Refreshing extra.files...                                                       
Refreshing community.files...                                                   
Refreshing multilib.files...                                                    
Resolving dependencies...                                                       
Warning: cannot resolve "qt5-styleplugins", a dependency of "manjaro-xfce-minimal-settings"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'qt5-styleplugins' required by manjaro-xfce-minimal-settings
pamac remove qt5-styleplugins
pamac remove qt5-styleplugins
Error: target not found: qt5-styleplugins

I see it now:

Branch         : unstable
Repository     : community
Name           : manjaro-xfce-minimal-settings
Base           : manjaro-xfce-settings
Version        : 20220204-2
URL            : https://gitlab.manjaro.org/profiles-and-settings/manjaro-xfce-settings
Licenses       : GPL
Groups         : None
Provides       : manjaro-desktop-settings  manjaro-xfce-gtk3-minimal-settings
Depends On     : illyria-wallpaper  manjaro-base-skel  manjaro-icons  matcha-gtk-theme  noto-fonts
                 papirus-maia-icon-theme  qt5ct  xcape  xcursor-breeze
Optional Deps  : None
Conflicts With : manjaro-desktop-settings  manjaro-xfce-gtk3-minimal-settings
Replaces       : manjaro-xfce-gtk3-minimal-settings
Download Size  : 30.20 K
Installed Size : 39.00 K
Packager       : Mark Wagie <mark@manjaro.org>
Architecture   : any
Build Date     : Fri 04 Feb 2022 19:24:02 CET
MD5 Sum        : a8e35c71f0a803e1a600b3e0aee4c040
SHA256 Sum     : 9e8980610d36fccee0fce57cd3783c6df506bd0be0b9134438e7c625426198e8
Signatures     : Yes
Description    : Manjaro Linux xfce-minimal settings

Branch         : testing
Repository     : community
Name           : manjaro-xfce-minimal-settings
Base           : manjaro-xfce-settings
Version        : 20220204-2
URL            : https://gitlab.manjaro.org/profiles-and-settings/manjaro-xfce-settings
Licenses       : GPL
Groups         : None
Provides       : manjaro-desktop-settings  manjaro-xfce-gtk3-minimal-settings
Depends On     : illyria-wallpaper  manjaro-base-skel  manjaro-icons  matcha-gtk-theme  noto-fonts
                 papirus-maia-icon-theme  qt5ct  xcape  xcursor-breeze
Optional Deps  : None
Conflicts With : manjaro-desktop-settings  manjaro-xfce-gtk3-minimal-settings
Replaces       : manjaro-xfce-gtk3-minimal-settings
Download Size  : 30.20 K
Installed Size : 39.00 K
Packager       : Mark Wagie <mark@manjaro.org>
Architecture   : any
Build Date     : Fri 04 Feb 2022 19:24:02 CET
MD5 Sum        : a8e35c71f0a803e1a600b3e0aee4c040
SHA256 Sum     : 9e8980610d36fccee0fce57cd3783c6df506bd0be0b9134438e7c625426198e8
Signatures     : Yes
Description    : Manjaro Linux xfce-minimal settings

Branch         : stable
Repository     : community
Name           : manjaro-xfce-minimal-settings
Base           : manjaro-xfce-settings
Version        : 20220616-1
URL            : https://gitlab.manjaro.org/profiles-and-settings/manjaro-xfce-settings
Licenses       : GPL
Groups         : None
Provides       : manjaro-desktop-settings  manjaro-xfce-gtk3-minimal-settings
Depends On     : illyria-wallpaper  kvantum-theme-matcha  manjaro-base-skel  manjaro-icons  matcha-gtk-theme
                 noto-fonts  papirus-maia-icon-theme  qt5-styleplugins  qt5ct  xcape  xcursor-breeze
Optional Deps  : None
Conflicts With : manjaro-desktop-settings  manjaro-xfce-gtk3-minimal-settings
Replaces       : manjaro-xfce-gtk3-minimal-settings
Download Size  : 23.94 K
Installed Size : 39.00 K
Packager       : Philip Müller <philm@manjaro.org>
Architecture   : any
Build Date     : Wed 15 Jun 2022 23:38:08 CEST
MD5 Sum        : 3422b50292a08f9377d893f5658408b0
SHA256 Sum     : 309a4ed908b56c8904f0b7fb8b7e8eeeaf6e5179bf3dd4d2f0d0900821e4969a
Signatures     : Yes
Description    : Manjaro Linux xfce-minimal settings

So on stable it is still part of that meta-package… hm… remove that fake package…

pamac remove manjaro-xfce-minimal-settings

and install the packages which contains manjaro-xfce-minimal-settings, if removed:

pamac install illyria-wallpaper manjaro-base-skel manjaro-icons matcha-gtk-theme  noto-fonts papirus-maia-icon-theme qt5ct xcape xcursor-breeze

OR just wait for the next big update, which should solve that issue when the package from testing moves to stable branch.


Worked like an absolute charm, mate.
Thanks for your help, have a nice day.

1 Like

I have the same error:

pamac remove manjaro-xfce-minimal-settings

gives the result: package not found

@philm packaged it with wrong dependency. :stuck_out_tongue:

EDIT: So you can either:
a) wait for it to be resolved
b) remove manjaro-xfce*-settings
c) build qt5-styleplugins from aur
d) download the package and remove depend = qt5-styleplugins from .PKGINFO in .pkg.tar.xz

Personally, I like ‘d’ option the most. :smiley:

1 Like

:wink:

2 Likes

:point_down:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.