Unable to uninstall pipewire

i try to do pamac remove pipewire-pulse but it says

Checking dependencies…
Error: Failed to prepare transaction:
could not satisfy dependencies:

  • removing pipewire-pulse breaks dependency ‘pipewire-pulse’ required by manjaro-pipewire
  • removing pipewire-pulse breaks dependency ‘pulseaudio’ required by pulseaudio-ctl

how do i remove pipewire?

sudo pacman -R manjaro-pipewire then install pulse audio

You can’t. You can replace it with pulseaudio with pamac install manjaro-pulse

You can’t remove Pipewire without installing something to replace it. Otherwise, all sound on your system would not work.

when i do this i get the error

Synchronizing package databases…
https://aur.manjaro.org/packages-meta-ext-v1.json.gz: Unacceptable TLS certificate
Failed to synchronize AUR database

what do i do?

i run pamac install panjaro-pulse but i get the following outcome

==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: ae
Synchronizing package databases…
Refreshing AUR…

Choose optional dependencies for manjaro-pulse:
1: paprefs: Configuration dialog
2: pasystray: system tray application
3: pavucontrol-qt: A Qt volume control tool
4: pulseaudio-equalizer: Graphical equalizer
5: pulseaudio-equalizer-ladspa: A 15-band equalizer
6: pulseaudio-jack: Jack support
7: pulseaudio-lirc: IR (lirc) support
8: pulseaudio-rtp: RTP and RAOP support
9: pulseaudio-zeroconf: Zeroconf support

Enter a selection (default=none):

Checking psautohint dependencies…
Cloning proton build files…
Generating proton information…
Checking proton dependencies…
Checking visual-studio-code-bin dependencies…
Cloning afdko build files…
Generating afdko information…
Checking afdko dependencies…
Checking python-ufonormalizer dependencies…
Warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)
Resolving dependencies…
Checking inter-conflicts…
Error: unresolvable package conflicts detected
Error: Failed to prepare transaction:
conflicting dependencies:

  • manjaro-pulse and pipewire-pulse are in conflict

Edit build files : [e]
Apply transaction ? [e/y/N] y

Transaction cancelled.

Please do not make duplicate threads for the same issue.

no one answered and this is a different issue

It is an extension of your first issue, which makes it count as part of the same issue. Also, it has been 43 minutes since your most recent post on the thread. Please be patient.

pamac install --no-upgrade pulseaudio pulseaudio-alsa

Disable AUR for this process with --no-aur

I think what you want is

sudo pacman -Syu manjaro-pulse

It should be a meta package for everything you need for pulse … usurping pipewire.

(in this case using pacman will just skip/avoid the pamac problems)

@cscs i run that command but get the following output

:: Synchronising package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)
resolving dependencies…
looking for conflicting packages…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: manjaro-pulse and pipewire-pulse are in conflict

what do i do?

Response shows use of pacman to install metapackage manjaro-pulse fails due to same dependency issues as pamac

This issue was reported to Manjaro Team, but not likely to be fixed

For pamac refuseniks, this command to install individual packages should work similar to command suggested in post #10

sudo pacman -S pulseaudio pulseaudio-alsa

i do that command and just get the output

resolving dependencies…
looking for conflicting packages…
:: pulseaudio-alsa and pipewire-alsa are in conflict. Remove pipewire-alsa? [y/N] y
:: pulseaudio and pipewire-pulse are in conflict. Remove pipewire-pulse? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-alsa breaks dependency ‘pipewire-alsa’ required by manjaro-pipewire
:: removing pipewire-pulse breaks dependency ‘pipewire-pulse’ required by manjaro-pipewire

is there a way to manually remove pipewire and install pulseaudio completely?

remove the metapackage as suggested in post#2

pamac remove manjaro-pipewire

then install packages individually

pamac install --no-upgrade pulseaudio pulseaudio-alsa

given the problems so far, I suggest do not select any additional optional dependencies when requested. They can be installed later once the main PulseAudio packages are reinstated

now i dont get any audio, i changed the output and input to the same in pulseaudio control but i cant hear anything

I suggest delete PulseAudio user configuration files (that may contain old settings from before change to PipeWire) and reboot system so PulseAudio creates new configuration files

rm ~/.config/pulse/*; reboot

If audio is not working after reboot, check if reinstated systemd units are active and error-free

systemctl --user -l --no-pager status pulseaudio.{socket,service} pipewire.{socket,service}

and check Profiles/Ports for audio playback are available

pactl list cards