Unable to Setup External Monitor on Manjaro KDE (AMD/NVIDIA)

Hello, I’ve been having a difficult time trying to setup an external monitor on my new gaming laptop with Manjaro KDE. I’ve tried a few things:

I’ve tried just normally setting it up through the KDE Display Configuration settings. It detects the external monitor, but when I enable it and click “apply”, it has no effect. If I then close the settings app and reopen it, the enabled checkbox for the external monitor is unchecked.

I tried using Arandr to configure it, but each time I enable the secondary monitor, I’m met with this error and I couldn’t really find anything helpful online from googling it.

I also tried switching to Wayland, following this guide, but the secondary monitor wasn’t detected at all, so I switched back.

System Info:

          Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
          Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
          Distro: Manjaro Linux 
          Type: Laptop System: Acer product: Nitro AN515-44 v: V1.03 serial: <filter> 
          Mobo: RO model: Stonic_RNS v: V1.03 serial: <filter> UEFI: Insyde v: 1.03 
          date: 10/20/2020 
          ID-1: BAT1 charge: 58.0 Wh condition: 58.0/58.8 Wh (99%) volts: 17.6/15.4 
          model: SMP AP18E7M type: Li-ion serial: <filter> status: Full 
          RAM: total: 15.08 GiB used: 1.99 GiB (13.2%) 
          RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
          Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP 
          arch: Zen rev: 1 L2 cache: 4096 KiB bogomips: 92657 
          Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 1: 1474 
          2: 1398 3: 1451 4: 1634 5: 1517 6: 1513 7: 1540 8: 1553 9: 1397 10: 1396 11: 1467 
          12: 1396 13: 1384 14: 1545 15: 1788 16: 1760 
          Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 
          bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy constant_tsc 
          cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc cr8_legacy cx16 
          cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr 
          fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm lbrv lm mba mca mce misalignsse 
          mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw 
          overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc 
          perfctr_nb pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a 
          rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a 
          ssse3 stibp succor svm svm_lock syscall tce topoext tsc tsc_scale umip 
          v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec 
          xsaveerptr xsaveopt xsaves 
          Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Acer Incorporated ALI 
          driver: nvidia v: 455.45.01 bus ID: 01:00.0 chip ID: 10de:1f95 
          Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu v: kernel 
          bus ID: 05:00.0 chip ID: 1002:1636 
          Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus ID: 3-3:2 
          chip ID: 0408:a061 
          Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu,ati,nvidia 
          unloaded: modesetting,nouveau alternate: fbdev,nv,vesa resolution: 1920x1080~60Hz 
          s-dpi: 96 
          OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0) 
          v: 4.6 Mesa 20.2.3 direct render: Yes 
          Device-1: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
          vendor: Acer Incorporated ALI driver: N/A bus ID: 05:00.5 chip ID: 1022:15e2 
          Device-2: AMD Family 17h HD Audio vendor: Acer Incorporated ALI 
          driver: snd_hda_intel v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
          Sound Server: ALSA v: k5.9.11-3-MANJARO 
          Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000 
          bus ID: 03:00.0 chip ID: 10ec:2600 
          IF: enp3s0 state: down mac: <filter> 
          Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 bus ID: 04:00.0 
          chip ID: 8086:2723 
          IF: wlp4s0 state: up mac: <filter> 
          IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
          IP v6: <filter> type: noprefixroute scope: link 
          WAN IP: <filter> 
          Local Storage: total: 476.94 GiB used: 10.81 GiB (2.3%) 
          ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN530 SDBPNPZ-512G-1014 
          size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 21103900 
          scheme: GPT 
          Message: No Optical or Floppy data was found. 
          Message: No RAID data was found. 
          ID-1: / size: 295.10 GiB used: 10.76 GiB (3.6%) fs: ext4 dev: /dev/nvme0n1p5 
          label: N/A uuid: eec6acb8-e5ce-4eb1-98ec-332ae82d7e23 
          ID-2: /boot/efi size: 96.0 MiB used: 51.0 MiB (53.1%) fs: vfat dev: /dev/nvme0n1p1 
          label: ESP uuid: 1EBF-E5D5 
          Alert: No Swap data was found. 
          ID-1: /dev/nvme0n1p2 size: 16.0 MiB fs: <superuser/root required> label: N/A 
          uuid: N/A 
          ID-2: /dev/nvme0n1p3 size: 175.00 GiB fs: ntfs label: Acer uuid: B6E4C13CE4C1001B 
          ID-3: /dev/nvme0n1p4 size: 1024.0 MiB fs: ntfs label: Recovery 
          uuid: E20EC1F80EC1C5AF 
          Hub: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
          chip ID: 1d6b:0002 
          Device-1: 1-4:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
          interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0029 
          Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
          chip ID: 1d6b:0003 
          Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
          chip ID: 1d6b:0002 
          Device-1: 3-3:2 info: Quanta HD User Facing type: Video driver: uvcvideo 
          interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 0408:a061 
          Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
          chip ID: 1d6b:0003 
          System Temperatures: cpu: 55.1 C mobo: N/A gpu: amdgpu temp: 36.0 C 
          Fan Speeds (RPM): N/A 
          Processes: 332 Uptime: 1h 43m Init: systemd v: 246 Compilers: gcc: 10.2.0 
          Packages: pacman: 1278 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

Driver Info:

    [matt@matt-nitroan51544 ~]$ mhwd -la
    > All PCI configs:
                      NAME               VERSION          FREEDRIVER           TYPE
       network-broadcom-wl            2018.10.07                true            PCI
         network-rt3562sta            2013.12.07                true            PCI
             network-r8168            2016.04.20                true            PCI
           network-slmodem            2013.12.07                true            PCI
        video-nvidia-430xx            2020.10.04               false            PCI
        video-nvidia-450xx            2020.10.04               false            PCI
    video-hybrid-amd-nvidia-435xx-prime            2020.10.04               false            PCI
    video-hybrid-amd-nvidia-450xx-prime            2020.10.04               false            PCI
         video-modesetting            2020.01.13                true            PCI
        video-nvidia-440xx            2020.10.04               false            PCI
                video-vesa            2017.03.12                true            PCI
    video-hybrid-intel-nvidia-455xx-prime            2020.10.04               false            PCI
    video-hybrid-amd-nvidia-455xx-prime            2020.10.04               false            PCI
    video-hybrid-intel-nvidia-390xx-bumblebee            2020.10.04               false            PCI
        video-nvidia-455xx            2020.10.04               false            PCI
              video-sisusb            2020.01.18                true            PCI
              video-voodoo            2017.03.12                true            PCI
    video-hybrid-intel-nvidia-340xx-bumblebee            2020.10.04               false            PCI
                  video-s3            2020.01.18                true            PCI
        video-nvidia-435xx            2020.10.04               false            PCI
           video-rendition            2020.01.18                true            PCI
      video-virtualmachine            2020.03.26                true            PCI
    video-hybrid-intel-nvidia-435xx-prime            2020.10.04               false            PCI
               video-linux            2018.05.04                true            PCI
    video-hybrid-intel-nvidia-430xx-bumblebee            2020.10.04               false            PCI
        video-nvidia-340xx            2020.10.04               false            PCI
        video-nvidia-418xx            2020.10.04               false            PCI
    video-hybrid-amd-nvidia-440xx-prime            2020.10.04               false            PCI
          video-openchrome            2020.01.18                true            PCI
    video-hybrid-intel-nvidia-450xx-prime            2020.10.04               false            PCI
    video-hybrid-intel-nvidia-418xx-bumblebee            2020.10.04               false            PCI
        video-nvidia-390xx            2020.10.04               false            PCI
    video-hybrid-intel-nvidia-440xx-prime            2020.10.04               false            PCI

    Warning: No USB configs found!

In some other related posts I saw people asking for this as well:

    [matt@matt-nitroan51544 ~]$ xrandr --listproviders
    Providers: number : 2
    Provider 0: id: 0x54 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 1 associated providers: 1 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0
    Provider 1: id: 0x1f6 cap: 0x2, Sink Output crtcs: 4 outputs: 1 associated providers: 1 name:NVIDIA-G0

I believe the problem is the same as here.

1 Like

It’s not quite the same because the OP there says that they can drag windows onto their second display and mine cannot do that, it won’t connect at all. But I’ll try and follow the guide you linked to them and see how that goes anyway. Thank you.

Indeed, you’re right, but as far as I know, it’s still not possible to use the nvidia gpu as an output sink when the source is the xf86-video-amdgpu driver. So you’ll most probably need to use optimus-manager and switch to the “nvidia” mode if you want to use external monitors. Or maybe it’s even possible to use the modesetting Xorg driver with the AMD gpu, and then using the nvidia gpu as output sink should technically be possible.

Ok, I’m just in the middle of following the guide here. I’m on step 8 and I want to make sure that the optimus manager status is ok. This is the output I’m getting.

[matt@matt-nitroan51544 etc]$ systemctl status optimus-manager.service
● optimus-manager.service - Optimus Manager Commands Daemon
     Loaded: loaded (/usr/lib/systemd/system/optimus-manager.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2020-12-23 16:17:54 EST; 4min 53s ago
    Process: 4282 ExecStartPre=/usr/bin/python3 -u -m optimus_manager.hooks.pre_daemon_start (code=exited, status=0/SUCCESS)
    Process: 4283 ExecStartPre=/usr/bin/python3 -u -m optimus_manager.hooks.pre_xorg_start (code=exited, status=1/FAILURE)
   Main PID: 4295 (python3)
      Tasks: 1 (limit: 18430)
     Memory: 8.5M
     CGroup: /system.slice/optimus-manager.service
             └─4295 /usr/bin/python3 -u -m optimus_manager.daemon

Dec 23 16:17:54 matt-nitroan51544 python3[4283]:     _wait_no_processes_on_nvidia()
Dec 23 16:17:54 matt-nitroan51544 python3[4283]:   File "/usr/lib/python3.8/site-packages/optimus_manager/kernel.py", line 200, in _wait_no_processes_on_nvidia
Dec 23 16:17:54 matt-nitroan51544 python3[4283]:     raise KernelSetupError("Timeout waiting for active processes to release the Nvidia GPU")
Dec 23 16:17:54 matt-nitroan51544 python3[4283]: optimus_manager.kernel.KernelSetupError: Timeout waiting for active processes to release the Nvidia GPU
Dec 23 16:17:54 matt-nitroan51544 python3[4283]: [5905] INFO: Removing /etc/X11/xorg.conf.d/10-optimus-manager.conf (if present)
Dec 23 16:17:54 matt-nitroan51544 python3[4283]: [5906] INFO: Writing state {'type': 'pre_xorg_start_failed', 'switch_id': '20201223T161748', 'requested_mode': 'integrated'}
Dec 23 16:17:54 matt-nitroan51544 systemd[1]: Started Optimus Manager Commands Daemon.
Dec 23 16:17:54 matt-nitroan51544 python3[4295]: [2] INFO: # Commands daemon
Dec 23 16:17:54 matt-nitroan51544 python3[4295]: [2] INFO: Opening UNIX socket
Dec 23 16:17:54 matt-nitroan51544 python3[4295]: [2] INFO: Awaiting commands

Also, to clarify, do I run optimus-manager --switch nvidia before or after I reboot?

That command has an immediate effect, you don’t need to reboot to see the change.

The service state looks more or less OK, there is a timeout error, but that could be caused by the fact that you have just installed it. After installation, I suggest you reboot first and do not try to switch the mode.

Wow, I think that worked! The external monitor displays as black, but I can now drag windows into the external monitor and they show up so I guess it’s just not displaying the default Manjaro background on it, but that’s not really a problem for me. Thanks so much for your help!

Well, that’s interesting. Is this in the “hybrid” or “nvidia” mode (optimus-manager --status)?

It’s in nvidia mode. This is the full output of that command. I noticed it says that at startup, it’ll be integrated so does that mean I need to switch to nvidia each time I login?

[matt@matt-nitroan51544 ~]$ optimus-manager --status
Optimus Manager (Client) version 1.3

Current GPU mode : nvidia
GPU mode requested for next login : no change
GPU at startup : integrated
Temporary config path: no

Just to summarize the solution for everyone:

I ran this command: pamac build optimus-manager-git

I then followed this guide, omitting steps 1 and 7. Make sure you start the optimus manager service if it isn’t already running in step 8.

Run sudo systemctl start optimus-manager.service if it isn’t running.

After the reboot in step 8, run optimus-manager --switch nvidia

Your screen might get a little messed up, just relog and it should be fine.

If you want to make optimus manager start in nvidia mode automatically:

Create the file /etc/optimus-manager/optimus-manager.conf and place the following in it:


# GPU mode to use at computer startup.
# Possible values: nvidia, integrated, hybrid, auto, intel (deprecated, equivalent to integrated)
# "auto" is a special mode that auto-detects if the computer is running on battery
# and selects a proper GPU mode. See the other options below.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.