Unable to satisfy dependency - nvidia driver install

When updating today I hit the following error:

 sudo LC_ALL=en_US pacman -Syyu
    :: Synchronizing package databases...
     core                                 169.9 KiB  1089 KiB/s 00:00 [####################################] 100%
     extra                               2016.3 KiB  4.04 MiB/s 00:00 [####################################] 100%
     community                              6.1 MiB  5.03 MiB/s 00:01 [####################################] 100%
     multilib                             194.6 KiB  1324 KiB/s 00:00 [####################################] 100%
    :: Starting full system upgrade...
    warning: ignoring package replacement (ilmbase-2.3.0-1 => openexr-2.5.3-1)
    warning: opencv: ignoring package upgrade (4.1.0-2 => 4.4.0-1)
    warning: openexr: ignoring package upgrade (2.3.0-1 => 2.5.3-1)
    :: Replace xapps with community/xapp? [Y/n] y
    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux57-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils' required by lib32-nvidia-440xx-utils

I did find a similar report here but I don’t use the hybrid drivers. What should I do?

Just run:

sudo pacman -R linux-latest-nvidia-440xx
sudo mhwd -r pci video-nvidia-440xx

then proceed installing the video-nvidia-450xx drivers.
sudo mhwd -i pci video-nvidia-450xx

Hi!
If you want to install 450 need to install the 440 first

Oki. A bit different on my case, I do use a neural network called darknet:

.

Cuda did some updates on the last weeks I did not keep track:
darknet -v
CUDA status Error: file: /home/vfbsilva/.cache/yay/darknet-alexeyab-git/src/darknet/src/dark_cuda.c : () : line: 39 : build time: Sep 8 2020 - 14:20:16

 CUDA Error: CUDA driver version is insufficient for CUDA runtime version
CUDA Error: CUDA driver version is insufficient for CUDA runtime version: Success

So I had to remove it then proceed to update:
sudo pacman -Rs cuda cudnn

Then follow @bogdancovaciu advice and reinstall darknet

But now it breaks with:
UDA status Error: file: /home/vfbsilva/.cache/yay/darknet-alexeyab-git/src/darknet/src/dark_cuda.c : () : line: 39 : build time: Sep 8 2020 - 14:20:16

 CUDA Error: no CUDA-capable device is detected
CUDA Error: no CUDA-capable device is detected: Success

Hi!
That’s far away from my knowledge. I hope any more savvy member than me can help you

Once you made the switch to the newer driver, reinstall cuda and what you need, then reboot again.
If is your code in the

then check the line 39 …

The culpirit is older and has not been adressed in darknet. Things is it uses old versions of:
ilmbase openexr opencv
in fact:
ilmbase-2.3.0-1-x86_64.pkg.tar.xz
opencv-4.1.0-2-x86_64.pkg.tar.xz
openexr-2.3.0-1-x86_64.pkg.tar.xz
Those are the versions you need to build.
@bogdancovaciu I do understand your comment and I do know I haven’t added the full info. But is at least rude.

Not sure i follow. Your or my comment is rude?

Yours, I’m not a native English speaker so might be a simple confusion.

My apology if any of my comment came as rude towards you, but i asure you there was nothing of such in any of them. I have no experience with darknet and cudnn … not sure exactly how the projects are stored and how the source for them works. Was just guessing that you can add some code to each project, and simply needs a tweak.
Anyway, probably someone more experienced will pass by with a better approach for that particular error you get.

1 Like

I’m facing a different kind of issue…

Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-amd-nvidia-450xx-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
warning: nvidia-450xx-utils-450.66-1 is up to date -- skipping
warning: nvidia-prime-1.0-4 is up to date -- skipping
error: target not found: linux59-nvidia-450xx
core is up to date
extra is up to date
community is up to date
multilib is up to date
Error: pacman failed!
Error: script failed!

I’m trying to install nvidia-amd-hybrid-450xx-prime

That means you have the linux59 installed and there are no modules for it, yet MHWD tries to reconciliate with them. Remove that kernel eventually.

So I just need to downgrade my kernel, and that’ll fix the problem, right?

Well, is improper to call it downgrade the kernel.
You can have linux58 and linux54 installed in the same time.
You could also have in the same time the linux59, but that one is still rc and no nvidia modules are ready for it.

Hi, I had the same issue, I fixed it by following the instructions specified by @bogdancovaciu:

Remove the older package


$ sudo pacman -R linux-latest-nvidia-435xx

Running this gave me a dependency error with cuda


$ sudo mhwd -r pci video-nvidia-435xx

> Removing video-nvidia-435xx...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/local/pci/video-nvidia-435xx/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

Processing classid: 0302

checking dependencies...

error: failed to prepare transaction (could not satisfy dependencies)

:: removing nvidia-435xx-utils breaks dependency 'nvidia-utils' required by cuda

Error: pacman failed!

Error: script failed!

How to fix it? Delete cuda. That will still give an error for cudnn because cuda is a dependency for it, so you’ll have to delete cudnn as well.


$ sudo pacman -R cudnn cuda

Now you should be able to remove the older version


$ sudo mhwd -r pci video-nvidia-435xx

Install the newer version


$ sudo mhwd -i pci video-nvidia-450xx

Install back cuda and cudnn


$ sudo pacman -S cudnn cuda

You should now be able to update


$ sudo pacman -Syyu

And you should now be good! Thanks @bogdancovaciu :smiley:

3 Likes