Unable to open a file from my portable drive to a program

Whenever I would try to load a file from my portable hard drive to a program such as maybe GIMP or Aseprite, it would say something like: "

Aseprite can't load /run/media/mika/MainDrive/Projects/Aseprite/Tileset.aseprite" file ("aseprite")

. Same with any file. And Discord does it too. It won’t display the file and say upload failed. How can I fix this? I’ll provide any information necessary.

Gimp is a flatpak or a native version? In flatpak you need to allow gimp to use this dir. Look for flatseal.

How can I check?

flatpak list --app  | grep -i gimp
pamac list | grep -i gimp 

Flatpak is giving me nothing.
And pacman is giving me:
error: no operation specified (use -h for help)

pamac not pacman…

Wow my dyslexia. I apologize!! :sob:

It’s now giving me “bash: pacmac: command not found”.

Keep calm and read again slowly… how it is written?

Exactly how I spelt it: pacmac list | grep -i gimp

Copied right from the terminal.

Do you see the difference? you add a c after pa.

Oh. My dyslexia again… I’m so sorry!

pamac list | grep -i gimp
gimp                              2.10.32-1                     extra      118.5 MB

ok well… can you show the permissions of the file?

stat /run/media/mika/MainDrive/Projects/Aseprite/Tileset.aseprite
stat /run/media/mika/Main 1/CRY3T41 Data H2/Projects/Aseprite/Tileset.aseprite
stat: cannot statx '/run/media/mika/Main': No such file or directory
stat: cannot statx '1/CRY3T41': No such file or directory

I have it in another folder, but this is what it gives me. Is it because of the spaces?

yes… this solves it:

stat '/run/media/mika/Main 1/CRY3T41 Data H2/Projects/Aseprite/Tileset.aseprite'

Thank you.

stat '/run/media/mika/Main 1/CRY3T41 Data H2/Projects/Aseprite/Tileset.aseprite'
  File: /run/media/mika/Main 1/CRY3T41 Data H2/Projects/Aseprite/Tileset.aseprite
  Size: 65338     	Blocks: 128        IO Block: 4096   regular file
Device: 8,17	Inode: 603888      Links: 1
Access: (0777/-rwxrwxrwx)  Uid: ( 1000/    mika)   Gid: ( 1000/    mika)
Access: 2022-07-27 22:32:07.519279900 -0400
Modify: 2019-05-28 17:28:36.000000000 -0400
Change: 2022-07-17 16:51:37.056146700 -0400
 Birth: -

That are 2 different paths. No wonder gimp don’t find the old one.

But I moved the file to test it. And I’m not using GIMP, I’m using Aseprite. It’s a pixel art program and the .aseprite is the project file. But that’s not the only problem, it seems to be every other file too. PNGs, or so when I try to load it into Discord or Aseprite. Those are what I know of that don’t work. GIMP seems to open files just fine I believe. But it’s the other prorgams that don’t know how to open it.

If it’s not on my portable drive, it can be uploaded to Discord or opened in Aseprite perfectly fine. And another issue is my desktop becomes frozen and unable to use it when I plug my drives in, but I think it goes back to normal after a pretty long time.

Sorry that is now confusing. Please post the output:

mount -t btrfs,ext4,ntfs,fuseblk

How do you open the files? Do click on “recent files” or switch though the folders and choose the file?

mount -t btrfs,ext4,ntfs,fuseblk
/dev/sda1 on / type ext4 (rw,noatime)
/dev/sdb1 on /run/media/mika/Main 1 type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

What I meant is I moved it to a more fitting folder that has my other stuff in it. What it was in before was a temporary folder, but the new directory is where it was meant to be, I meant.

And I tried all methods. I tried opening them using Discord and Aseprite, I tried “Recent files” in Aseprite but same issue. I tried drag and drop, and for Discord, it displays a transparent image and says it failed to upload when I try to send it.