Unable to launch NeoChat on a fresh install

I flashed Manjaro-ARM-plasma-mobile-pinephone-factory-20210112.img.xz to my PinePhone via Jumpdrive.

Upon a fresh install, I’m unable to launch NeoChat, one of the default apps on the phone.

I tried to launch it via the terminal instead, and I get the following:

[kde@plasma-mobile ~]$ neochat
neochat: error while loading shared libraries: libQuotient.so.0.6: cannot open shared object file: No such file or directory

I’m not 100% sure how to handle this, so I decided to check pacman and see if there was anything interesting.

[kde@plasma-mobile ~]$ sudo pacman -Ss quotient
[sudo] password for kde:
community/libquotient 0.6.6-1 [installed: 1:0.7-1.3]
    A Qt library to write cross-platform clients for Matrix

So I already have libQuotient installed?

I’ve already done updates via pacman -Syu and on discover.
Does anyone have any ideas what might be wrong here?

I can vouch the flatpak for NeoChat works, though not very well. I’d like to try get it running via the installation candidate on pacman.

That image is way to old.

Use one of the newer stable images, or at least the Beta 4 when flashing at this point.

Please do this and see if that helps:

sudo pacman-mirrors -f5
sudo pacman -Syyu
1 Like

That image is way to old.

Ahh, sorry about that! I assumed the factory images might’ve been more stable.
That’s my fault, I should’ve checked which image is recommended for new installations.

I executed both commands, it reported that the following weren’t updated because my local versions were newer:

  • kuserfeedback
  • libquotient

I did the following to get them reinstalled and downgraded to the versions in the repository.

sudo pacman -S kuserfeedback
sudo pacman -S libquotient

NeoChat works now. \(^-^)/
Thank you for the support!

2 Likes