Unable to get past Grub on live usb on Dell New Inspiron 7710 AIO All in One

The computer bought newly is Dell Inspiron 7710 All in One PC

  1. Comes with pre-installed Windows-11 only unlike some other Dell models where one can choose OS
  2. Flashed the latest Manjaro Plasma on USB using Rufus (GPT) and other times using Balena etcher
  3. Disabled Secure UEFI boot in BIOS Settings
  4. Changed storage control from RAID to AHCI/NVMe in BIOS Settings
  5. Changed boot sequence to USB in BIOS
  6. Rebooted
  7. Grub loads
  8. On choosing any option in Grub, the screen goes blank and system halts
  9. Hard reboot system from USB. Tried adding linux kernel parameters noacpi, noapic, nomodeset and removed quiet splash. But upon Ctrl+X after that, the screen goes blank and system halts
  10. Tried flashing Debian, Ubuntu, MXLinux and Manjaro. All of them seem to do the same.
  11. So I feel problem cannot be the Kernel incompatibility with processor since Dell uses same Gen 12 processor on other models with Ubuntu shipped.
  12. Regarding graphics card compatibility, I feel no incompatibility as the youtube video on a different computer At minute 2:28 of youtube video titled “A clean install of linux mint 21 (Dell UEFI BIOS with Secure Boot and MOK)”
  13. Tried disabling touchscreen option in BIOS and retried above steps and same result
  14. The exact same problem is also reported by somebody at Mint forum forum thread number 379517 titled “Mint 21 (dualboot) on Dell “New” Inspiron 7710 AIO”

I am thoroughly at loss as to how to proceed. I have never had a live USB fail at first step with no error messages to debug in the past 10 years of using Debian, Ubuntu. Had to move to Manjaro due to stable release of Kernel of 5.19 that supports the hybrid Alder Lake processor.
Not sure if secure erase both HDD and SSD will help.
Also first time I am seeing such a complicated BIOS and it has something called “Microsoft CA key (If you disable this, your computer may become inoperable)” and below that there are some db and other file formats. I tried disabling this also and now I cannot get into windows because Bitlocker seems to ask for a key.
Since I am changing my computer after 10 years, I may be outdated with some of these new features.

Any help to get the Live USB to work is appreciated. I can manage all steps of install thereafter.

I am not sure if Grub is having a problem locating the kernel to load or if the kernel is prevented from loading due to weird UEFI or Kernel is unable to start or some other big incompatibility that I have overlooked.


use ventoy to flash the iso, and download the latest stable iso with the 6.0 kernel from here; download both zip files, merge them and try with it

Thank you for your time and message.
Tried the latest stable image of KDE iso with ventoy as per your suggestion.
Same problem persists whether I choose proprietary drivers or open source drivers. Saw that in the grub menu that various init parameters to systemd and kernel are already given by default in the ISO and thought this can go to a step where it displays a message giving the error. But sadly it is blank and keyboard is unresponsive. Since it could be a computer model specific problem, I will go back to windows until the problem is more widely reported by more users and more diagnosis is possible. Thanks.

do you have nvidia, since you mentioned proprietary drivers? if yes add this parameter:
here is a link on where you add it…
if you dont have nvidia, try adding this parameter:
and see if that helped…
do this in the latest linux 6 iso

Thanks again.
I tried your suggestion on Intel Iris Xe graphics card and latest iso.
Both i915.enable_psr=0 as per your suggestion and
i915.enable_psr=0 i915.enable_dc=0 intel_idle.max_cstate=2
reported by others to work on Intel graphics card, do not work. Still getting a blank screen.
Not sure if I should toggle i915.modeset=1 to i915.modeset=0 as I read it is supposed to be in 1 for intel graphics. nomodeset does not work indicating that i915.modeset=1 should be appropriate.
Will try to read more about Intel graphics card related kernel parameters and try all options.
Once again thank you very much for your time and suggestions. Will update if I find something. It would have been nice to see an error message instead of a blank screen, but, as you have pointed out if it is a graphics card related error, then it may be difficult to debug.

i dont know if its related to graphics… could be because it is a new hardware and its not properly supported with linux… or it could be related to some bios settings - especially the secure boot that you mentioned… i would also try fedora or ubuntu isos with the kernel 6, to see if it can boot, since both support secure boot…

Excellent suggestion. Installed Ubuntu. No problems at all. You are correct it seems to be an issue with secure boot.
Thank you very very much.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.