Unable to find secondary drive to set as steam library

I have a hard drive which is automounted at /home/USERNAME/sda1 using fstab. I executed

sudo chmod -R 777 /home/USERNAME/sda1

then rebooted to see if that would get steam to see the drive but it is still not there.
What can I do now?

Welcome here, @Ka5pian :wave:

Please post your fstab file

cat /etc/fstab

to see how you mounted the partition and what file system it has.

Also, please show us output of

sudo parted -l
sudo blkid
UUID=779C-BE0B                            /boot/efi      vfat    umask=0077 0 2
UUID=8379197a-5a6d-4e32-b79c-51bbc8e05f5d /              ext4    defaults,noatime 0 1
UUID=feb26a93-365d-4035-ab60-cbee1fc41690 swap           swap    defaults,noatime 0 0

UUID=b7763217-46bd-4b42-bd4a-9a08c13a254f /home/ka5pian/sda1 ext4 defaults 0 2

UUID=19d1258d-6a67-4517-9fdf-8865459ad0d0	/home/ka5pian/nvme1n1	ext4	defaults	0	2

the bold is the drive i am trying to use

Model: ATA ST2000DM001-1CH1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 
Number  Start   End     Size    File system  Name                Flags
 1      17.4kB  2000GB  2000GB  ext4         LDM data partition
/dev/sda1: LABEL="Syuff" UUID="b7763217-46bd-4b42-bd4a-9a08c13a254f" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="LDM data partition" PARTUUID="c286a643-fe79-11e9-9fce-4ccc6a60fe49"

Did you create the folder by

sudo mkdir /home/ka5pian/sda1

Have you tried getting ownership by

sudo chown -R ka5pian /home/ka5pian/sda1

I made the directory before editing fstab


sudo chown ka5pian /home/ka5pian/sda1

then restarted steam and nothing changed

I can access the drive through nemo

What gives

ls -la /home/ka5pian

You can truncate it if you don’t want to show all.

drwx------  3 ka5pian ka5pian 4096 Jan 30 20:39 nvme1n1
drwxrwxrwx 14 ka5pian ka5pian 4096 Jan 30 20:28 sda1

sda1 is dark blue text and has a teal highlight whereas the nvme drive is only dark blue.

(sidenote: Steam is the flathpak version)

Then the folder is OK and the issue on the side of steam I guess…

You can certainly check content of the folder by

ls -la /home/ka5pian/sda1
drwxrwxrwx  3 ka5pian ka5pian   4096 Dec 13 16:34  SteamLibrary

I now understand what the text colour means

I’m going to try and install the windows version of steam and using it through wine to see if that solves the issue.
(will reply the outcome)

Why not the normal repo version, or something from AUR?

The windows version worked but I’ll try the AUR version.

I think reinstalling steam fixed the issue. I used the AUR package