Unable to download libvirt through pacman

I’m attempting to download libvirt through:

sudo pacman -S libvirt

But while running the program I get:

Error: GDBus.Error:org.freedesktop.DBus.Error.TimedOut: Failed to activate service ‘org.freedesktop.PackageKit’: timed out (service_start_timeout=25000ms)

Am I missing a file or need to change a config file to fix the error?

There’s a rule - always ensure your system is up-to-date. Do not use -S <pkgname> on a not-up-to-date system

Always use

sudo pacman -Syu <pkgname>

You can try to manually start the service
systemctl start packagekit

systemctl status packagekit.service
journalctl -xe
for details.

1 Like

I ran the “sudo pacman -Syu libvirt” command but still received the error. I assumed that it means something was out of date like you said and I found that I am running an older packagekit. I tried downloading the newest packagekit available (1.2.5-1) but received the same error:

Error: GDBus.Error:org.freedesktop.DBus.Error.TimedOut: Failed to activate service ‘org.freedesktop.PackageKit’: timed out (service_start_timeout=25000ms)

Is there another out-of-date but critical package used to update the packagekit system I could have?

I ran the systemctl start packagekit and in return got these errors:

packagekitd[4708]: Failed to initialize alpm: using /etc/PackageKit/alpm.d/pacman.conf: /etc/PackageKit/alpm.d/pacman.conf:8/etc/pacman.conf:101unrecognised directive ‘clea’

systemd[1]: Failed to start PackageKit Daemon.

Post the contents of your /etc/pacman.conf file.

Remove package kit - it is not a necessity

sudo pacman -Rns packagekit

If you encounter something depending on packagekit - remove that as well

# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
# We cannot check disk space from within a chroot environment
#ParallelDownloads = 6

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Server = https://repo.pritunl.com/stable/pacman

This is your problem.

Remove those lines, maybe also the ones beneath them, save the file and try again.

I have no idea what the pritunl repository is…

sudo pacman -Rns packagekit                                                                                                                                                                1 ✘  16s  
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing packagekit breaks dependency 'packagekit' required by packagekit-qt5

5 posts were split to a new topic: After installing libvirt - I get error creating virtual machine

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.