Unable to change screen brightness after reboot

As the title says, I am unable to configure the brightness of the screen, both through fn+up and down keys, and through the sliders in the Gnome top bar. This happened after I booted into windows and then back to Linux. The brightness set itself to max and I am completely unable to change it.

I recently installed new updates that became available today, but this was not the first time i rebooted after the updates, but the first time I booted into windows after the updates.

2 Likes

Hello @JoelEng :wink:

Persist the problem if you shutdown and start the laptop instead of rebooting?

yes, this made no difference

I managed to fix this issue by using kernel 5.10

@JoelEng Could try to install xorg-xbacklight try on the terminal to increase and decrease the backlight?

xbacklight -inc 10
xbacklight -dec 10

Just to check if it is a gnome problem or a driver problem.

It says “No outputs have backlight property”. I didn’t expect this to work though, as I am using wayland and this sounds like it’s exclusive to Xorg

Ah i see… sorry no idea about wayland.

Hi,

I was having a similar issue after today’s update. I don’t have any dual boot on my laptop and I’m not running Wayland.

  • Linux kernel 5.4 -> Working fine
  • Linux kernel 5.9 -> Max brightness only

Following answer resolves my issue (Intel i915 only):

2 Likes

Sorry if this is a total noob question, but how do I change boot parameters?

@JoelEng,

Please check before that you are running the i915 driver with the following command inxi -G. Example of output:

~ >>> inxi -G                                                                                                                                                                           [130]
Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 455.45.01 
           Device-3: Syntek EasyCamera type: USB driver: uvcvideo 
           Display: x11 server: X.org 1.20.9 driver: modesetting,nvidia resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.2.2 

You can edit kernel parameter with sudo nano /etc/default/grub and add this parameter to the line GRUB_CMDLINE_LINUX_DEFAULT="" or GRUB_CMDLINE_LINUX="". Do not remove existing parameters.

When you are done you need to run sudo update-grub and reboot.

I will not share my grub file as I don’t use quiet splash and it could be misleading for you.

Be aware that you may have from time to time a *.pacnew file and you will have to merge it partially or not to keep you settings.

6 Likes

I was facing a similar issue. After I turned on my laptop today I noticed that my screen was at full brightness and the keys didn’t work.

I followed your instructions and added the i915.enable_dpcd_backlight=0 line, updated grub and restarted the laptop.
GRUB_CMDLINE_LINUX="i915.enable_dpcd_backlight=0"
Now the brightness keys are working again. Thanks vcottineau for providing the solution and JoelEng for making a thread.

I had the same issue, I can confirm the solution worked for me, too. Thanks, guys!

My laptop: XPS13 9370

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.