Unable to boot or use chroot

Am stuck. I have 3 HD’s, one big one for data. A smaller one (250GB) for a spare system. A larger one (500GB) for my main OS. Two days ago I went onto the backup system to check it was working since hadn’t opened in more than a year. It is Debian because my computer programmer son uses it so I thought why not, it doesn’t need to update much so good for a backup. But on updating after a year, the var file was too small to accept the update for some reason so I couldn’t update. So I decided to have Manjaro be the backup and managed to install it by erasing that 250 GB (sda) disk and putting in a btrfs system. Now I think I made a small mistake: I told it to use the sda for booting whereas my main OS is on sdc. Anyway, I installed and then on rebooting it goes to the sdc boot screen which used to show the Debian just fine, and then still did and didn’t see the new system. So by a process of elimination learned to go into the boot menu, hit C and then it would bypass all the grups and go to the new system on sda.

Then I compounded the error. I installed (side by side) a new Nobara OS based on Fedora because the reviewer said it took care of so many installation problems etc. and I thought maybe the grub thing would repair itself magically with a second install. That went fine - and I must say their graphics after doing the Nvidia scripts are decidedly better than what I usually see in Manjaro with the nvidia installed so that is interesting I guess - but the same problem with booting up: it goes to the origina boot-up screen, still showing Debian, but now an EMERGENCY problem:

Now I cannot boot up the old system. No matter how many fallback images or saved snapshots. Except one time it worked and Timeshift prompted me to do a restore which I did after which I’ve never got back into my main Manjaro OS. At one point I did a restore from the new Manjaro so now the boot up screen has changed to include both Manjaros but not the Nobara, but they don’t work, I have to go out of those screens and then hit C or exit or whatever and I get there in the end to the new systems, a screen offers me either NObara or Manjaro on the sda drive and here I am.

I tried the chroot things from searching for solutions but none of them work. OR: I am unable to follow the instructions with lots of strange letters as examples that I guess I don’t know what they mean.

I would like to be able to restore my main OS and will happily delete everything on the new drive to start over but I cannot figure out how to do it, and cannot access my main OS.

Any help much appreciated.

can you boot with USB live manjaro
open a terminal and a browser on this topic
and provides

inxi -Fza
sudo parted -l
1 Like

Thank you.

[sudo] password for ash: 
Model: ATA CT240BX500SSD1 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  115GB  115GB   primary  btrfs
 3      115GB   116GB  1074MB  primary  ext4            boot
 4      116GB   231GB  114GB   primary  btrfs
 2      231GB   240GB  9449MB  primary  linux-swap(v1)  swap

Model: ATA ST2000LM015-2E81 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name     Flags
 1      1049kB  1064GB  1064GB  ext4         2TBData
 2      1064GB  2000GB  936GB   ext4         STBBU1

Model: ATA SAMSUNG MZMTE512 (scsi)
Disk /dev/sdc: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  9437kB  8389kB
 4      9437kB  316MB   306MB   fat32                 boot, esp
 2      316MB   8704MB  8389MB  linux-swap(v1)        swap
 3      8704MB  512GB   503GB   btrfs

I notice that the partition table on sda - where I am now on the new backup OS Manjaro Gnome - is MSDOS, whereas the partition table in sdc (my main OS = Manjaro Gnome) is gpt which is what I wanted for this new OS on the smaller 240 GB HD (sda). Maybe that has nothing to do with it. Anyway…

can you provide

inxi -Fza

other question
sdb seems to be ok
on sdc is it really manjaro ? or something else ?

you cant mix MBR and GPT disks

  Kernel: 6.1.22-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=dd97e1f0-830f-43b7-ad9e-879a45733be5 rw rootflags=subvol=@
    quiet splash apparmor=1 security=apparmor
    resume=UUID=8df1bb2d-4816-4352-8cee-e53b2ded4b63 udev.log_priority=3
  Desktop: GNOME v: 43.4 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 24415QU v: ThinkPad W530
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 24415QU serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: G5ETB2WW (2.72 ) date: 06/11/2018
  ID-1: BAT0 charge: 5.7 Wh (100.0%) condition: 5.7/47.5 Wh (12.0%)
    volts: 12.0 min: 10.8 model: SANYO 45N1001 type: Li-ion serial: <filter>
    status: full
  Info: model: Intel Core i7-3840QM bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x20
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1239 high: 1442 min/max: 1200/3800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1200 2: 1442 3: 1200
    4: 1197 5: 1200 6: 1197 7: 1200 8: 1281 bogomips: 44713
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166
    class-ID: 0300
  Device-2: NVIDIA GK107GLM [Quadro K1000M] vendor: Lenovo driver: nouveau
    v: kernel non-free: series: 470.xx+ status: legacy-active (EOL~2023/24)
    arch: Kepler code: GKxxx process: TSMC 28nm built: 2012-18 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
    active: none empty: DP-1, DP-2, DP-3, LVDS-2, VGA-2 bus-ID: 01:00.0
    chip-ID: 10de:0ffc class-ID: 0300 temp: 42.0 C
  Device-3: Bison ThinkPad Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-1.6:6 chip-ID: 5986:02d2 class-ID: 0e02
  Display: wayland server: X.org v: with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: LVDS-1 model: Lenovo 0x40b2 built: 2009 res: 1920x1080 dpi: 142
    gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: OpenGL v: 4.2 Mesa 23.0.1 renderer: Mesa Intel HD Graphics 4000 (IVB
    GT2) direct-render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  API: ALSA v: k6.1.22-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.67 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active tools: pacat,pactl
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e
    v: kernel port: 7080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0085 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Broadcom BCM20702 Bluetooth 4.0 [ThinkPad] type: USB driver: btusb
    v: 0.8 bus-ID: 1-1.4:5 chip-ID: 0a5c:21e6 class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 2.5 TiB used: 777.06 GiB (30.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX500SSD1
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 041 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000LM015-2E8174
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0001 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: MZMTE512HMHP-000MV
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 1M0Q scheme: GPT
  ID-1: / raw-size: 107.38 GiB size: 107.38 GiB (100.00%)
    used: 19.58 GiB (18.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 107.38 GiB size: 107.38 GiB (100.00%)
    used: 19.58 GiB (18.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 107.38 GiB size: 107.38 GiB (100.00%)
    used: 19.58 GiB (18.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nouveau temp: 42.0 C
  Fan Speeds (RPM): fan-1: 2724
  Processes: 334 Uptime: 1h 13m wakeups: 1 Memory: 30.91 GiB
  used: 3.36 GiB (10.9%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1245
  pm: pacman pkgs: 1239 libs: 326 tools: gnome-software,pamac pm: flatpak
  pkgs: 6 Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.26

If I cannot mix MBR and GPT disks, does this mean I need to erase all the new installations and start over? Why did the installer install a btrfs system on non GPT disk?

But mainly: how can I go and rescue my system on the sdc disk? Yes, it’s Manjaro and nothing else, with all the Timeshift backups sitting there but I cannot use them apparently.

I can also open all the files on sdb and see sdc and open up those directories too, though am not touching anything.

this is not good , boot on USB live manjaro is failback to MBR boot

so go in UEFI motherboard and recheck all options

  • no Secure boot
  • no CSM
  • all disks on AHCI
  • no fast boot
  • only USB mass storage


Thank you. Will try now.

This is over my pay grade. But thank you. I am going to scrub this new hard-drive and not install anything else. Then I will not be able to use any OS at all except on a flash drive. Hopefully there is a way to restore my main system via Timeshare or repairing the grub menu or some such but first I will get rid of this new hard drive and both OS’s on it - which work, but are seemingly part of the problem with my main OS that I can no longer acess via the grub menu. The menu displays, but all options I choose do not boot up any more.

from live iso USB ?

I deleted the new OS’s in the backup SSD which is now empty and GPT.
But the bootup menu for my default OS, which still comes up every time, still yields no joy. None of the options results in a bootup. So now I am on a live iso unable to access my installed OS and not yet knowing how to repair the grub file - or whatever it is - so that it can boot up again properly.

you should see
UEFI < USB vendor name > < partition 1 > → boot in EFI

open a terminal and check before install

inxi -Mxa ( check for UEFI only )
test -d /sys/firmware/efi && echo efi || echo bios

if efi , then check also

sudo efibootmgr 

for restore grub manjaro , you go in chroot ( prompt red #)
( check both / and /boot/efi mount from sdc )

sudo manjaro-chroot -a 
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck 
mkinitcpio -P
efibootmgr -v
exit ( end chroot ) 

I cannot do the chroot, seemingly.

sudo manjaro-chroot -a sdc                                    ✔ 
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
==> ERROR: No Linux partitions detected!
    ~  sudo manjaro-chroot -a sdc4                        255 ✘  6s  
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
==> ERROR: No Linux partitions detected!
inxi -Mxa                                       1 ✘  13m 16s  
  Type: Laptop System: LENOVO product: 24415QU v: ThinkPad W530
    serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: LENOVO model: 24415QU serial: <superuser required> UEFI: LENOVO
    v: G5ETB2WW (2.72 ) date: 06/11/2018
    ~  test -d /sys/firmware/efi && echo efi || echo bios            ✔ 
    ~  sudo efibootmgr                                               ✔ 
BootCurrent: 000D
Timeout: 0 seconds
BootOrder: 0000,0001,0002,0003,000D,0008,000C,000A,000B,0007,000F,0009,0010,0011,000E,0012
Boot0000  Setup	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0001  Boot Menu	FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0002  Diagnostic Splash Screen	FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0003  Lenovo Diagnostics	FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0004  Startup Interrupt Menu	FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0005  ME Configuration Menu	FvFile(82988420-7467-4490-9059-feb448dd1963)
Boot0006  Rescue and Recovery	FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0007* USB CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0008* USB FDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0009* ATAPI CD0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35401)
Boot000A* ATA HDD0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot000B* ATA HDD1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot000C* ATA HDD2	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot000D* USB HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot000E* PCI LAN	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot000F* ATAPI CD1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35404)
Boot0010  Other CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35406)
Boot0011* ATA HDD3	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f604)
Boot0012  Other HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f606)
Boot0013* IDER BOOT CDROM	PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,1,0)
Boot0014* IDER BOOT Floppy	PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,0,0)
Boot0015* ATA HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot0016* ATAPI CD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
Boot0017* PCI LAN	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot0018  OEM Hot Key	FvFile(0b5a75d0-2793-4efa-bfa7-74689122fa55)

just sudo manjaro-chroot -a ( nothing else )
you should have lines 0) or 1) ( always 1 to select ) or more

sudo manjaro-chroot -a                                 255 ✘  6s  
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
==> ERROR: No Linux partitions detected!

I tried that first, also before I came to forum. Unable to use chroot.

Very frustrating. All those timeshift images are there. But cannot use them. I think I’m going to give up soon trying to back up OS’s or trying to configure themes I like etc. since every time there is a crisis, I can’t do anything except re-install all over again. Also frustrating because entire system was working great for so long that I never even booted into my backup OS but when I tried to install a new one yesterday, I lost the original one on a different HD. It’s still there, but I cannot use it.

I think I’ll be deleting it soon and starting all over with a fresh OS but none of the themes etc. I like and much too complicated to try to reconstitute it.

And was checking out the installation menu and if I want to re-install it, it will not only erase everything but also not give me the option to use a Swap file, it will erase that too for some reason. The whole installation business is a pain and so dangerous for other OS’s etc. Very frustrating!!!

ok i see from sdc :
1 1049kB 9437kB 8389kB this is a bios-grub (8Mo) partition

==> reboot on USB MBR ( active CSM only)
==> put on sdc1 flag bios-grub ( boot & esp will be removed from 4 , as you cant get full UEFI and disks )
with Gparted & flag options
==> recheck return

sudo manjaro-chroot -a
grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sdc
exit ( end-chroot)

Thanks, the

sudo manjaro-chroot -a

still doesn’t work for me, so nor does the second line.

grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sdc