"No EFI system partition configured" during install despite being configured in the partition section

I am doing a fresh install of manjaro on a blank drive. Once I finish setting up my partitions, I get an error stating that I have not configured the EFI partition, and need to create a FAT32 partition with boot flag enabled and mounted to boot/efi. That’s exactly what I had done in the previous step – the very first partition is a 200MiB partition, fat32, mounted to /boot/efi and the boot flag is selected under flags.

So I am very confused as to what’s causing this and what I am doing wrong. Any help would be greatly appreciated.

1 Like

I screenshot would be handy to see exactly your partitions.
Also, check your boot sequence in your BIOS/UEFI, if it points to that drive.

check info in your UEFI motherboard

disable secure boot
disable fast boot
disks on AHCI
no legacy
no CSM
UEFI only or others ( not windows )

you should see
UEFI < USB vendor name > < partition 1 > → boot in EFI

open a terminal and check before install

inxi -Mxa ( check for UEFI only )
test -d /sys/firmware/efi && echo efi || echo bios
sudo lsbk -fs ( check uuid /boot/efi)
sudo parted -l ( disk format should GPT)

you can also use Gparted to format and create partitions size

I tried, but it seems that I don’t have permission to post screenshots yet as I just created my account here.

Either way, I ignored the warning and my system installed just fine, I can boot into manjaro no problem. I don’t know what that prompt was about, but my best guess is that the installer was looking for an existing efi partition that simply wasn’t there yet and gave me an error because of that. Purely uneducated speculation though.

As I mentioned in another reply, just ignoring the warning and proceeding with the install worked fine. I did boot into the live usb again though to see if I get the warning again; I still do, so I went through your steps, results are below:

All bios settings are correct
I am indeed in UEFI mode


Machine:   Type: Desktop Mobo: BIOSTAR model: X470NH serial: <superuser required> UEFI: American Megatrends LLC. v: 5.17 
           date: 02/23/2021

test returns efi

Output of parted for my drive here:

Model: Samsung SSD 970 EVO Plus 1TB (nvme)
Disk /dev/nvme0n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 3      1049kB  269MB   268MB   fat32                 boot, esp
 1      269MB   17.0GB  16.8GB  linux-swap(v1)        swap
 2      17.0GB  69.5GB  52.4GB  ext4
 4      69.5GB  1000GB  931GB   ext4

Full output of lsblk here:

NAME      FSTYPE      FSVER         LABEL              UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0     squashfs    4.0                                                                         0   100% /run/miso/sfs/livefs
loop1     squashfs    4.0                                                                         0   100% /run/miso/sfs/mhwdfs
loop2     squashfs    4.0                                                                         0   100% /run/miso/sfs/desktopfs
loop3     squashfs    4.0                                                                         0   100% /run/miso/sfs/rootfs
sda2      ntfs                                         8C2E5B532E5B3584                                    
sda3      ext4        1.0                              0d7e504c-4891-4655-87e8-7fd9e209e596                
sda4      ext4        1.0                              a4fa1e1d-83cd-4f9b-a5ce-0fc9c66f33a8                
sdb1      vfat        FAT32                            B152-775E                                           
sdb2      swsuspend   s1suspend                        080f1af3-166a-4350-b647-0348b5ed5362                
sdb3      ext4        1.0                              2fc5424c-bdda-4157-a212-78f0e95447ef                
sdb4      ext4        1.0                              02c663d1-fa62-4675-a54e-ba4cdebe0e60                
sdb7      ntfs                                         329E84B19E846EE3                                    
sdc1      crypto_LUKS 2                                1b78ed90-ddfd-4c69-8b04-0b6f358226fd                
sdd1      iso9660     Joliet Extens MANJARO_GNOME_2113 2021-09-16-12-15-29-00                              
└─sdd     iso9660     Joliet Extens MANJARO_GNOME_2113 2021-09-16-12-15-29-00                     0   100% /run/miso/bootmnt
sdd2      vfat        FAT12         MISO_EFI           E45F-2361                                           
└─sdd     iso9660     Joliet Extens MANJARO_GNOME_2113 2021-09-16-12-15-29-00                     0   100% /run/miso/bootmnt
nvme0n1p1 swap        1                                a4e93aef-fa32-4fc4-af7d-ff92880e7153                
nvme0n1p2 ext4        1.0                              21c89769-b282-4d51-8a5e-9c5144118cce                
nvme0n1p3 vfat        FAT32         NO_LABEL           D861-8147                                           
nvme0n1p4 ext4        1.0                              923523d9-7cc0-44d7-94cc-99572d0604cc                

One curious thing I don’t understand is why the number for my efi partition is 3, as I had that set up as the first partition.

have you mixed disks MBR & GPT ?
sda is MBR or GPT ?
sdc is MBR or GPT ?

maybe missing flag ESP , have you checked with gparted before reboot ?
other try with 512Mib for /boot/efi

sudo parted -l

I had a similar problem when I installed Manjaro for the first time in Lenovo Ideapad.

The problem was with the VMD controller. When the VMD controller is on the Manjaro does not boot up and returns Disk bot found or bootable partition not found.

Make sure of two things:

  1. You make a separate boot partition instead of the given 100 MB partition.
  2. And Turn the VMD controller off from the secure mode.

Hope it helps.

There is a “bug” in Calamares where it complains about the EFI partition if it is smaller than 500MiB. I think is already fixed, but I suppose it should land in the next ISO version.

EDIT: Manual partition shows wrong error message · Issue #1761 · calamares/calamares · GitHub

1 Like

thank you very much for your help.