Unable to boot on the RPI 4

Hi there,

After the ARM stable update on 2021-06-18 my RPI 4 was unable to boot. Inserting the micro SD card and powering it up reveals a solid red and green line on the board, and then nothing happens.

I made a comment in the forum post regarding that same stable update - link - but only now did I had the time to look further into it, and it seems that there is a problem with the image itself that leads to an unbootable system, that has now been fixed (according to a comment in that same thread and a comment on a different thread saying that all RPI images have been rebuilt).

The problem is I would like to keep my system the way it is, and reflashing a different image would erase everything I had done so far. How should I proceed in order to make my RPI 4 boot again without having to completely reinstall and reconfigure everything?

It probably doesn’t make any difference but I have the minimal headless version installed.

I went back and read your posts in that thread. It appears that initially after the upgrade it would boot but froze after ssh to it. Then after that you were unable to boot at all after pulling the power plug. I am afraid that there is corruption now at different places on your sdcard and would be hard to figure out what all is corrupted.

Other than the controller going bad on the sdcard the other thing that comes to mind is too much overclock with the cpu can cause corruption with large upgrades.

I have never performed any type of overclocking on my system.

Is there a way to fix corruption? I’ve tried using fdisk but I was unable to, but I think it’s because of my USB to SD card adapter, since it seems that I am unable to unmount the partition but keeping it available in dev.

Otherwise, if fixing the corruption isn’t possible, is there any other way to restore the system? The only that I can think of is copying as much config files as I can, reinstall the packages, and then replace the config files.

It seems that the issue might be bigger after all, I’ve downloaded the latest available image for the Manjaro ARM Minimal for the Raspberry Pi 4, flashed it into my micro SD card (without errors) and when inserting it in the RPI the green and red light stay always on as they were before.

There were no errors shown while flashing with Balena Etcher nor with GParted when I was resizing the partitions to increase the root partition size.

This would make me assume that the problem is either the SD card or the RPI itself, but I don’t think I have any other SD card laying around nor another RPI.

Try booting the device before you resize it?

The system will resize itself as part of the First Run setup.
Changing the partitions before that, might mess up the drive designations.

Thanks for the help, but the issue remains, I left it there for a whole minute and both lights remain solid on. The ethernet cable doesn’t flash any light by contrast.

I only fanshim setup, it’s not even connected to the GPIO but I’ll remove it regardless, it might be causing something weird to happen.

Nope, still the same behavior, strange. I did flash the SD card again to ensure everything was alright.

I’ll look into getting another SD card or use another distribution, it might be because of that.

try the latest release 21.07

I’ll try it tomorrow, hopefully with a new SD card, since I tested this out with Ubuntu Server (64 bit) and the same thing happened, so it’s very likely that it is the SD card. Thanks for the link, didn’t know that everything was there.

I’ve tried the latest Manjaro build using my cellphone SD card and it doesn’t work either.

It seems to me that this is most likely a problem with the Pi itself instead of the SD card or the OS.

Try flashing the eeprom with a recovery image. Read under Recovery on this page.


I’ve downloaded the rpi-imager from the AUR, then pressed Choose OS > Misc utility images > Bootloader > SD Card Boot.

After inserting it on my RPI the same thing happened, providing further evidence that this might be due to the RPI itself. (I let it sit the for over a minute and tried with two different SD cards)