Unable to boot Manjaro KDE after installation

It booted perfectly with USB, after testing I decided to install it. I’m familiar with installing linux/ubuntu distros, I decided to manual partitioning using MBR option since my laptop system uses BIOS. After that, the installation program asked me to change the partitions to GPT and adding an additional unformatted partition of 8MB with bios-grub flag enabled. I did as requested, and after finished the installation, I restarted and it didn’t boot. It was only showing me a black screen that flashes on and off every second.

  Kernel: 5.15.59-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=ebe5008f-92c2-44b5-9fc5-c1497262103c rw quiet
    resume=UUID=dc749f11-436c-4cee-af52-a073891a6135 udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: SAMSUNG product: 300E4A/300E5A/300E7A/3430EA/3530EA
    v: 0.1 serial: <superuser required> Chassis: type: 9 v: 0.1
    serial: <superuser required>
  Mobo: SAMSUNG model: 300E4A/300E5A/300E7A/3430EA/3530EA v: FAB1
    serial: <superuser required> UEFI-[Legacy]: Phoenix v: 03QA date: 12/14/2011
  RAM: total: 5.71 GiB used: 2.58 GiB (45.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i3-2350M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 built: 2010-12 process: Intel 32nm family: 6 model-id: 0x2A (42)
    stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 829 high: 924 min/max: 800/2300 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 924 3: 798 4: 798
    bogomips: 18367
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est
    flexpriority flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce md_clear
    mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pebs pge pln pni popcnt pse pse36 pti pts rdtscp sep ssbd sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme
    vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Samsung Co driver: i915 v: kernel arch: Gen-6 process: Intel 32nm
    built: 2011 ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0116 class-ID: 0300
  Device-2: Silicon Motion WebCam SC-03FFL11939N type: USB driver: uvcvideo
    bus-ID: 1-1.4:3 chip-ID: 2232:1028 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: Seiko Epson 0x4249 built: 2011 res: 1366x768
    hz: 60 dpi: 112 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 22.1.4
    direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Samsung Co driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.59-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Centrino Wireless-N 130 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:0896
    class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Samsung Co driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB
    driver: btusb v: 0.8 bus-ID: 2-1.3:4 chip-ID: 8086:0189 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 5 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 298.09 GiB used: 14.17 GiB (4.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF032
    size: 298.09 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A scheme: MBR
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SN-208BB rev: SC00
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 289.29 GiB size: 283.68 GiB (98.06%) used: 14.17 GiB
    (5.0%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: ebe5008f-92c2-44b5-9fc5-c1497262103c
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: dc749f11-436c-4cee-af52-a073891a6135
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.4:3 info: Silicon Motion WebCam SC-03FFL11939N type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 2232:1028 class-ID: 0e02
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.1:3 info: YICHIP Wireless Device type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 3151:1002 class-ID: 0301
  Device-2: 2-1.3:4 info: Intel Centrino Advanced-N 6230 Bluetooth adapter
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    chip-ID: 8086:0189 class-ID: e001
  Device-3: 2-1.5:5 info: TABLET Pen type: Mouse driver: uclogic,usbhid
    interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 50mA chip-ID: 256c:006e
    class-ID: 0301
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 212 Uptime: 22h 1m wakeups: 1 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
  Packages: 1202 pacman: 1197 lib: 322 flatpak: 5 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20

What did I do wrong and how can I fix it? I installed the system erasing all and skiping the manual partitioning and it worked but I need to make the partitions so I can have /home separed from the rest.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

You can find good Information about Btrfs in the wiki

Following you explanation, I assume you did nothing wrong. Is your BIOS capable to boot from GPT? I believe the GPT Option is only for UEFIs with legacy mode. Not all pure BIOS can handle GPT Partitions for booting.

Try disabling SecureBoot in BIOS.

I would recommend btrfs with timeshift snapshots. If updates brakes your system in the future, you will be able to roll back to last working snapshot.

Hi! thanks for the suggestion, it’s done I have already edited my post with all the info.

thanks for the suggestion, I’ll make sure to use timeshift and I’ll keep in mind using btrfs partitions.

How could I know if my bios is capable to boot from GPT?

If it can recognize HDDs of 2TB and above. But generally speaking, you have to try it.

As I see you have an UEFI, not a pure BIOS, so you start it in UEFI Legacy mode:

However, if you want avoid UEFI, then just use MBR instead of GPT, but legacy mode plus GPT goes like this:

  1. 8MB flagged with bios_grub
  2. 1GB flagged with legacy_boot → /boot
  3. (RAM * 1.5)GB Swap
  4. 30GB for root → /
  5. The rest → /home.

Anyway, if you can use UEFI, then I would recommend using it instead of legacy mode.

On bios setup I enabled the option of UEFI support, and I did the partitioning as you recommended but I got the same error. After the partitioning part I got this message

“To configure an EFI system partition, go back and select or create a suitable filesystem. The filesystem must be mounted on /boot/efi. The filesystem must have type FAT32. The filesystem must be at least 300 MiB in size. The filesystem must have flag boot set.”

maybe I should had created that partition.

Sorry but :man_facepalming:, read again… I said this is for legacy mode / BIOS mode.

Of course…

Oh I may have misunderstood.
So, since I want to use UEFI, should I just add this partition mounted on /boot/efi and do the partitioning as before?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.