Tuxedo Manjaro Pulse 15 - Multiple issues with system as delivered


two days ago I got my Tuxedo Manjaro Pulse 15 that I was very excited for.
Unfortunately, some things just don’t work.

The first issue was reported on these forums elsewhere, but I’m not allowed to post links :roll_eyes:
The title of the thread is “Manjaro-settings-manager language issue”.
When trying to install language packages via Manjaro Settings Manager, this just fails.
More precisely, it doesn’t ask for root password, and then fails with a permission error.

[system] Activating service name='org.manjaro.msm.languagepackages' requested by ':1.48' (uid=30000 pid=1495 comm="/usr/bin/systemsettings ") (using servicehelper)
[system] Activated service 'org.manjaro.msm.languagepackages' failed: Failed to execute program org.manjaro.msm.languagepackages: Permission denied

The other issue I have is that the function keys for screen brightness don’t do anything.

Finally, the LED that is supposed to indicate whether the touch pad is locked, doesn’t work as well.

I didn’t really change anything about the system, these issues exist after a fresh installation (i.e., as the device was shipped).

Any help would be appreciated!
If more information is required, just let me know.

The least important issue, i.e., touch pad LED, is fixed by installing tuxedo-touchpad-switch and rebooting.

I’m already in contact with Tuxedo support, they say I’m supposed to get help here because they only provide the hardware and this is a software issue (and they don’t provide the software).

As this is some sort of cooperation between Tuxedo and Manjaro, I don’t care who fixes this, but if it doesn’t get fixed the device is going back (would be a shame though).

1 Like

I don’t know anything about Tuxedo hardware but in any case no warranties of any kind attached.

From the message it looks like you are using KDE.

If you didn’t provide any password for the first user - then you will have a problem changing system settings.

Autologin can have a similar effect

The easiest method is to use localectl to set keyboard and system locale


localectl list-locale

Then example for Germany

sudo localectl set-locale de_DE.UTF-8


localectl list-keymaps

Then where the first is console and the second is X

sudo localectl -set-keymap de de

Well, I ordered a laptop from them and it’s not working as advertised, there’s 2 years warranty.

Anyways, certainly I did provide a passwort for my user account.
The password prompt when using sudo is working in the terminal.
The graphical password prompt is working as well, e.g., when using pamac CLI.
It just doesn’t seem to work with the Manjaro Settings Manager (MJM).

My locales are fine (they can’t be changed via MJM due to the same problem though).
The issue is that the graphical password prompt is not triggered somehow.
I found that the same issue occurs when I click “install open source drivers automatically” in MJM.
Just fails with permission error, without asking for password.

I do appreciate your attempts at helping!
But I think the things you suggest don’t have anything to do with my problem.

I just tested Manjaro Settings Manager on a regular XFCE installation:



… and was able to install suggested Language packages just fine.

Well, the ticket is not closed yet and the guy on the phone was nice.
I think they’re trying to help as well, I’m gonna give this whole thing a week or so.

That is an issue with a single application - and I don’t know what the issue is - but it is hardly a cause for loud dissatisfaction.

Thanks for trying that out. I’m on KDE Plasma and also have another device where Manjaro KDE runs on and this doesn’t have any issues as well.
Seems to be an issue with whatever modifications were made for the Tuxedo device.

@all thanks for all the replies, I can hardly keep up replying!

Tuxedo is using their own way on how to install Manjaro. Therefore some needed packages can be missing, which we ship with our install medias otherwise. You could try to download our official KDE build boot that up and see if MSM works as expected. Sure some additional tuxedo packages might be needed to been installed.

Another option would be to send the output of pacman -Q and use pastebin to share that content. Then we may compare it with a regular package list to see if we can spot some missing package.

There may be some hardware tweaks which is detected and installed by mhwd but I really don’t think the software differs that much from a default Manjaro installation - and certainly not the Manjaro Settings Manager - maybe some Tuxedo theming and packages to control keyboard backlight et al.

My initial comment was only to give some ideas of where to look or what to do.

The ideal method to share the package list to compare is

echo $(pacman -Q) | curl -F 'f:1=<-' ix.io

Then share the shorlink returned

The set of packages and maybe settings may differ from install medias we provide. Tuxedo is not using our OEM services we normally provide to our vendors. They have their own install system called WebFAI.

Here’s the package list: http://ix.io/3RXF

I already thought about just installing an official Manjaro KDE image, but that’ll take a bit more time.

Well, there are slightly different packages installed as you can see here. Have to see what might be the issue. MSM uses KAUTH_HELPER as found here, which uses polkit-qt5. Currently have a hard time to figure out what might be missed. Maybe some group setting of the user or so.

I have never seen any open source software that comes with warranty, I know that is what you and many desire but it just does not happen with any Linux hardware, usably they install your distro of choice as a convenience service but there is no support.

Also I don’t think any of you posts how a manufacturer should work is going to help the original poster in fixing is issue in any way.

I see. I did generate a diff myself, but can’t pinpoint any packages that may be related.
The more interesting ones are probably

  • kinit
  • lib32-libxmu ?
  • lib32-libxt ?
  • manjaro-kde-settings (already tried that, didn’t help but changed my shell from bash to zsh with a pretty nice prompt)

There are a couple of others (as you probably have seen) that I’m rather sure are unrelated.
I’m downloading the official KDE image currently… kinda defeats the purpose though (as I could do that with any other laptop as well :D)

You could check with groups <username> in which groups you are in. If wheel is missing you may add the user to that one: usermod -a -G wheel <username>. A normal manjaro user is in: wheel tty lp uucp sys lock network power autologin <username>.

These are my groups wheel lp optical storage video sys network scanner power <username>.
wheel is there, but some others are missing.
tty missing looks strange intuitively, but I don’t know what that group is for.
What about the others, could uucp or lock be related?

what happens if you start it with sudo manjaro-settings-manager? somehow it is about permissions after all via kauth and polkit. Code-wise it executes pacman as root.

Interesting, even when launched with sudo it fails in the same way!
It says “Waiting for user input” - and then just continues without asking.
Unfortunately I don’t have experience with polkit rules, there’s always something new to learn :smiley:


Have to check with one of our developers on what might be wrong with Manjaro-Settings-Manager. I’m sure it will work on our official builds as otherwise we would have a lot of issues in that regard. On my end I added my user to sudoers file without asking a password for pacman. In the end what the UI does is installing language packages based on a list via pacman. So you could get that list and use pacman directly to have the same effect.

manjaro-settings-manager /usr/share/polkit-1/actions/org.manjaro.msm.kernel.policy
manjaro-settings-manager /usr/share/polkit-1/actions/org.manjaro.msm.keyboard.policy
manjaro-settings-manager /usr/share/polkit-1/actions/org.manjaro.msm.languagepackages.policy
manjaro-settings-manager /usr/share/polkit-1/actions/org.manjaro.msm.locale.policy
manjaro-settings-manager /usr/share/polkit-1/actions/org.manjaro.msm.mhwd.policy
manjaro-settings-manager /usr/share/polkit-1/actions/org.manjaro.msm.users.policy