Tuxedo Manjaro Pulse 15 - Multiple issues with system as delivered

Thanks a lot for your help so far :slight_smile:
On my end I’m gonna try out the official build and then report back.
I’d also expect that MSM will just work.
The brightness keys are a different story though, but one thing at a time…

I’m aware I could just install the packages via pacman or pamac, I just can’t stand if there’s something on my system that’s not working as it’s supposed to.

Well, normally MSM works as it is simple. However we have no clue if Tuxedo has some additional rules for polkit added. Regarding no password prompts I found this: polkit - ArchWiki

Well, not an good example but some community editions even bypass polkit: community/webdad/desktop-overlay/etc/polkit-1/rules.d/49-nopasswd_global.rules · master · Profiles & Settings / iso-profiles · GitLab - but ya, some is wrong with polkit setup somehow. What happens if you create a new user with sudo rights and one without sudo?

seems you start the module from kcm. what happens if you use the manjaro-settings-manager UI.

what is the output of: systemctl status polkit

Alright, I’m back from installing the official Manjaro Minimal LTS variant.

Manjaro Settings Manager works as expected and the brightness control function keys work out-of-the-box!
Touch pad LED and Tuxedo Control Center (TCC) function key don’t work yet (no wonder, TCC isn’t installed yet).

I then went head and installed tuxedo-touchpad-switch, tuxedo-keyboard, and tuxedo-control-center (and linux-headers), then rebooted.
Now the touch pad en/disable function key works, and the double-tap to lock feature for the touch pad works as well. The LED still doesn’t work though, but the double-tap feature itself somehow seems to work more reliably.
TCC function key also not working.

This state is arguably much better than the one I described in the very first post.
Maybe the last few issues can be fixed as well.

@philm Thanks a lot for all the suggestions to try and the support! Because I was (after trying out the live system a bit) installing the other Manjaro version, I didn’t get to try all of them.
I always launched the settings manager via GUI, the log entries are from journalctl after the bug happened.
I didn’t try creating the additional users or systemctl status polkit.

Edit: Shutting down takes forever somehow :roll_eyes:
Edit2: Wayland was used by default and journalctl showed “stuff”/warnings/errors related to wayland before shutdown. Logged out, logged back in with X instead, shutdown, problem solved.
Edit3: Seems that also fixed the issue with the touch pad LED and TCC function key, both work now :scream: Looks like everything works now?
I’ll see over the couple of days and will also update Tuxedo support on this.


Well, this simply tells me that there is something missing from Tuxedo in installing our OS. Sure, the extra packages needed for the Tuxedo Notebooks we ship in our repos but don’t have it pre-installed in regular ISOs. With our other hardware vendors we have all the hardware in-house and make sure from our end that they work. This is with Starlabs and Minisforum. Tuxedo and the Belgian shop do their own spins of Manjaro without our testing.

I’ll check with Tuxedo at some point in how we may improve things. TCC button might send out a key-combination, you may map an app to that key. Look the docs for hotkeys: Tutorials/hotkeys - KDE UserBase Wiki

You’re replying quickly! I added another edit to my previous post while you were replying, the function key issue is solved :slight_smile:
Thanks a lot again!
Fingers crossed that no new issues arise :smiley:

As a company and community we are known to reply fast to reported issues. Based on the package list, all the needed basics are given, however I don’t know how Tuxedo had configured our OS not behaving as it should. So if installing our official ISOs and adding the needed Tuxedo Software and configure those manually I’m glad we could solve it this way.

However we may need to do some rounds internally to see on how we may support Tuxedo to improve their install routine in that regard.

Enjoy the OS, the community and let us know if some is still open.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.