Turn off the screen when my raspberry turn off with kodi action

Since couple of days i’m running a manjaro minimal on raspberry 4 where i decided to install kodi on it because there no other choice now if i want kodi with no other graphical interface and the capability to install some other service behind via ssh now that osmc is not avaible on raspberry 4.

When i power on my raspberry, my TV turn on, i don’t know exactly what config is behind but it turn on. And now i want to try to power off that screen when i choose on kodi to power off my raspberry.

I’m not very good at creating a service, i saw that with tvservice -o, my screen can be power off but i’m not capable of making it at a service before shutdown.

So if someone have any information or tip to share that i can use to help me with that it could be very helpfull.

I have another things too, my cec-client don’t see anything, but on libreelec when i was on it, he worked out of the box if there is any information too but for me this is very optionnal.

Thanks in advance.

Your post is a little confusing and you have not given and config’s you have.

In my case here if I configure for my vizio tv I have to use fkms as my tv’s edid info is not being obtained and in this scenario my tv will not properly shutdown and a different version of libcec-rpi has to be installed than what is in our repo (6.0.2-2).

Here is the libcec-rpi package for using fkms.


It is recommended by kodi to use kms which is not possible with my tv but is with my gateway monitor. Using my gateway monitor and kms the libcec-rpi in our repo works and the monitor will properly shut down.

[ray@pi4 ~]$ pacman -Ss libcec-
community/libcec-rpi 6.0.2-3 [installed]
    Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter (Raspberry Pi using

I’m running into a similar issue with my pi and kodi. As soon as I exit kodi or close the window, my TV will shut off. When I turn it on, the resolution of the DE will reset to its Max. Its frustrating having to redo the resolution every time. It may have something to do with the kms to fkms settings. From my understanding, can I just install the libcec-rpi-fkms and just replace this line in the config from:

My config below:
#gpu_mem=64 #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2 #disable cause kodi uses more

Your post is a little confusing. Did you set up for kodi as posted here in post #1?


Yes exactly like that. However I did not set it up to boot directly into kodi. I’m running it from DE sometimes from terminal alt f2 depending if I need hvec stream. Unless the rpi-kodi is not meant to be run from DE which would probably be the issue. If that is the case, is it possible to have two kodi versions installed?

The kodi-rpi package is really set up to be a stand along media server as was mentioned in the link I posted above. After disabling whatever login display manager you may have and enabling kodi.service it will boot straight into kodi.

Trying to configure your system to boot so kodi will run and also have a DE removes configs that maximizes the DE. In this scenario you should lose HW decoding if trying to launch kodi from within a DE.

I realized that this issue im having with my TV and resolution being reset is not only from kodi. If I turn my TV off and back on randomly from the DE, my resolution is reset and will have to change settings. Any ideas how to fix this?

What is the tv resolution you are wanting?


It looks like when you open kodi it configures it’s self for a different video environment then when exiting kodi to go back to the DE it is trying to configure it’s self all over again and grabbing the higher resolution instead of what you desire. One would think that it would go with what you had previously set in the DE but evidently this is not happening.

One thing to try is manually setting the tv resolution in /boot/config.txt you want but looking at the available screen resolutions in the pi docs it appears that 1600x900 is an odd ball resolution and only has one choice for monitors that support Screen Blanking.


Add this to /boot/config.txt and reboot to see what happens. Try first with #hdmi_ignore_edid:0=0xa5000080 and if it does not work then un-comment that line and reboot.


Unfortunately, none worked. Is there a way to change the lock screen resolution? When booting the OS, the lock screen starts up at the Max resolution, then once entered into DE it will load the configured resolution. Maybe by changing the lock screen resolution to my desired one, it may save it from resetting all the time on the DE after powering off and on my TV monitor.

I figured out my issue with the resolution resetting. It has to do with another program called xscreensaver daemon which activates a screensaver. It turns out kodi is not at fault for that particular issue.

1 Like