Trying to install anbox on a pi 4

I installed Manjaro KDE on my pi 4 and have been loving it so far. I tried to install anbox with discover from testing repos and it installs quickly however when I try to launch it I am shown a “Starting…” screen and then it crashes. I’m semi-new to this so just explain this like I’m 10. Thanks in advance!

Can we see maybe which version is installed?

pamac search -i anbox

And then also maybe try starting it from the terminal and showing us that output.

pamac search -i shows that i have version 0_git20200927-1. When I run anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewAct ivity (the same command that the launcher uses) I get this message after the startup screen: [ 2020-10-29 04:08:08] [daemon.cpp:61@Run] [org.freedesktop.DBus.Error.ServiceUnknown] The name org.anbox was not provided by any .service files

It probably would have been better to copy the whole output.
I cant see that version anywhere in the repos or AUR … so maybe I can guess it is a SNAP ?

Like I said in the original post I am in the testing channel, here is the full output: anbox 0_git20200927-1 community I have had this same problem with the stable version

Mk.

(I forgot to look in the ARM repos … that version is there. I have also moved the thread to that section)

Have you started/enabled the service?

systemctl enable anbox-container-manager.service --now

I ran systemctl enable anbox-container-manager.service --now and I still got the same exact error both before and after rebooting.

Oh. it appears you still need an anbox-image* package too.
https://wiki.archlinux.org/index.php/Anbox

I installed anbox-image-aarch64 and got the same error, I noticed on the Anbox wiki page you sent mentioned something about certain kernel versions working. It looked like I had an older kernel version (5.4.72-1-MANJARO-ARM) so I followed the instructions however I was not able to install any of the packages needed probably because they were not available on Manjaro ARM

Sorry … I dont have a way to test myself right now.
Hopefully now that the thread is in the ARM section someone that can will see it.

That’s fine I will continue to look for a solution. Thanks for trying, if I find the solution I will post it here incase anyone else has the same problem.

First I am glad they finally updated the arch wiki; it was bad out of date.

The RPi folks has backported the android modules to the 5.4 kernel so do not install the dkms modules and do not modprobe them as they are built in the kernel.

What ever you have done along the way should be probably reversed and uninstall the anbox packages and start fresh; especially the anbox-modules-dkms-git package if installed. Then:

sudo pacman -S anbox-image-aarch64 anbox

Then reboot as there are some udev rules that needs to be picked up. Then:

sudo systemctl start anbox-container-manager.service

Then click on the Anbox icon in the menu to start it.

It will say Starting… for a while while the image is being decompressed although I do have it set to use all cores in the kernel. Here is where a usb drive would come in handy for speed.

After you get it going you can enable anbox-container-manager.service if you want it started at boot if desired. Also be advised that anbox has a way to go and is a little unstable and will crash trying to load some programs.

Thanks a lot this worked perfectly

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.