Trouble with: vmware-workstation

Greetings fellow Manjaro enthusiasts,

for work purposes it’s required to use VMware, so I installed the packages through pamac.

Description of the problem:

Error messages starting the virtual machine:

Could not open /dev/vmmon: No such file or directory. Please make sure that the kernel module vmmon’ is loaded.`

What I have done to fix the problem:

Googeling around and installing this package: ncurses5-compat-libs 6.2-1

Still the same error message.

So I looked up in Arch wiki to read in the article about vmware and executed the solution in the paragraph “Module Issues: /dev/vmmon not found”

Somehow it didn’t worked out and I checked the status with:

sudo systemctl status vmware.service

The reply is:

● vmware.service - VMware daemon
Loaded: loaded (/etc/systemd/system/vmware.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Fri 2020-09-04 20:45:41 CEST; 15min ago
Process: 52813 ExecStart=/etc/init.d/vmware start (code=exited, status=203/EXEC)
Main PID: 52813 (code=exited, status=203/EXEC)

Sep 04 20:45:41 0x00 systemd[1]: Started VMware daemon.
Sep 04 20:45:41 0x00 systemd[52813]: vmware.service: Failed to execute command: No such file or directory
Sep 04 20:45:41 0x00 systemd[52813]: vmware.service: Failed at step EXEC spawning /etc/init.d/vmware: No such file or directory
Sep 04 20:45:41 0x00 systemd[1]: vmware.service: Main process exited, code=exited, status=203/EXEC
Sep 04 20:45:41 0x00 systemd[1]: vmware.service: Failed with result ‘exit-code’.

Problem not solved. I don’t know what else to do to fix it… :sleepy:

Anyone an idea?

~ Sincerely, SudoSandwich

Which kernel are you using? Vmware player isn’t compatible with kernel 5.8 and unfortunately won’t be until Vmware is updated to the next release. It should work fine with 5.7 and 5.4lts

2 Likes

Hello,
Have a read also here:

2 Likes

Thank you both for replying so quickly, @sawdoctor and @bogdancovaciu! :call_me_hand:

After some reading into your solution guys, I chose to wipe the M2 SSD and install a fresh Manjaro system as host on the dektop with kernel 5.7.

The vmware-workstation works smoothly!

Tip: Don’t for get to activate AMD-V in the BIOS if you have an AMD processor.

~ Sincerely, SudoSandwich

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.