Could not open /dev/vmmon

Hello, I’m a bit new to arch linux and have no experience with vmware. When I attempt to start a virtual machine I create on vmware I get the error:

Could not open /dev/vmmon: No such file or directory. Please make sure that the kernel module `vmmon’ is loaded.

I attempt to fix it with the command: sudo vmware-modconfig --console --install-all. When I do this I get the the following error.

[AppLoader] GLib does not have GSettings support.
sh: /usr/lib/systemd/scripts/vmware: No such file or directory
Unable to stop services

Any help is appreciated. Thanks.

System Info:
Kernel Headers: 5.7.17-2-MANJARO
vmware version:vmware-workstation 15.5.6-2 (Downloaded from AUR)

Hello,

here is something from the VMWare article
https://kb.vmware.com/s/article/2146460

It means you do not have the linux-headers installed for your running kernel.
The following command will install the linux-headers automatically for all installed kernels but you are better using a LTS kernel:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Reboot and then run:
sudo vmware-modconfig --console --install-all

Also see this for a reference, as you mentioned 5.7 kernel:

2 Likes

Thank you for your response.
I tried running the command you listed and I’m still getting the same error. I installed linux-lts and linux-lts-headers as well but the error also occurs.

LTS kernel: 5.4.60-2-MANJARO (linux54)

I still cannot run sudo vmware-modconfig --console --install-all but after removing vmware workstation and reinstalling in the LTS kernel I do not get the original vmmon error. Thank you for your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.