Trouble mounting .iso files

I have tried using every tactic outlined on the wiki page. As well as the traditional “mount” commands. I have attempted using .iso files that I have previously mounted using these methods on this current system. Attempted on both Kernel 419 and 54 (freshly updated). Given full read/write permissions to the mounted files. Keep returning the following error which I’ve attempted to search for a fix but with no such luck. Please help!!!

init: wrong standard identifier in volume descriptor 0, skipping…
init: wrong standard identifier in volume descriptor 1, skipping…
init: wrong standard identifier in volume descriptor 2, skipping…
init: wrong standard identifier in volume descriptor 3, skipping…
…until finally
init: wrong standard identifier in volume descriptor 17, exiting…

Even if someone could explain what this error message is indicating could be a great help.

I also once met an ISO that couldn’t be mounted in any way. I had to do MKVRemux with VLC. There is also AUR (en) - Search Criteria: makemkv

Judging by mistake, it seems to me that you are doing something wrong. What is this ISO, CD, DVD, BD, this movie or something else?

I assume you have downloaded or created an ISO file or did you convert another type of image to ISO?.

what is the output of

file name.iso

name is the name of your iso file

I have downloaded an ISO file that is some compressed data that a friend of mine has sent me. I have the md5 checksum that I used to verify that the file was complete and not corrupted.

the output of that command is :
name.iso: data

Oh its a BD i believe, but its got many types of data on it. Not just video and audio, so I dont think this mkv convertor thing will work

If the output of the command I provided is ‘data’ then the ISO unrecognizable.
For the record this does not mean corrupt perse.

If it is as you told an bd, you could try

Installing udftools

sudo pacman -S udftools

and mount with

sudo mount -o loop -t udf /path/to/file.iso /path/to/mountpoint/

If it does not work, what is the output message you get?

1 Like

That worked! Thanks for your assistance and speedy responses. Could you please tell me what you mean by the data being unrecognizable and what sort of responses the ‘file name.iso’ should be returning?

I had udftools installed and was using a somewhat similar command that was not working:
sudo mount -o loop -t udf9660 …

or something along those lines. Does this mean my ISO type is of a different breed, hence making it unrecognizable? Sorry for all the questions, its good to learn these things.

Glad it worked.

It means it cannot recognize the file system it caries.

That can be because a corrupt file, wrong converting or simple because you did not build support for it (indeed a different ’ breed’ ).

If you want to know what it should look like, just do the same command again :wink: