How do I unmount this device?

Continuing the discussion from Trouble mounting .iso files:

This above discussion successfully mounted an iso. Now, I want to unmount it. I tried umount <target that I used when I mounted: /dev/sdf1>, but, it says it’s busy.

The mount command shows this:
/dev/sdf1 on /run/media/userid/1A12A09C2505F91C type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

I’ve closed all my apps and it still says it’s busy. There’s no copying, file manager, or other apps using this drive.

How did you mount it?

Likely not with:
sudo mount -o loop /path/to/file /path/to/mountpoint

unmount is probably:
fusermount -u /run/media/userid/1A12A09C2505F91C

since it is mounted as type fuseblk

Can’t hurt to try.


and yes, if it is busy, you have something still accessing some place inside the mountpoint

I used the wrong target mount path. umount works. Thanks!

I just used sudo umount and it worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.