Trouble installing Manjaro KDE on PC build with Nvidia 1050 TI

I think most consumer MOBOs these days do not have onboard graphics. Well, not just these days, I haven’t seen a consumer MOBO with onboard graphics in many years.

And OP is most likely using a CPU with no iGPU.


I looked through the BIOS and found nothing about an onboard GPU

Exactly, my friend who picked out the parts for me even told me there’s no onboard card.

Indeed ! If the CPU does not have a GPU option the onboard HDMI will probably not work. (It took me a few minutes to figure that out, I have a B540 and ryzen 5 3600 (no internal gpu unit))

I tried booting the live USB with Manjaro KDE with both the open source and proprietary drivers, both showed a black screen after choosing

Highly not recommended to install via an old installer, as configs have changed a lot.

I would recommend you to try using manjaro-architect… but the Manjaro team no longer releases the manjaro-architect ISO unfortunately, which makes me sad because that’s the ISO I mainly use. But it’s probably because it’s unmaintained now. It does get some updates though.

You could technically use it on the Live ISO… but you’d have to update that whole Live ISO to get the newest manjaro-architect because just updating manjaro-architect might break it due to partial upgrade and I don’t think that’ll work that well.

Edit: Oh also, the older ISO might be working because it contains the correct driver for your GPU, and the newer doesn’t by default. It’s a possibility. I wouldn’t know how to fix the issue though… I stick with AMD because it’s built into the kernel.

OK… maybe try this at least:

  1. Boot the ISO
  2. edit the menu with e
  3. add on the kernel parameter

Now the ISO should boot to the basic login prompt. Login there with:

username: manjaro
password: manjaro

Now you can try to start:

sudo systemctl start display-manager.service



to skip the login screen.

You can also change the TTY with CTRL+ALTF1 untilF9

At /var/log/Xorg.0.log you will get more information:

cat /var/log/Xorg.0.log | less

I put this in the “setparams” list inside the single quotes, but it didn’t boot. Is that where it’s supposed to go?

EDIT: Also worth noting is that when it goes to the black screen, my keyboard backlighting also turns off; wonder if this means anything.

It must be set after

linux /boot/vmlinuz-$version

Or after quiet on this picture:

Ok here’s what I got:

    Booting a command list
error: file '/boot/vmlinuz-' not found.
error: you need to load the kernel first.

Press any key to continue...

lol… $version is a placeholder, since I have no idea which version is there…

I ran it again just to make sure i entered it correctly (it was version $2) and it just gave a black screen.

I’m running that same Graphic card plugged into an older Acer motherboard with no issues.If you know the card is plugged in and working I’d suggest making sure something in the BIOS settings isn’t set wrong.You might try setting the BIOS back to default then see what happens.Also make sure secure boot and fast boot are not enabled.

Yeah I’ve looked thru the BIOS and fiddled with the settings, just set it back to default and no dice. Secure boot and fast boot are both disabled as well.

Tried to update your BIOS?

Tried to rewrite the USB stick after verifying the ISO is not corrupt?

You can also try the LTS minimal ISO with an older Kernel just to see if it boots with that. If it works maybe generate yourself a full ISO on GitHub following the instructions in the video and just changing the kernel to “linux54” instead of “linux513” Building your custom Manjaro ISO via Github Actions CI - YouTube

Ok so I was able to install Manjaro using the USB stick with the LTS minimal ISO paired with the command, (which is now also in the etc/default/grub file) but for some reason plasmashell isn’t starting. When I try and start it, it gives a TON of debug messages, ended with this:

terminate called after throwing an instance of 'std::runtime'
    what(): random_device: rdrand failed

anyone know what this error message means? i also have log files from dmesg and journalctl if you need info from those

Ok so I was able to build an ISO using the guide provided. Unfortunately, it stops at the

[OK] Reached target Graphical Interface

part whether launching with proprietary or open-source drivers. The does allow me to boot to a command line. I totally forgot about trying the

cat /var/log/Xorg.0.log | less

command, so I did. Unfortunately, it gave nothing. Also, when I try and start the SDDM, which seems to not be working upon sending the startx command, and when I try and launch it manually I get this error message:

x sddm.service - Simple Desktop Display Manager
    Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled) 
    Active: failed (Result: core-dump) since Fri 2021-08-20 20:59:24 UTC; 49s ago 
        Docs: man: sddm (1)
    Process: 2524 ExecStart=/usr/bin/sddm (code=dumped, signal=ABRT)
    Main PID: 2524 (code-dumped, signal=ABRT) 
    CPU: 22ms
Aug 20 20:59:24 manjaro systemd[1]: sddm.service: Scheduled restart job, restart counter is at 2.
Aug 20 20:59:24 manjaro systemd[1]: Stopped Simple Desktop Display Manager. 
Aug 20 28:59:24 manjaro systemd[1]: sddm.service: Start request repeated too quickly.
Aug 20 20:59:24 manjaro systemd[1]: sddm.service: Failed with result 'core-dump'.
Aug 20 20:59:24 manjaro systemd[1]: Failed to start Simple Desktop Display Manager.

So at this point there are 2 problems; when booting normally, it gets stuck on the “reached target graphical interface”, and when booting with the multi-user thing, it fails to start SDDM at all. Any ideas?

Looks like sddm tries to start, but repeated too often. Therefore it stopped. It seems the GPU initialize slow and sddm does not wait for it.

Are you really sure, there is only the nvidia card available?

inxi -Gazy

A workaround could be:

Replace MODULES=() with:

MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset)

at /etc/mkinitcpio.conf

Then run sudo mkinitcpio -P to update the initramfs.

i915 → intel driver

Ok so I was able to get the LTS minimal ISO installed. Unfortunately, on tty1 it gets stuck on the “clean…files…blocks” screen, so I have to launch tty2, run “startx”, and still SDDM doesn’t start. I tried the MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset) thing, (along with updating the initramfs) but that didn’t fix it :confused:

I think the issue at this point is clearly SDDM, but what options are left?

that is clear. SDDM won’t start if you run startx, but starts KDE directly. SDDM starts with this:

sudo systemctl start display-manager.service

If you run the xserver as normal user, then the Xorg.0.log should be located here:


or search it:

find /home/$USER -name "*Xorg*"

This log is important in your situation.