Trouble installing any program at all

I’m not sure where this post belongs
. please feel free to move it or let me know where to post it.

I just installed XFCE yesterday and I tried to install Firefox with the add or remove program ; also I tried to install SMPlayer ? also “DISKS” . evrything I try to install , the system , add/remove also wants to install ceph and now ceph-libs - so I went ahead with the install of ceph-libs but after a lengthy time period it fails and I am unable to install any program at all.\

on top of that I don’t even know how to use the cli properly.
example. in the terminal when I type

[aloia@aloim ~]$ cd download it comes back with- bash: cd: download: No such file or directory

consequently I am unable to even follow along with the directions in the user guide for checking sha-1 or sha-256
I apologize if I am committing a foul by writing here incorrectly.

1 Like

Did you install from a minimal .iso? To the best of my knowledge, firefox should normally already be installed by default in all of the normal images for the official editions.

You most likely don’t need that package. The long install time is because said package was recently dropped to the AUR, and the AUR contains build scripts. In other words, the system was trying to build ceph-libs into binaries from source code.

And that would be correct, because first of all, UNIX is case-sensitive — ~/downloads is not the same thing as ~/Downloads — and secondly, you’re also missing the “s” at the end of the directory name. :wink:


First, I want to thank , not only you but everyone who has responded to my posts.

ok, 1st I removed ceph-libs succesfully. as an experiment I installed both Firefox and SMPlayer - successfully . However , while installing a warning comes up -

unable to lock database
Failed to synchronize databases

I have no idea why Firefox was not installed by default. to me that says something is going on or I’ve done something upon install or not done something correctly OR something is going on with this PC. I do see that , only 1 stick of my 2 , 8GB sticks of ram is lit up and working . I only noticed that yesterday. I assume that the only effect will be , it won’t run operations as fast.

moving on-

I am sure and double checked in the user guide the text/script instructions for CDing in the terminal to the Downloads folder. I typed it exactly the way it is written. I am aware of case sensitivity tho I don’t really know " case sensitivity " per operation . many times in the past I have attempted to get better with the cli but end up baffled .
I found the problem- in the guide the command is lower case - which doesn’t work.
when I made the D , upper case it works. due to my unsuccess in the past and therefore inexperience I had no way of knowing this , even tho I’ve tried different case sensitivities many times .
I will tackle the sha confirmations soon.

moving on

I installed from the 1st xfce image on the Manjaro download page ; not anything minimal .
I don’t know whats going on with default programs and why , perhaps some others ? , like Firefox did not install . Thats why I downloaded xfce again today and tried to check it with sha . maybe now I can work my way thru the guide using different upper and lower cases.

again , I thank all of you who have replied to me

It indeed is not installed with the Xfce4 minimal .iso

although, the default choice on the download page is not the minimal, but the full version

I do not know which I installed - but firefox was not included

you should update your mirrors (where your choice of software will be drawn from)

then update - or try to install something new
(update first - then after that, install things not previously available)

Nachlese- I saw your post about the mirrors and I will refresh them now - etc . .

I refreshed the mirrors and installed Shotwell successfully but everytime I install something I still get the warning - unable to lock database
Failed to synchronize databases

well , I checked the latest download of xfce and it shows "OK " with sha1.
I’ll write it to usb now and install and see how it goes

Have you forced the package manager to close while in progress?
It usually puts a lock file at the beginning of a transaction in order to avoid concurrent modifications to the installation, and then remove it at the end. It can be forcefully removed if you are sure there is no other package manager running.

That is usually a hardware matter: check on your motherboard notice how RAM sticks shall be plugged (positions often matter). If it is correctly plugged, then it might be faulty.

Commands used in the terminal / TTY are technical programs. Most of them come with manuals.

man <command>
<command> --help
1 Like

Its possible that you have corrupted database files.
sudo rm /var/lib/pacman/sync/*.*
will remove them, then refresh the database’s to replace them.


Thank you for this info. At this very moment I’m doing a fresh install of xfce and I checked it with sha1. So we shall see what happens now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.