Trouble getting fcitx5 to work

Hi, im starting a new forum because im pretty sure the other forum is dead. So I can’t type chinese in some applications so Im trying to figure out why I can’t type chinese. Im using fcitx5 and I think the problem is that I didn’t at the lines:
to the file which i don’t know what it is. Please help me : |

My Laptop:
Operating System: Manjaro Linux
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.12.2-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-2467M CPU @ 1.60GHz
Memory: 3.7 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 3000

Try adding them to your ~/.xinitrc, but you have to also export them. :arrow_down:

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS='@im=fcitx'

Then, log out, log back in, and cross your fingers. :wink:

Like this?

so this didn’t work. Imma try this

It didn’t as well Im gonna try add this at the start of the text instead of the end.

Now Im adding them in the front instead.

So they all didn’t work. I tried rebooting instead of loging out but it also doesn’t work.

there should be & after the fcitx5 command, and if it still doesn’t work there are videos on youtube which show how to install fctix install properly

Did you install fcitx5-gtk and fcitx5-qt?If not,try install fcitx5-im group and fcitx5-chinese-addons.

And the wiki recommends editing /etc/environment and add the following lines:

Or ~/.pam_environment:

And there is no need to add fcitx5 in .xinitrc or any other profile,because:

If you are using any XDG compatible desktop environment such as KDE, GNOME, Xfce, LXDE, after you re-login, the autostart should work out of box.

You can see fcitx5 installed a file named /etc/xdg/autostart/org.fcitx.Fcitx5.desktop


etc enviorment
Hello, I checked the group with my terminal I (I typed = {sudo pacman -Ss fcitx5 -im} and it outputs:
community/fcitx5 5.0.8-1 (fcitx5-im) [installed]
Next generation of fcitx
community/fcitx5-configtool 5.0.5-1 (fcitx5-im) [installed]
Configuration Tool for Fcitx5
community/fcitx5-gtk 5.0.7-1 (fcitx5-im) [installed]
Fcitx5 gtk im module and glib based dbus client library
community/fcitx5-qt 5.0.6-1 (fcitx5-im) [installed]
Fcitx5 Qt Library

So I try updating it but it was already the latest version, so I tried add these lines:
to the /etc/enviourment folder (arch wiki recomends this folder) but I can’t even edit it with Nano, Vim, Xed, Kate, gedit so I ran out of ideas what to do.

I also couldn’t find the ~/.pam_enviroment folder. I tried unhiding the files cuz there a .symbol infront of the file so I thought it was hidden but I still can find it. I tried using the terminal cd ‘~/pam_environment’ but I still can’t find it : (

You should use sudo nano /etc/enviourment

~/.pam_enviroment is a file not a folder ,just touch ~/.pam_enviroment if you can’t find it

Just choose one,no need to edit both

1 Like

Ok I edited with sudo nano /etc/enviourment and pasted GTK_IM_MODULE=fcitx QT_IM_MODULE=fcitx XMODIFIERS=@im=fcitxI think I broke somthing and I can realy type cause I can’t see what I typing and I still can’t typ in some applications.

ok I fixed it by removing the lines and I can read what Im tying now but I still can’t type in some applications like libreoffice, leafpad, gedit, atom.

I tried using the .pam_enviourment sudo I typed :


But it didn’t work

Sorry I can‘t give more suggestions.

Try type fcitx5-diagnose to see what’s going on.

If you’ve actually typed it like this, your system won’t be able to read it since it’s misspelled.
Delete that file and edit /etc/environment instead (and don’t accidentally delete this file!) EDIT: Maybe do a backup first: sudo cp /etc/environment /etc/environment.bak


and “.pam_enviourment” obviously won’t work either…

1 Like

my mistake

This is the right place right and then I just copy and paste