"Translucent" option in panel settings doesn't work

> Right click on a panel with an analog clock widget in it.
> More options
> Opacity > Translucent

Nothing changes.
So I started trying things I found on the internet.

Things I’ve tried:

  • Loggin out and in.

  • Changing the Rendering Backend option in Compositor from OpenGL 2.0 to 3.1 and then logging out and in.

  • Changing the Contrast effect setting in different ways in the metadata.desktop file, in /usr/share/plasma/desktoptheme/breath2-2021-dark/ like so:
    enabled=true ← tried changing this to false
    contrast=0.2 ← tried changing this to 3.0,6.0
    and logged out an in again after each of these changes.

  • In Desktop Effects tried turning background contrast on and off again, translucency as well.

  • Installing the Panel transparency button widget and turning it on/off.

  • Tried following this but
    1 There’s no indication what “this widget” is, and more importantly:
    2 When right clicking on the panel there is no option called Add graphical component.

The system is up to date (written on the 3rd of December).

I know that there is an option of learning the KDE documentation, but that for me is an overkill, I imagine there is a simpler way for changing this one thing.

In case you have some ideas for workarounds here’s what I’m trying to get:
An analog clock with (enough) visible numbers or ticks that’s always on top and transparent to a degree, with resizing capability.

  • Analog - because it helps me get a feeling how far in the day I am and how much time I have left in a very visual & more tangible way, as opposed to a digital format which is just a line of numbers.
  • Transparency setting - 'cause I don’t want it to be too imposing.
  • Sufficient number of Visible numbers or Ticks for hours - a blank circle with 2 clock hands doesn’t give me enough information.
  • Resizing - 'cause I don’t want it to be too imposing, but still make it readable enough.


I was going to write a issue about this when I saw your post.

do you mean this option at the lower-right side? (Sorry for the Chinese desktop)

( that’s okay )

Does transparency work anywhere else?

When I move windows by click and hold of the title bar for example, yes.

I tried creating an empty panel and trying the translucent option there, in case the widget was doing something funny - but nope, the widget wasn’t the culprit.
i.e. - on an empty panel the translucent option doesn’t work either.

I believe you need to use a plasma theme which has been done with transparency. It’s not a user setting, it’s in the theme.

More specifically it is the Panel I think that handles the transparency. Some Panel / Plasma Style work, some won’t.

Breath and Breeze as far as I know work. Breath-Dark doesn’t.

My suggestion is to go to store.kde.org and search for the style of analog clock you like best but I think many are from the Plasma 4 days so I don’t know if they’ll still work. For example I think this Panel Clock is somewhat what you’re looking for but it’s from 2010 and I don’t know about transparency.

Did you get this to work? I can’t figure this out. I’ve switched plasma themes, logged out and in, turned on/off blurring windows and contrast, etc. I have a pretty default install and the compositor is running, but my panel won’t go translucent. I feel like there is some setting I’m missing, but I can’t find anything in the Settings for the panel, and the panel just has the three options for translucency. On my other computer I don’t even have the option in the panel, though it is on the side, not above the screen, but I can’t imagine why that would matter.

It is called Plasma Style, not Panel, in System Settings. Refer to my post above. Try with the Translucent option, as Opaque obviously is not what you want, and adaptive is translucent or not depending on condition (maximized window).

@flux Yeah, maybe. I think that the new Plasma version is still pretty new so it’ll take time for them to iron out the kinks.

@omano Changing the global theme to Breeze and logging out and in still didn’t make the translucent option work in panels funnily enough. And I don’t have Breath neither as a preinstalled global theme nor as a downloadable theme. Maybe if I went to one of the websites with downloadable themes I could try, but I got used to working without transparency by now. It’ll probably start working after one of the updates anyway.

@ydar Yeah that clock is a good fit, but I got used to working without transparency by now. The translucent option will probably start working after one of the updates anyway.
Thank you for your time regardless!

@xdevnull Nope, didn’t get it to work. It’ll probably start working with one of the future updates.

What if you change what I talked about and repeated again? Change the PANEL? Let see if changing the PANEL does anything?

Also this is not transparency, it is translucency, this is a major difference if you expect a transparent Panel.

Depending on the Panel used, it will be slightly different and more or less translucent.

1 Like

I switched to KwinFT and compositor worked again. I use the Nouveau driver, btw. Beware KwinFt may move your panels around initially. But easy to put back. :slightly_smiling_face: Optionally you could also install wayland protocol.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.