Touchpad stopped working after upgrading to linux kernel 6.1

I have been on the LTS kernel 5.15 for a while now and decided to try out the new 6.1.7-1 kernel. The touchpad on my Thinkpad P50 laptop doesn’t work on this kernel. Also tried out the older 6.0 kernels. Same issue. While I don’t need to use the 6.0 kernels, I don’t want to be stuck forever on 5.15. There seems to be a couple of issues opened on this forum regarding the same problem, but no solution offered. For example, see here. Any suggestions how to move forward?

1 Like

Have you tried installing these packages?


Or it may be your Desktop Environment…

I haven’t tried installing them as I didn’t know that I needed to install them, since these are not the sort of things the users have to do themselves.

It cannot be the Desktop Environment as I only experience this problem when I switch kernels.

Hi there.

The 5.15 kernel will be supported until October this year, so you have time. Does your ThinkPad work fine on 5.10? If so, that will be maintained until December 2026. If your machine doesn’t work so well with 5.10, then consider installing the packages that DrJeff16 suggested - I can’t say if it’s a good suggestion or not.

All the best meantime.

Ruziel :slight_smile:

PS I think people can sometimes get too concerned about having the latest kernel - unless they specifically need it. I would suggest testing out 5.10 & if it works, keep it on your machine as a back-up kernel.