Touchpad not working on Lenovo Thinkbook 15 IIL

Hi everyone, I am on manjaro gnome. currently running kernel 5.7.14-1. My touchpad is not being detected. Can you help me solve the issue or raise it to a dev team (maybe the manjaro team) to include it into a fix ?

xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ HP HP Link-5 micro dongle Mouse id=9 [slave pointer (2)]
⎜ ↳ HP HP Link-5 micro dongle Consumer Control id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Integrated Camera: Integrated C id=13 [slave keyboard (3)]
↳ Ideapad extra buttons id=14 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]
↳ HP HP Link-5 micro dongle System Control id=10 [slave keyboard (3)]
↳ HP HP Link-5 micro dongle id=11 [slave keyboard (3)]
↳ HP HP Link-5 micro dongle Consumer Control id=16 [slave keyboard (3)]

Although I can see, I have ELAN0634. I don’t see any drivers like elan_i2c to make them operate.

ls /sys/bus/acpi/devices
ACPI0003:00 device:22 device:48 device:6e device:94 LNXPOWER:05
ACPI000C:00 device:23 device:49 device:6f device:95 LNXPOWER:06
ACPI000E:00 device:24 device:4a device:70 ELAN0634:00 LNXPOWER:07
CRQ0340:00 device:25 device:4b device:71 INT0E0C:00 LNXPWRBN:00
device:00 device:26 device:4c device:72 INT3394:00 LNXSYBUS:00
device:01 device:27 device:4d device:73 INT33A1:00 LNXSYBUS:01
device:02 device:28 device:4e device:74 INT3400:00 LNXSYSTM:00
device:03 device:29 device:4f device:75 INT3403:00 LNXVIDEO:00
device:04 device:2a device:50 device:76 INT3403:01 MSFT0001:00
device:05 device:2b device:51 device:77 INT3403:02 MSFT0003:00
device:06 device:2c device:52 device:78 INT3403:03 PNP0000:00
device:07 device:2d device:53 device:79 INT340E:00 PNP0100:00
device:08 device:2e device:54 device:7a INT3455:00 PNP0103:00
device:09 device:2f device:55 device:7b INT3519:00 PNP0A08:00
device:0a device:30 device:56 device:7c INT3F0D:00 PNP0B00:00
device:0b device:31 device:57 device:7d INTC5000:00 PNP0C02:00
device:0c device:32 device:58 device:7e LIC0001:00 PNP0C02:01
device:0d device:33 device:59 device:7f LNXCPU:00 PNP0C02:02
device:0e device:34 device:5a device:80 LNXCPU:01 PNP0C02:03
device:0f device:35 device:5b device:81 LNXCPU:02 PNP0C02:04
device:10 device:36 device:5c device:82 LNXCPU:03 PNP0C04:00
device:11 device:37 device:5d device:83 LNXCPU:04 PNP0C09:00
device:12 device:38 device:5e device:84 LNXCPU:05 PNP0C0A:00
device:13 device:39 device:5f device:85 LNXCPU:06 PNP0C0C:00
device:14 device:3a device:60 device:86 LNXCPU:07 PNP0C0D:00
device:15 device:3b device:61 device:87 LNXCPU:08 PNP0C0E:00
device:16 device:3c device:62 device:88 LNXCPU:09 PNP0C14:00
device:17 device:3d device:63 device:89 LNXCPU:0a PNP0C14:01
device:18 device:3e device:64 device:8a LNXCPU:0b PNP0C14:02
device:19 device:3f device:65 device:8b LNXCPU:0c PNP0C14:03
device:1a device:40 device:66 device:8c LNXCPU:0d PNP0C14:04
device:1b device:41 device:67 device:8d LNXCPU:0e PNP0C14:05
device:1c device:42 device:68 device:8e LNXCPU:0f PRP00001:00
device:1d device:43 device:69 device:8f LNXPOWER:00 SYNA2B60:00
device:1e device:44 device:6a device:90 LNXPOWER:01 USBC000:00
device:1f device:45 device:6b device:91 LNXPOWER:02 VPC2004:00
device:20 device:46 device:6c device:92 LNXPOWER:03 YMC2017:00
device:21 device:47 device:6d device:93 LNXPOWER:04

$ ls /sys/bus/i2c/drivers/

88PM860x dummy max8998 tps6586x
aat2870 htcpld-chip palmas tps65910
ab3100 intel_soc_pmic_i2c rc5t583 tps68470
adp5520 lochnagar sec_pmic tps80031
as3711 lp8788 smsc twl
‘CHT Whiskey Cove PMIC’ max77620 stmpe-i2c twl6040
da903x max77843 sx150x-pinctrl wm831x
da9052 max8925 tc3589x wm8350
da9055-pmic max8997 tps65090 WM8400

Thank you !

Does sudo modprobe -r psmouse && sudo modprobe -a psmouse help?

There have been some reports of Lenovo IdeaPad users having issues with an Elan touchpad.
Maybe you can try out some suggestions from this thread.

Some guy using ubuntu have a fix for this. I am on Arch linux and I tried it and it made my touchpad working. So should be working with manjaro too.

Please check here - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1861610
See Comment no #66

I am sure it will help you too…

Thanks.

No. but thank you for trying.

It didn’t work in my case because the I have no driver for elan_i2c under /sys/bus/i2c/drivers/. So I have no driver that could control the touchpad. Any idea how I can install such a driver ?
It seems to me like it should be there but for some reason it’s not in my installation (probably because the distro or kernel didn’t pick up the touchpad hardware).
Also, I wonder how to get this fixed in the kernel. do you know if and how to send this issue to the manjaro team?
Many thanks !

@gauravpadia:

  • I just applied the solution in your url + I did a $modprobe elan_i2c as root before rebooting.
  • Also, please note that there is no acpidump in Arch. these commands should be used instead to decompile and recompile the acpi tables

-Extract the tables cat /sys/firmware/acpi/tables/DSDT > dsdt.dat-Decompile:iasl -d dsdt.dat-Recompile:iasl -tc dsdt.dsl`

Refer to DSDT - ArchWiki for more info.

Thanks a lot !!

Hey @ZakMB,

acpidump is available in “acpica” package. So install this package - Arch Linux - acpica 20200717-1 (x86_64)

DId you followed all steps properly? I am sure it will work if you relax and do it.

In step where guy says to comment 4 lines make sure you are not commenting “Return (0x0F)” line by mistake. I did that mistake when tried first time.

Also don’t forget to blacklist i2c_hid as per mentioned in steps.

Also “update-grub” command will not work on manjoro instead do this command: grub-mkconfig -o /boot/grub/grub.cfg

And you don’t have to do modprobe manually, just reboot and if you did all fine then it will work surely.

I hope this time it works for you. If not please share your dsdt.dsl file.

Thanks.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.