Touchegg starts also in Wayland

I’ve just installed the latest Manjaro Gnome 21.1.1, which by default uses Wayland with nice touchpad gestures working out of the box.

However, touchegg is also installed (to handle gestures also in X11) with the corresponding Gnome extension. The problem is that touchegg is started automatically (see /etc/xdg/autostart/touchegg.desktop) and this fills the log with tons of messages of the shape

touchegg.desktop[1570]: Error connecting to Touchégg daemon: Could not connect: Connection refused
touchegg.desktop[1570]: Reconnecting in 5 seconds...

of course, I could remove touchegg entirely (see also Error connecting to Touchégg daemon: Could not connect: Connection refused) but this will require removing also the X11 extension, and I wouldn’t be able to test Gnome also with X11. I could also remove touchegg.desktop from /etc/xdg/autostart/touchegg.desktop, but wouldn’t it be better to ship such a .desktop file so that the program starts only in Wayland?

1 Like

I think you meant X11. :wink:

@Chrysostomus and I haven’t figured out how to only enable the service for an X11 session. Maybe a custom user service.

1 Like

Hi there,

Just disabling x11gestures from tweak tool and removing touch* packages and dependencies wipes the error from the system.

Hope it helps!

As I said in my original post, I’d like to avoid removing touchegg

By the way, I also tried the X11 Gnome, and from what I understand the touchegg.service is not enabled by default, so you don’t get touchpad gestures in X11 anyway… am I missing something? Why is touchegg.desktop configured to start automatically but not touchegg.service?

lorebett: I also have this issue. the solution for me is to edit /etc/sdg/autostart/touchegg.desktop and add a line Hidden=true at the bottom.

To your question of why it’s installed: I have no idea, but for some reason it comes with some package. It’s worth noting that systemd’s unit files and .desktop files are different and unrelated (as far as I understand). I don’t entirely see why there’s be a .desktop file and a systemd unit installed, so indeed that seems buggy.

ah, in the upstream documentation there is an answer to this^ pondering touchegg/installation at master · JoseExposito/touchegg · GitHub (2021-11-22 link) - quoting inline:

  • either launch touchegg via your desktop env. automagically via .desktop file
  • or launch it as a systemd daemon

So I’m guessing we have a setup (mine was the default manjaro gnome install) that must be utilizing wayland and leaving that .desktop file intact incorrectly? Just a guess.

The developer is planning on only enabling the service if a Xorg session is detected, see:


I think that would be the best solution :slight_smile:

For the moment I went back to Xorg since Wayland doesn’t seem to be completely usable at the moment

Touche application is working on Xorg but not on Wayland, without any visible error messages. Technically it’s apps problem but because it ships with the official Manjaro release (that starts with Wayland on GNOME natively) I felt like posing it here somewhere.