Toolbar battery icon colour missing?

xfce 21, I logged on and when the desktop loaded the battery icon is just an outline on the left of the update icon. Any ideas appreciated.
I tried a number of times to upload a small 2.8 KiB image, but apparently this forum doesn’t allow image posting?

Hello,

Not for new members, all explained here and how you still can share links and images

Is that related to the icon theme used?

Ok using default settings Appearance Style “Match-sea” Icons “Papirus-Maia”
Wnindow Manager Theme “Matcha-sea”
On AC power the icon appears correct green and graphic level. However on battery power there is an empty space where the icon was. There is a shadow outline, no other details.

System:
  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux
    base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP ProBook 470 G3 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8102 v: KBC Version 40.73 serial: <superuser required>
    UEFI: HP v: N78 Ver. 01.53 date: 11/24/2021
Battery:
  ID-1: BAT0 charge: 32.7 Wh (67.8%) condition: 48.2/55.1 Wh (87.5%)
    volts: 11.1 min: 10.7 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: discharging cycles: 427
Memory:
  RAM: total: 7.66 GiB used: 2.91 GiB (38.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
    required.
CPU:
  Info: dual core model: Intel Core i7-6500U bits: 64 type: MT MCP
    smt: enabled arch: Skylake rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 4 MiB
  Speed (MHz): avg: 500 min/max: 400/3100 cores: 1: 500 2: 500 3: 500
    4: 500 bogomips: 20810
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht hwp
    hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc
    tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-9 ports: active: eDP-1
    empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916
    class-ID: 0300
  Device-2: AMD Topaz XT [Radeon R7 M260/M265 / M340/M360 M440/M445 530/535
    620/625 Mobile] vendor: Hewlett-Packard driver: amdgpu v: kernel
    arch: GCN-3 pcie: speed: 2.5 GT/s lanes: 4 bus-ID: 01:00.0
    chip-ID: 1002:6900 class-ID: 0380 temp: 37.0 C
  Device-3: Cheng Uei Precision Industry (Foxlink) HP HD Camera type: USB
    driver: uvcvideo bus-ID: 1-6:3 chip-ID: 05c8:0383 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: amdgpu,modesetting alternate: fbdev,vesa dri: iris,radeonsi
    gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: eDP-1 model: AU Optronics 0x219e res: 1600x900 hz: 60 dpi: 106
    size: 382x214mm (15.04x8.43") diag: 438mm (17.2") modes: 1600x900
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d70
    class-ID: 0403
  Sound API: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: speed: Unknown
    lanes: 63 port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:4 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 931.51 GiB used: 9.96 GiB (1.1%)
  ID-1: /dev/sda vendor: Samsung model: ST1000LM024 HN-M101MBB
    size: 931.51 GiB speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0001 scheme: GPT
  Optical-1: /dev/sr0 vendor: hp model: DVDRW DU8A6SH rev: DH61
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / size: 457.13 GiB used: 9.95 GiB (2.2%) fs: ext4 dev: /dev/sda3
    label: N/A uuid: 91b091a0-b8ee-45e0-ab40-01db19c90a10
  ID-2: /boot/efi size: 511 MiB used: 4.6 MiB (0.9%) fs: vfat
    dev: /dev/sda1 label: N/A uuid: 998C-B80D
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/sda2 size: 465.51 GiB fs: ext4 label: N/A
    uuid: 00c9a817-60b9-4f86-8d1a-80054e350640
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: USB OPTICAL MOUSE type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 0000:3825 class-ID: 0301
  Device-2: 1-6:3 info: Cheng Uei Precision Industry (Foxlink) HP HD Camera
    type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 05c8:0383 class-ID: 0e02
  Device-3: 1-7:4 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2b class-ID: e001
  Device-4: 1-8:5 info: Validity Sensors VFS495 Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 138a:003f class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 35.0 C pch: 36.5 C mobo: N/A gpu: amdgpu
    temp: 36.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 215 Uptime: 1h 56m wakeups: 1 Init: systemd v: 251
  default: graphical Compilers: gcc: 12.2.0 clang: 14.0.6 Packages:
  pm: pacman pkgs: 1095 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.22

First you may update your system. This comes always first . Reboot… .

  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.58 running: yes

…there should be only running one (default in xfce is PulseAudio).

Swap:
  Alert: No swap data was found.
...
Memory:
  RAM: total: 7.66 GiB

…are you shure, you don’t want swap (not even a swapfile) ?

The problem is Matcha-light-sea style, panel dark mode. I need the light style [vision problems] to see the windows headings. I tried all the icon sets installed and cannot get the battery icon to display?