Too silent fans?

i just got here from windows where the fans would be quit active and loud;
obviously while gaming,but even when opening multiple YouTube tabs one after the other and also in other various scenarios.
on manjaro i can barely hear them and their rpm rarely increase;
in the YouTube example i mentioned they do ramp up,but just a bit.(i haven’t gamed on it yet)
i assumed that might have to do with Linux being less demanding/resource hungry and maybe also run less background processes.
then i stumbled upon this guy’s video where he states something similar to my observation:

so while looking for monitoring/power management softwares, i saw on the wiki that there was one called TLP.and while looking for it in Pamac,i saw it was already installed.

so my questions are:
-have you noticed that too? is it a normal behavior?
-are the guy’s assumptions in the video correct?(“manjaro being aggressive on power management”)
-is TLP currently running/started on my laptop(by default)or is it just installed?
-is there a way to chose a “power plan”(High Perf. etc)in manjaro in one of the GUI menus,or do i have to use another tool like TLP/TLPUI?(if that’s indeed the way to do that).

1 Like

Hi @linub :wink:

Yes, it seems quite normal… I guess linux just overwrites the BIOS/UEFI fan values and watches the temp itself.

Well, i would say no, but depends on personal view if that is aggressive…

Check if it is running with:

sudo systemctl status tlp

Yes, you can define that directly in /etc/tlp.conf or use tlpui (which is a gui for tlp)

pamac install tlpui
1 Like

hi @megavolt
i checked the status of TLP and it looks activated;
since that’s the case then I’ll get the GUI and see what can be tinkered with in it’s settings.

TLP/TLPUI are wonderful tools, especially if you have a laptop!
I agree in toto with @megavolt 's answer and I had your same experience when I first installed Manjaro: Windows ramped up my poor laptop fan a lot, with Manjaro on the other hand, in light load condition, the fan even stops, I find that awesome xD!
With a little bit of work and digging through TLP settings, I think you can make Manjaro handle power even better than Windows, or at least that was my experience.

1 Like

is there a way to chose a “power plan”(High Perf. etc)

I suggest you check the CPU scaling governor

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

you may want to try changing governor to performance

sudo cpupower frequency-set -g performance

This change is not persistent so system will revert back to original governor when restarted

CPU frequency scaling - Scaling governors - ArchWiki

1 Like

Thanks,that was useful information,especially while browsing the tlpui settings and i learned something new,which brought a few questions:

i checked the CPU scaling governor and it’s on powersave.

now in tlpui under ‘processors setting’ i have an option to change the ‘scaling governor’ with a warning that i must disable my distribution’s governor setting or conflicts will occur.

then there’s another setting which is “CPU perf policy on ac”;
now i wonder how this setting differs from the CPU ‘scaling governor’(one is frequency and the other power draw?)and what would be the benefit of changing the ‘perf policy’ to performance,since the CPU scaling is already set by default to powersave?

on windows i set to the ‘high perf’ plan,which meant my cpu was always running at it’s highest clock speed with it’s usage obviously varying upon what i was doing.
this would suit me fine since i prefer getting the most out of my hardware and having the best experience and I’m most of the time plugged to the AC.

as i was reading more about it i stumbled upon this interesting discussion:

while it’s all still above my head,it seems that the new Intel driver is now responsible for power management too(epp,epb,hwp)which are the settings under "CPU_perf_policy"in tlpui. so i’m not sure if this should be messed with and maybe it’s better to change CPU governor to perf. and let it do the rest?

At least on my end, distribution’s governor settings are changing while I set governor in TLPUI, so it looks like this warning can be ignored, but we will see what @nikgnomic will say because I don’t have that much knowledge than he :slight_smile:

1 Like

I can’t say much about about tlp as I only have AMD desktop systems and most of the power management is turned off
I use the ‘performance’ governor some of the time, but only when I am running a big project in JACK. Changing governor used to be essential with JACK, but the governor does not seem to make much difference if JACK is running a simple workflow

MX is using cpufreq for frequency scaling and ‘ondemand’ governor. And MX uses sysvinit instead of systemd so they are not likely to use cpupower like Manjaro instead of cpufreq

The ‘equivalent’ intel_pstate governor to ondemand would be performance
CPU frequency changes dynamically and would maintain a higher frequency than powersave when system load requires it

cpupower is configured in /etc/default/cpupower to use performance governor
but the systemd service cpupower.service is not turned on
(I suspect this is to avoid problems with noisy fans or high temperatures on older systems - MX forum does get an occasional complaint about those issues)

this command is all that is needed to turn on systemd service

systemctl enable cpupower.service --now

but there is also cpupower-gui in AUR which can probably deal with all of this GUI if you prefer that

If you want CPU locked to high speed you can edit /etc/default/cpupower to comment out the governor and use freq= setting instead
but you should have tools to monitor CPU and system temperatures if you want to try it


@nikgnomic I was waiting for your response in case I don’t know something and potentially mislead @linub

So it looks like in laptop case it doesn’t have much difference do you set governor in tlp or cpupower directly. In Xfce cpupower is installed anyway and perhaps tlp use cpupower for CPU settings, but I can be wrong.

All in all it looks like if you decide to use tlp don’t touch cpupower settings. tlp will handle it and also change distribution configuration. When you decide to use cpupower just unmark options in CPU_SCALING_GOVERNOR (tlpui) or comment these options in tlp config. These also result in governor will be automatically set to distribution settings (after reboot) and after setting scaling in cpupower, distribution settings will be overwritten by settings in cpupower. So you can safely test which method you prefer.
Maybe in case you set different options in cpupower and tlp by accident, burn ISO on stick, so you will have access to config files :smiley:

1 Like

I use Intel chip and tried different governors as described by @nikgnomic by

sudo cpupower frequency-set -g *governor*

Default is powersave, but replacing *governor* with performance caused constantly max. cpu frequencies but it did not affect the fan directly, was practicable as silent as before, same for temperatures, only extremely little effect on my system. When there is load also with powersave frequence is going to max. value.

1 Like

i set

sudo cpupower frequency-set -g performance

CPU ramped to it’s max and fans started spinning more when needed.
(i could hear the fans but watch -n1 -d 'sensors | grep fan' showed 0 RPM for CPU_fan ??)

  • how do i make this change persist after reboot?

still not sure what should i do with “cpu_energy_perf_policy” in tlp.
it’s on “balance performance”.

-would putting it in “performance” increase performance?how so since the CPU is already at max;
maybe it allow the CPU to get more power from the AC?
-should i even mess with it or is it the CPU that takes care of that?

edit this file:

nano /etc/default/cpupower


and enable service:

systemctl enable cpupower.service

Never changed that, at least don’t remember. I use performance while recording/mixing music, and it looks like governor set to performance is enough.
In major of cases if you don’t know what particular option will do after change, don’t mess with it :slight_smile:

Create separate thread for this. Maybe somebody will be able to help if it’s possible. But before check this out


Thanks for that

about making the change persistent;
first of all,do i need to remove the # before "governor=‘performance’ " ?

and then while searching for how to make the change persistent(just to be sure :slightly_smiling_face:),
i found a site that said to do it like you suggested,but then a few others that said i needed to Create systemd service file to set CPU governor at system boot(/etc/systemd/system/cpupower.service):
is it just another way to make it persistent or is it because they’re different Distros?

and about the Fan showing 0 RPM,while looking around,it seems that some Asus laptops and mother boards(same as what i have) need maybe a special driver for Senors to detect them(or other tweaks),
or maybe i need to run “sensors-detect” first,which i won’t bother with either right now since i can hear the Fans spinning and monitor the temp manually.

yes, because that character is to make it a comment, so by removing it-it becomes an active setting.

Most probably, because on my system that service is already installed by the distro.

> systemctl cat cpupower                                                                                                       
# /usr/lib/systemd/system/cpupower.service
Description=Apply cpupower configuration


1 Like

Personally I gave up trying to make it working on thinkpad I use now, that’s why I advised to create a dedicated thread for this issue.
Running sensors-detect most probably don’t help if fan RPM’s are not recognized already. If fans are spinning or don’t freak out, you rather don’t have reason to worry about, but my knowledge is very limited, so I can be wrong.

1 Like

Thank you very much everyone for your inputs,instructions,helping me understand and pointing me in the right direction.
now my Fans are less silent :grin:

in case i want to revert it to default;
what would be the right procedure;
just typing

systemctl disable cpupower.service


1 Like

Yes, after reboot settings will back to default :slight_smile:

1 Like