Tlp not starting at boot

So I installed tlp as per the wiki instructions Power Management - Manjaro and enabled tlp (systemctl enable tlp --now).

But it will not start automatically at boot. It needs to be started manually every time. What gives?

$ sudo systemctl status tlp                                       

○ tlp.service - TLP system startup/shutdown
     Loaded: loaded (/usr/lib/systemd/system/tlp.service; enabled; vendor prese>
     Active: inactive (dead)

Maybe this might work?

sudo systemctl enable --now tlp.service

TLP is installed and enabled in most editions by default.

I guess we could maybe do with some other explanations, like logs, or if you installed or configured anything related like other power management?

Thanks but it didn’t. Same result.

But tlp is there, right?

which tlp

I’m running gnome. I didn’t install anything extra (other than what I already have under Settings → Power). I’m new to Manjaro and linux in general. If you could guide me where to look and what to look I can dig and post back.


$ which tlp                                                       

And, if I start manually using sudo systemctl start tlp it does without any issues but having to do it manually every time is a PITA.

Maybe something like

systemctl | grep power

Here is what I got:

$ systemctl | grep power  
  power-profiles-daemon.service                                                                                   loaded active running   Power Profiles daemon

  upower.service                                                                                                  loaded active running   Daemon for power management

This conflicts with TLP.
You must choose one.

(or hacky workaround is to edit the service unit files and change that conflict … but … probably dont)

1 Like


With tlp the battery life literally doubled from 4 hours to 8.5 hrs. So, I tried sudo systemctl disable power-profiles-daemon.service and then enabled tlp. Still no luck. After reboot I found power-profiles-daemon running and tlp not running.

You’ll need to stop it and mask it as well:

systemctl disable --now power-profiles-daemon
systemctl mask power-profiles-daemon

Thank you. That took care of it. Battery life back to as good as it used be :slight_smile:

Hope replacing power-profile-daemon with tlp is safe?

Yes, of course. I did it and nothing exploded. :stuck_out_tongue_winking_eye:

1 Like