Tlp active exited no way to make it work

Hi, I recently re installed Manjaro with GNOME, kernel is 5.15.31-1 LTS, and I am not able to make tlp working :

systemctl status tlp.service

tlp.service - TLP system startup/shutdown
     Loaded: loaded (/usr/lib/systemd/system/tlp.service; enabled; vendor prese>
     Active: active (exited) since Mon 2022-05-02 09:31:21 CEST; 1min 53s ago
    Process: 3588 ExecStart=/usr/bin/tlp init start (code=exited, status=0/SUCC>
   Main PID: 3588 (code=exited, status=0/SUCCESS)
        CPU: 758ms

mai 02 09:31:20 manjaro systemd[1]: Starting TLP system startup/shutdown...
mai 02 09:31:21 manjaro tlp[3588]: Applying power save settings...done.
mai 02 09:31:21 manjaro tlp[3588]: Setting battery charge thresholds...done.
mai 02 09:31:21 manjaro systemd[1]: Finished TLP system startup/shutdown.

systemctl | grep power

upower.service loaded active running Daemon for power management

I read this thread : Tlp not starting at boot - #12 by Yochanan
and I tried systemctl disable --now power-profiles-daemon

But it didn’t change a thing. How can I make tlp work ?

1 Like

TLP is working as expected. TLP does not include a daemon and there is no tlp process showing up in the output of ps. It only applies it settings during system startup/shutdown just like powertop.

Use the following command to check that TLP is enabled and active:

sudo tlp-stat -s
+++ System Status
State = enabled
Last Run = <Time of system start or last change of power source>

Also see Usage — TLP 1.5 documentation.

Ok, thanks, tlp-stat -s shows me that tlp is running :slight_smile:

Sorry for the invonvenience, I didn’t get it, I’ll RTFM ^^

EDIT : after trying some tweaks with TLP, I switched from TLP to power-profiles-daemon and my battery was doubled. I thought it could interest other people.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.