Thunderbird doesn't open links in the browser

Hello everyone,

Thunderbird does not open the browser when clicking on a link in an email. Is this a security setting and should I leave it like this?
But I would prefer that when I click on the link in an email, the Google Chrome browser opens as my default browser. So what could I do?

I have Manjaro-Cinnamon, but the same behavior was observed under XFCE.

Hi @Tut_tut,

No, you don’t have to leave it. I don’t think it’s a security thing. If it is, welp, then I’ve got a security hole. Oh well.

Please post the output of:

grep http ~/.config/mimeapps.list

Hello @Tut_tut :wink:

Usually you will be asked which browser should be used and the browser is saved in ~/.config/mimeapps.list. It works for me perfectly well. Delete the file and it will reset to system defaults, thus it will ask again everywhere.

That should be written there if firefox should be used:


Just replace firefox.desktop with yours.

Here is more to study: XDG MIME Applications - ArchWiki

Not necessarily, certainly not on my machine.

I was particuarly interested in this thread because thunderbird opens different browsers depending on whether the link I click on is on the header bar (opens in Falkon), body (Falkon) or attachment list (LibreWolf). I’m trying to train it away from Falkon but it’s very disobediant.

When I deleted the mime list it made no difference (after closing/opening thunderbird) and the file was not immediately replaced.

That is a different topic entirely, please don’t hijack a thread.

It is probably more due to the link’s address. But no matter. Another place to look is in ~/.local/share/applications/defaults.list:

cat ~/.local/share/applications/defaults.list
1 Like

I was not hijacking, merely pointing out that the file quoted was not necessarily the right one, and that the browser launched may differ.

cat ~/.local/share/applications/defaults.list

does not exist, either.

And does:

cat /etc/xdg/mimeapps.list


It looked like a hijack since your comment wasn’t useful to finding the problem, and actually quite different. I recommend you rather start a new thread.

cat /etc/xdg/mimeapps.list

Not there, either. Sorry.

Thanks for your suggestions. I’ll stop now.

You don’t have to stop if you want more help, instead I think I’ll ask one of the @moderators to split this into a new topic for more exposure and so as not to polute the original thread.

MY last suggestion is checking if there is something in:

cat ~/.local/share/applications/mimeapps.list


cat ~/.local/share/applications/defaults.list

If there’s nothing, we can see in Thunderbird’s .desktop file if there are any weird associations. But to do that we need to know where the .desktop file is. Probable /usr/share/applications/ somewhere.

ls -l /usr/share/applications/ | grep thund

In Cinnamon Control Center: Is Firefox (or any Browser) set as default application?

So, here is my output:

$ LC_ALL=C grep http ~/.config/mimeapps.list

I deleted the file, an after that:

LC_ALL=C grep http ~/.config/mimeapps.list
grep: /home/micha/.config/mimeapps.list: No such file or directory

and the problem is the same.

but after new preferred settings:

LC_ALL=C grep http ~/.config/mimeapps.list

It’s a shame that the discussion drifted a bit, my problem still exists. Do you have any other ideas for me as to what I could do? :sweat_smile:

Try setting the default browser - we have a script for it [root tip] [Utility Script] Setting the default web-browser

Never click a link in an email - always verify the link target …
Never open attachments - always be suspicious with attachments …

Clicking links in an email is a high level security risk and a high level privacy risk - emails is often constructed in a way to reveal if the user has read it or opened it - e.g. web beacons and links are likely constructed with a unique identifier so spammers know if a given email is actively read and they are commonly used to spread malware.

Perhaps use Ctrl click - like in a terminal if a link is present or right click the link and choose open.

Done. google-chrome.desktop
Default browser set using google-chrome.desktop

But the problem still exists. :star_struck:

Last thing I can think of:

Check if these files exist:

stat ~/.local/share/applications/mimeapps.list


stat ~/.local/share/applications/defaults.list


And if they do, post their content, please:

cat ~/.local/share/applications/mimeapps.list


cat ~/.local/share/applications/defaults.list
LC_ALL=C stat ~/.local/share/applications/mimeapps.list
  File: /home/micha/.local/share/applications/mimeapps.list
  Size: 0         	Blocks: 0          IO Block: 4096   regular empty file
Device: 259,2	Inode: 5507876     Links: 1
Access: (0644/-rw-r--r--)  Uid: ( 1000/   micha)   Gid: ( 1000/   micha)
Access: 2024-02-04 19:03:26.612106773 +0100
Modify: 2024-02-04 19:03:26.612106773 +0100
Change: 2024-02-04 19:03:26.612106773 +0100
 Birth: 2024-02-04 19:03:26.612106773 +0100
[micha@X1-Carbon ~]$ LC_ALL=C stat ~/.local/share/applications/defaults.list
stat: cannot statx '/home/micha/.local/share/applications/defaults.list': No such file or directory

Could the problem also lie here?
I always save the /.thunderbird folder on a USB stick and copy it to the home directory when I reinstall the operating system. Could it be that I created too many profile files? I have probably 20 different *.default directories in the /.thunderbird folder. The only question would be, which is the active profile that I am currently using? I could delete the others?


LC_ALL=C cat ~/.local/share/applications/mimeapps.list
[micha@X1-Carbon ~]$ LC_ALL=C cat ~/.local/share/applications/defaults.list
cat: /home/micha/.local/share/applications/defaults.list: No such file or directory

You could always check which one’s your default with:

thunderbird --profilemanaager

Or whatever the name of the executable is.

And then rename the other directories, which deletes them according to Thunderbird, and than test. If it doesn’t work, you can restore, if it does, you can delete it permanently.

I don’t think so, but


If you’ve finished, please post the output of:

locate '*thunderbird*desktop'
LC_ALL=C locate '*thunderbird*desktop'
bash: locate: Kommando nicht gefunden.


LC_ALL=C locate '*thunderbird*desktop'
locate: can not stat () `/var/lib/mlocate/mlocate.db': No such file or directory

Incidentally, I deleted all unused profiles

Install the plocate package for that:

pamac install plocate

Update the database:

sudo updatedb

and try the command again:

locate '*thunderbird*desktop'