The video card does not consume the prescribed watts

My 3080 has a dynamic TDP of 140-165 watts, but in Manjaro for some reason it’s 115 watts. Tried Fedor 36, 165 watt always. How to fix?

post the output of

sudo nvidia-smi -q -d POWER

and also the basic-minimum infos required in this forum because none of us owes a functioning glass bowl

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

sudo nvidia-smi -q -d POWER

Timestamp                                 : Sat Jun 11 13:42:30 2022
Driver Version                            : 510.73.05
CUDA Version                              : 11.6

Attached GPUs                             : 1
GPU 00000000:01:00.0
    Power Readings
        Power Management                  : N/A
        Power Draw                        : 16.64 W
        Power Limit                       : N/A
        Default Power Limit               : N/A
        Enforced Power Limit              : N/A
        Min Power Limit                   : N/A
        Max Power Limit                   : N/A
    Power Samples
        Duration                          : Not Found
        Number of Samples                 : Not Found
        Max                               : Not Found
        Min                               : Not Found
        Avg                               : Not Found

inxi --admin --verbosity=7 --filter --no-host --width

  Kernel: 5.18.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=a7eb2963-e8e8-4c1f-8679-09b363ffa917 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82N6 v: Legion 7 16ACHg6
    serial: <superuser required> Chassis: type: 10 v: Legion 7 16ACHg6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI: LENOVO v: GKCN50WW date: 11/24/2021
  ID-1: BAT0 charge: 79.3 Wh (100.0%) condition: 79.3/80.0 Wh (99.2%)
    volts: 17.3 min: 15.4 model: Celxpert L20C4PC1 type: Li-poly
    serial: <filter> status: full cycles: 40
  RAM: total: 31.27 GiB used: 7.24 GiB (23.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25)
    model-id: 0x50 (80) stepping: 0 microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2840 high: 3269 min/max: 400/4463 boost: enabled
    scaling: driver: amd-pstate governor: schedutil cores: 1: 3051 2: 2990
    3: 3269 4: 2988 5: 2216 6: 2910 7: 3245 8: 2790 9: 2855 10: 3089 11: 2668
    12: 2565 13: 2775 14: 2535 15: 2793 16: 2703 bogomips: 102241
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB]
    vendor: Lenovo driver: nvidia v: 510.73.05 alternate: nouveau,nvidia_drm
    non-free: 515.xx+ status: current (as of 2022-06) arch: Ampere
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:24dc class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 191 s-size: 340x221mm (13.39x8.70")
    s-diag: 406mm (15.97")
  Monitor-1: DP-4 res: 2560x1600 dpi: 4064 size: 16x10mm (0.63x0.39")
    diag: 19mm (0.74") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3080 Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.73.05 direct render: Yes
  Device-1: NVIDIA GA104 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: bus-ID: 3-1:3 chip-ID: 2a45:0128 gen: 3 class-ID: 0300 speed: 8 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-3: Meizu HiFi DAC Headphone Amplifier type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.0-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-4:2
    chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.84 TiB used: 824.1 GiB (43.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 44.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Samsung
    model: MZVLB1T0HBLR-000L2 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 3L1QEXF7 temp: 41.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 150.65 GiB size: 147.22 GiB (97.73%)
    used: 40.29 GiB (27.4%) fs: ext4 dev: /dev/nvme1n1p6 maj-min: 259:9
    label: N/A uuid: a7eb2963-e8e8-4c1f-8679-09b363ffa917
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 43.7 MiB (17.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:4
    label: SYSTEM uuid: 081B-B6FA
  ID-3: /run/media/david/BOOT raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 254.8 MiB (26.2%) fs: ext4 dev: /dev/nvme1n1p4 maj-min: 259:7
    label: BOOT uuid: 11c7cb73-d896-4b0f-a3b3-3365af030190
  ID-4: /run/media/david/Windows-SSD raw-size: 800 GiB
    size: 800 GiB (100.00%) used: 478.25 GiB (59.8%) fs: ntfs
    dev: /dev/nvme1n1p3 maj-min: 259:6 label: Windows-SSD
    uuid: 52C41E2AC41E1139
  ID-5: /run/media/david/Диск raw-size: 931.5 GiB
    size: 931.5 GiB (100.00%) used: 305.27 GiB (32.8%) fs: ntfs
    dev: /dev/nvme0n1p2 maj-min: 259:3 label: \xd0\x94\xd0\xb8\xd1\x81\xd0\xba
    uuid: F24A4A094A49CAD5
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme1n1p2 maj-min: 259:5 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme1n1p5 maj-min: 259:8 size: 1.95 GiB fs: ntfs
    label: WinRE_DRV uuid: 90EC1E7DEC1E5E32
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 3 rev: 2.1 speed: 480 Mb/s
    chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-2.1:4 info: Kingston HyperX Pulsefire Dart type: Mouse,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 98mA
    chip-ID: 0951:16e1 class-ID: 0300 serial: <filter>
  Device-2: 1-2.3:5
    info: Razer USA RC30-0315 Gaming Mouse [Basilisk X HyperSpeed]
    type: Mouse,Keyboard driver: hid-generic,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 500mA chip-ID: 1532:0083 class-ID: 0300
  Device-3: 1-4:3 info: Integrated Express ITE Device(8258) type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 048d:c968 class-ID: 0301
  Hub-3: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-2:2 info: Genesys Logic GL3523 Hub ports: 3 rev: 3.2
    speed: 5 Gb/s chip-ID: 05e3:0620 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:3 info: Meizu HiFi DAC Headphone Amplifier type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 2.0
    speed: 480 Mb/s power: 100mA chip-ID: 2a45:0128 class-ID: 0300
  Device-2: 3-4:2 info: Intel AX210 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0032
    class-ID: e001
  Hub-6: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 45 C
  Fan Speeds (RPM): N/A
  Processes: 395 Uptime: 3h 2m wakeups: 1 Init: systemd v: 250
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: 1268 pacman: 1263 lib: 338 flatpak: 5 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.17

Did I do everything right?

and now the output of

glxinfo | grep server

glxinfo | grep server

server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

first things first: i will not give any advice for “tuning” (in other words wrecking) your cards. everything you’ll do is on your own risk and if you end up with a smoking pc it’s your fault.

if your interested in wrecking your card check the internet for “linux nvidia power limit” etc… the main software that nvidia delivers with to set your card options is named nvidia-smi, you can search also for this. be aware that different options are only avaiable to different cards, there is no guarantee to anything. if you wanna try to cook eggs there are better ways.

fingers crossed and good luck.

I tried like this, “Changing power management limit is not supported for GPU: 00000000:01:00.0.”

I have a hardware power switch for the video card, maybe it needs to be fixed programmatically?

if you have to setup your card-bios, changing whatever card-switches etc. is described at your cards manual and it’s up to you to change anything. but in my honest: check and read the manuals before you start trickeling and fiddeling ending up with broken hardware.
there is no further advice from me.

Is all of the “NA” and “Not found” output normal for a fully recognized video card? I really wonder about that.

if the nvidia-powermanagement is disabled/not active then no data is avaiable.
please check the nvidia-manuals of the nvidia-driver for further details. it’s nvidia-software not linux-related.

So this may be the actual issue. He should check this first.

no it isn’t, the power-draw is recognized. but it’s up to him to check and validate all issues. i expect a playchild and a broken card in the end, period.