The session is losing it authentication after some time in the same session

After a while in a session kcminit looses it ability to connect to the still running X-server/Wayland-system. As a result I can’t run any new programs in that session before I restarted the userspace or rebooted the entire system from another terminal (e.g. tty4 with Ctrl+Alt+F4).

I found the following entries in my system logs:

Process 420066 (kcminit) of user 1000 dumped core.

Stack trace of thread 420066:

#0 0x00007fdd62eac83c n/a ( + 0x8e83c)
#1 0x00007fdd62e5c668 raise ( + 0x3e668)
#2 0x00007fdd62e444b8 abort ( + 0x264b8)
#3 0x00007fdd634a00c2 _ZNK14QMessageLogger5fatalEPKcz ( + 0xa00c2)
#4 0x00007fdd63b3f402 _ZN22QGuiApplicationPrivate25createPlatformIntegrationEv ( + 0x13f402)
#5 0x00007fdd63b3fa99 _ZN22QGuiApplicationPrivate21createEventDispatcherEv ( + 0x13fa99)
#6 0x00007fdd6369b995 _ZN23QCoreApplicationPrivate4initEv ( + 0x29b995)
#7 0x00007fdd63b3fb46 _ZN22QGuiApplicationPrivate4initEv ( + 0x13fb46)
#8 0x00007fdd63b4087c _ZN15QGuiApplicationC1ERiPPci ( + 0x14087c)
#9 0x00005592887aa11d n/a (kcminit + 0x311d)
#10 0x00007fdd62e45cd0 n/a ( + 0x27cd0)
#11 0x00007fdd62e45d8a __libc_start_main ( + 0x27d8a)
#12 0x00005592887aaef5 n/a (kcminit + 0x3ef5)
Stack trace of thread 420067:
#0 0x00007fdd62f20f6f __poll ( + 0x102f6f)
#1 0x00007fdd6236c2b6 n/a ( + 0xb82b6)
#2 0x00007fdd6230c162 g_main_context_iteration ( + 0x58162)
#3 0x00007fdd636ead0c _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE ( + 0x2ead0c)
#4 0x00007fdd6369ac04 _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE ( + 0x29ac04)
#5 0x00007fdd634f7576 _ZN7QThread4execEv ( + 0xf7576)
#6 0x00007fdd641f0a9a n/a ( + 0x18a9a)
#7 0x00007fdd634f379a n/a ( + 0xf379a)
#8 0x00007fdd62eaa9eb n/a ( + 0x8c9eb)
#9 0x00007fdd62f2e7cc n/a ( + 0x1107cc)
ELF object binary architecture: AMD x86-64

The problem persists a couple of months by now and I haven’t found anything similar enough that it was helpful.

Edit: fixed one formating issue
Edit:Changed the tags now that I learned more

Hi @Kupferdrache, and welcome!

While I have never even seen such an error, I’ll give you this tip:

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

This is only a symptom of something else.

I use my Plasma Wayland workstation 10-12 hour stretches without losing any authentication.

While I recognise you having an issue - I am fairly certain it relates to an application you are using.

If it was a widespread problem - the forum would have been flooded by now.

Are you by any chance using password-less logon aka automatic logon?

Please do not use [quote][/quote] for pasting code - use code fence - the button next to quote button </> as # is markdown for <h1></h1> - two ## is markdown for <h2></h2> and so forth

Please use codefence like this

pasted code or terminal output

A search for kcminit + 0x311d - provides among other results this topic [SOLVED] KDE/Plasma on X11 is dumping core / Applications & Desktop Environments / Arch Linux Forums where the statement below lead to the solution

You probably have QT_QPA_PLATFORM set to wayland?



Is this thread relevant?

Do you stay logged in for over 9 Days without rebooting ?


I do. :stuck_out_tongue: And no uptime-cheating with hibernation or suspend-to-RAM either. :wink: :face_with_hand_over_mouth:

[aragorn] >  uptime
 12:51:40 up 7 days, 11:51,  1 user,  load average: 0.77, 0.77, 0.51

UNIX was designed as a 24/7 operating system. It executes maintenance tasks overnight — e.g. updatedb, logrotate, a weekly fstrim, et al — and my email client (kmail) keeps on polling for new emails every 10 minutes or so. :wink:

If you shut down the machine every day, then it has to do all of those things upon the next boot because it will have missed the scheduled execution times. And that’s quite hard on the circuits — your CPU load and temperature will be much higher — plus that it may generate additional race conditions while the system itself is trying to start daemons and get the network up.


Could be true, I thought it was when I only locked the session when away and total uptime was over a week. S3/S4 isn’t working right atm, but I think it is a problem with the mainboard or the iGPU not awaking right after sleep, but the mainboard supplier doesn’t really want to support Linux on a technical side, but that was the mainboard available when I bought my components last spring.

Output of QPA platform is empty right now.


    ~   

Seems, it may be that issue, haven’t found that one. There wasn’t an anwser that the solution worked. but If I have to exempt these temp files from auto deletion that would be fine with me.

Is that update still not packaged in sddm yet?

systemd-tmpfles-clean.service will only clean out files that have not been accessed in over 24 hours, plus that deleting a file will not take any effect while the file itself is being held open. The file’s entry in the directory will then be deleted and its link counter in the inode will be diminished by 1, but the file will continue existing (without a filename) for as long as it’s being read from or written to.

I don’t know. Have you checked your .pacnew files lately?

Who does not? I reboot only when stable update arrives.

Or some special reason happens. Why do so otherwise? Better to just keep it runing to minimize any wear&tear happening when shutting down and powering up.


Because the vast majority of the members of this forum come from the Windows and (to a lesser extent) the macOS world, where a computer is not regarded as being a computer but as being a household kitchen sink appliance.

Exactly. Powering up — which includes resuming from a hibernated state — is very hard on the circuits (and on the spindle motors of HDDs), while at the same time it uses up a lot more electricity too, and especially when the system is trying to catch up with all of the scheduled tasks that were not executed overnight because the machine was shut down.

If you want your computer (and all of its components) to stay healthy for the longest time, keep it running 24/7 without sleep or hibernation. That way it’ll stay at a constant temperature, it will consume the least amount of power, the continuous airflow inside the chassis will prevent dust from settling down, and there are no spikes in the regular wear & tear.

The only thing that you should put to sleep is your monitor, so as to avoid burn-in — which is still a problem, even on TFT monitors.

seems the installed sddm package 0.20.0-2 is from August 2023, and the fix is from December 2023.

Does anyone know if the video Linux driver is the right OSS driver for a modern Radeon card? I have a recollection, that the right driver has a different name, my old system used a Intel iGPU, so I never had to think about the right driver.

Yes, this issue is the relevant one. It is solved upstream,but it implies some change on the systemd side might also be needed.

I changed the tags of this threat because of that.

I am not sure how to proceed on my end. Should I apply the workaround discussed? but in which file so it applies correctly and doesn’t break again with new upstream changes when sddm and/or systemd get a security fix or other change?

AMD has kernel support …

If you need something highly specialized there is always the amdgpu-pro drivers (use the custom script from AUR - usually pulls the latest from AMD download) but that is only for edge cases.

Usually the kernel driver is better - see AMDGPU - ArchWiki and AMDGPU PRO - ArchWiki for more info.

I’m pretty sure threats are against the forum’s rules. :grin:

right, the issue with ‘d’ and ‘t’ aswell as ‘h’ or not ‘h’ .

But I am sure context is all that’s needed.

Back on topic, thanks, confirms the kernel driver is running as intended. The other issue, that turning the monitor connected via DP off seems to mess up the resolution while on the lock screen can be irritating, but solves it self when the desktop comes back. Just let’s me wonder if the GPU is sleeping right while the screen is locked and the monitor turned off. But that is another topic if I want to dig deeper.

I don’t claim to know any more about this than you, but my understanding is that @renkforce1 created the file /etc/tmpfiles.d/tmp-xauth.conf, with the contents:

X	/tmp/sddm-auth*
X	/tmp/xauth_*

I believe this takes advantage of a systemd drop-in directory, so the file will not be overwritten by subsequent package updates.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.