"The process for the filenamesearch protocol died unexpectedly"(since last update)

i tried searching something in Dolphin under “/” and get the error above.
under Home it works fine.

kdeinit5[22262]: QWidget: Cannot create a QWidget without QApplication
systemd-coredump[22274]: Process 22262 (filenamesearch.) of user 1000 dumped core.
                                              Stack trace of thread 22262:
                                              #0  0x00007f1364ea8ef5 raise (libc.so.6 + 0x3cef5)
                                              #1  0x00007f1364e92862 abort (libc.so.6 + 0x26862)
                                              #2  0x00007f13650c99ac _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5 + 0x909ac)
                                              #3  0x00007f136468ce3d n/a (libQt5Widgets.so.5 + 0x14ee3d)
                                              #4  0x00007f136489b4a2 _ZN7QDialogC1EP7QWidget6QFlagsIN2Qt10WindowTypeEE (libQt5Widgets.so.5 + 0x35d4a2)
                                              #5  0x00007f136091cc11 _ZN11KMessageBox10messageBoxEP7QWidgetNS_10DialogTypeERK7QStringS5_RK8KGuiItemS8_S8_S5_6QFlagsIN>
                                              #6  0x00007f13609bf154 n/a (libKF5JobWidgets.so.5 + 0x10154)
                                              #7  0x00007f136531c322 _ZN7QObject5eventEP6QEvent (libQt5Core.so.5 + 0x2e3322)
                                              #8  0x00007f13652ef7f0 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x2b67f0)
                                              #9  0x00007f13652f2313 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5 + 0x2b9>
                                              #10 0x00007f1365348ce4 n/a (libQt5Core.so.5 + 0x30fce4)
                                              #11 0x00007f13639bd02c g_main_context_dispatch (libglib-2.0.so.0 + 0x5402c)
                                              #12 0x00007f1363a10b59 n/a (libglib-2.0.so.0 + 0xa7b59)
                                              #13 0x00007f13639ba781 g_main_context_iteration (libglib-2.0.so.0 + 0x51781)
                                              #14 0x00007f1365348321 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.>
                                              #15 0x00007f13652ee17c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2b517c)
                                              #16 0x00007f1365e98900 n/a (filenamesearch.so + 0x4900)
                                              #17 0x00007f1365e98b96 n/a (filenamesearch.so + 0x4b96)
                                              #18 0x00007f1365e98f28 n/a (filenamesearch.so + 0x4f28)
                                              #19 0x00007f136160f93f _ZN3KIO9SlaveBase8dispatchEiRK10QByteArray (libKF5KIOCore.so.5 + 0x8893f)
                                              #20 0x00007f1361610436 _ZN3KIO9SlaveBase12dispatchLoopEv (libKF5KIOCore.so.5 + 0x89436)
                                              #21 0x00007f1365e99116 kdemain (filenamesearch.so + 0x5116)
                                              #22 0x000056513dae45bd n/a (kdeinit5 + 0x75bd)
                                              #23 0x000056513dae5a59 n/a (kdeinit5 + 0x8a59)
                                              #24 0x000056513dae6237 n/a (kdeinit5 + 0x9237)
                                              #25 0x000056513dae1b54 n/a (kdeinit5 + 0x4b54)
                                              #26 0x00007f1364e93b25 __libc_start_main (libc.so.6 + 0x27b25)
                                              #27 0x000056513dae26be n/a (kdeinit5 + 0x56be)
                                              Stack trace of thread 22263:
                                              #0  0x00007f1364f6037f __poll (libc.so.6 + 0xf437f)
                                              #1  0x00007f1363a10ae8 n/a (libglib-2.0.so.0 + 0xa7ae8)
                                              #2  0x00007f13639ba781 g_main_context_iteration (libglib-2.0.so.0 + 0x51781)
                                              #3  0x00007f1365348321 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.>
                                              #4  0x00007f13652ee17c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2b517c)
                                              #5  0x00007f1365105ea2 _ZN7QThread4execEv (libQt5Core.so.5 + 0xccea2)
                                              #6  0x00007f136122c098 n/a (libQt5DBus.so.5 + 0x17098)
                                              #7  0x00007f136510708f n/a (libQt5Core.so.5 + 0xce08f)
                                              #8  0x00007f1364526299 start_thread (libpthread.so.0 + 0x9299)
                                              #9  0x00007f1364f6b053 __clone (libc.so.6 + 0xff053)
░░ Subject: Process 22262 (filenamesearch.) dumped core
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ Documentation: man:core(5)
░░ Process 22262 (filenamesearch.) crashed and dumped core.
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.

a reported bug from a few days ago:
and a report on reddit too.

and this

so i guess i’ll wait?

That’s a coredump, so yes, wait for that to be solved.

While waiting, you can do the following:

pamac install mlocate
sudo updatedb
locate NameOfFileYouWantToLocate

and after the bug gets fixed:

pamac remove mlocate



i just checked after this last update,and the issue hasn’t been fixed yet(for me).


Thank you for asking the question linub, I am experiencing the same issue as well…

Process 462036 (filenamesearch.) of user 1000 dumped core.

Stack trace of thread 462036:
#0  0x00007ff755688d22 raise (libc.so.6 + 0x3cd22)
#1  0x00007ff755672862 abort (libc.so.6 + 0x26862)
#2  0x00007ff7558a8910 _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5 + 0x90910)
#3  0x00007ff754e00fff n/a (libQt5Widgets.so.5 + 0x14efff)
#4  0x00007ff7550201a2 _ZN7QDialogC1EP7QWidget6QFlagsIN2Qt10WindowTypeEE (libQt5Widgets.so.5 + 0x36e1a2)
#5  0x00007ff750d1837e _ZN11KMessageBox10messageBoxEP7QWidgetNS_10DialogTypeERK7QStringS5_RK8KGuiItemS8_S8_S5_6QFlagsINS_6OptionEE (libKF5WidgetsAddons.so.5 + 0xcb37e)
#6  0x00007ff750dc1578 n/a (libKF5JobWidgets.so.5 + 0x10578)
#7  0x00007ff755afe4ff _ZN7QObject5eventEP6QEvent (libQt5Core.so.5 + 0x2e64ff)
#8  0x00007ff755ad1378 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x2b9378)
#9  0x00007ff755ad44a9 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5 + 0x2bc4a9)
#10 0x00007ff755b2a9a4 n/a (libQt5Core.so.5 + 0x3129a4)
#11 0x00007ff7540f910c g_main_context_dispatch (libglib-2.0.so.0 + 0x5410c)
#12 0x00007ff75414cb99 n/a (libglib-2.0.so.0 + 0xa7b99)
#13 0x00007ff7540f6871 g_main_context_iteration (libglib-2.0.so.0 + 0x51871)
#14 0x00007ff755b29fd6 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x311fd6)
#15 0x00007ff755acfd1c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2b7d1c)
#16 0x00007ff756690beb n/a (filenamesearch.so + 0x4beb)
#17 0x00007ff756690eed n/a (filenamesearch.so + 0x4eed)
#18 0x00007ff756691453 n/a (filenamesearch.so + 0x5453)
#19 0x00007ff751ab6f5f _ZN3KIO9SlaveBase8dispatchEiRK10QByteArray (libKF5KIOCore.so.5 + 0x92f5f)
#20 0x00007ff751ab7a76 _ZN3KIO9SlaveBase12dispatchLoopEv (libKF5KIOCore.so.5 + 0x93a76)
#21 0x00007ff75669177c kdemain (filenamesearch.so + 0x577c)
#22 0x00005628ecdedcad n/a (kdeinit5 + 0x7cad)
#23 0x00005628ecdef501 n/a (kdeinit5 + 0x9501)
#24 0x00005628ecdefbf9 n/a (kdeinit5 + 0x9bf9)
#25 0x00005628ecdeab33 n/a (kdeinit5 + 0x4b33)
#26 0x00007ff755673b25 __libc_start_main (libc.so.6 + 0x27b25)
#27 0x00005628ecdeb6be n/a (kdeinit5 + 0x56be)

Stack trace of thread 462037:
#0  0x00007ff75573fb2f __poll (libc.so.6 + 0xf3b2f)
#1  0x00007ff75414cb29 n/a (libglib-2.0.so.0 + 0xa7b29)
#2  0x00007ff7540f6871 g_main_context_iteration (libglib-2.0.so.0 + 0x51871)
#3  0x00007ff755b29fd6 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x311fd6)
#4  0x00007ff755acfd1c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2b7d1c)
#5  0x00007ff7558e4e12 _ZN7QThread4execEv (libQt5Core.so.5 + 0xcce12)
#6  0x00007ff75167bae8 n/a (libQt5DBus.so.5 + 0x15ae8)
#7  0x00007ff7558e5fef n/a (libQt5Core.so.5 + 0xcdfef)
#8  0x00007ff754c9a259 start_thread (libpthread.so.0 + 0x9259)
#9  0x00007ff75574a5e3 __clone (libc.so.6 + 0xfe5e3)

And thank you for the workaround Fabby!

1 Like

KDE bug tracker claims it was fixed in kio 5.83, but it still happens in 5.84 :frowning:


I just noticed another alternative app loaded by default in Manjaro KDE Plasma… KFind

I’m not sure that it loads a database like mlocate for performance… seems like it’s crawling the file structure as it searches… but does have a GUI if that’s a nice feature to have. And as you can see it has no issues searching outside the HOME folder.


As I keep getting :heart: on my post to use locate, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.