The pop-up window cannot be redrawn,




Sometimes the pop-up window cannot be redrawn, it is always printed on the screen 。
I can only change the rendering mode from OpenGL 2.0 to OpenGL 3.1 , or from OpenGL 3.1 to OpenGL 2.0 .
These pop-up windows that should disappear will truly disappear from the screen.

When I press Meta+D to display the desktop, I double-click the application icon on the desktop. Then when I press Meta+D to restore the hidden windows, all windows will become transparent, but still accept keyboard and mouse input events. I have to close the window and reopen it to return to normal.
This error is not common, I will add a screenshot later.

For example, the interface of the input method.


Operating System: Manjaro Linux
KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.12.16-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3800X 8-Core Processor
Memory: 23.5 GiB of RAM
Graphics Processor: Radeon RX 580 Series

I ran into this problem after updating the system on July 13th.

Please specify what application is that.

Is that the fcitx5 with or without mozc or iBus? Or is a browser extension, on what browser?

I think this is a random bug, look at the second picture。there are get new global theme window and search online theme dialog window
You can see the Dialog window, but when I move the mouse up, the focus is on the button of the window behind it. It is because the dialog window has been closed by me, But it still draws graphics on the monitor。
fctix5 input method 、get new global theme Window、 windows app by wine 、 At present, only these few have bugs。
you know,I can only make the display redraw the existing Window by changing the rendering mode.
I don’t know where the problem is and what should be done.

look the picture, This video window opened by microsoft edge is displayed in the lower right corner of the monitor. But it still exists on the display, but it does not accept any events because it has been successfully closed.

Yes, I’ve run into this myself twice now since the update, i.e. certain graphical elements remaining on screen after they should have vanished.

It’s a bug in the compositor, and restarting the compositor takes care of it.

This is a probability event,
The window is closed, but there is still a shadow on the monitor.
I have to change the rendering mode and redraw the window to eliminate this shadow.

the last update packages has the bug.
amd r7 3800x, b450m, amd rx 580 4G 2304

@bogdancovaciu hello, i have a new picture. how can i do ?

Just as you did it in your previous post. Upload it as an attachment. :slight_smile:

1 Like

Play with this settings a bit


Not quite sure what is going on on your side. Tried to reproduce and i can’t …

It’s very random. Probably a timing issue in the redrawing of the screen buffer.

I myself have had it twice now: once with a context menu in Chromium that remained on screen, and once with the virtual desktop switching popup. And as I said, restarting the compositor fixes it.

@blueisboy, if it happens again, try hitting Alt+Shift+F12 twice. The first time it’ll disable the compositor, and the second time it’ll re-enable it again.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.